Dorico 2 Pro HALion Sonic SE 3 "some audio files are missing" error message

Hi all, I’m trying to set up Dorico 2 Pro on a new computer. I’m 99% sure I downloaded everything I need and the list in the library manager looks complete (at least at a layman’s glance). Product registration (soft e-licensor) worked fine.

I tried various combinations of program installs/uninstalls/reinstalls/repairs. I dug around in the system program files area to check each VST audio file one at a time in the library manager and all of the ones I have on the system appeared to be recognized and accounted for.

No matter what I do, I keep getting the dreaded “some audio files are missing, please check installation” error message (this is the exact wording - it does not specify which files or sub-programs are the problem). I also tried the entire process as system admin and everything still acted the same.

I also cannot get any audio whatsoever to work in Dorico right now (I have some Spitfire LABS and those don’t work either). My sound output bitrate matches Dorico’s so I know that’s not the problem. I did notice via Task Manager that the VST engine doesn’t appear to launch during Dorico playback even though the VST engine files are where they should be in the system programs area. I tried force launching it after opening Dorico but apparently it didn’t do anything.

I included the diagnostics, a short test project, and some screenshots of library content for all explicitly HALion items I have).

If relevant: I’m running on Win 10 Pro x64, i7-4785T, 6GB RAM, 128GB SSD

Dorico (333.7 KB)
test.dorico (410.8 KB)

Thanks for the data. I’m still not sure what would be missing in your installation. I just saw that the HSO preset files are in an unusual directory, namely under

C:\Users\Lenovo\AppData\Roaming\Steinberg\Content\VST Sound\FCP_SMT_027_HSO_Presets_01.vstsound

whereas on my computer it is

C:\ProgramData\Steinberg\Content\VST Sound\FCP_SMT_027_HSO_Presets_01.vstsound

Try to copy that file over and do a double click on it to register. Then start Dorico and see how it goes.
Regarding the playback and no sound, well, you don’t need to explicitly launch the audio engine. That’s done automatically during launch of Dorico. However, in your case, the reason why no sound comes out is, that the audio engine can’t find an output port to stream audio to. Go to Edit > Device Setup and then click the Control Panel button, another little window opens.
In the middle of that window is a list of output ports. I suppose it is empty with you, right? What if you toggle the option at the top of that window (that says something like ‘Allow exclusive access’), does then some output port appear?

1 Like

Success, thank you!! :grin: I wouldn’t have noticed something like that because I always let programs use their default location preferences for download/installation, so I would have assumed that it belonged in the other folder. Very strange.

Audio is working now too. I’m not sure what happened, maybe it was just a system glitch. The device control panel output settings were correct yesterday and didn’t need changing. At the time, I couldn’t find the VST engine in the system processes list, which was why I had assumed it was a VST engine problem (my bad, it was there when I checked task manager today but it happened to be in an irregular place in the list and I overlooked it at first). Who knows, maybe the problems were related.