Dorico 3.1.10 hangs during launch on Win 10 (x64)

Dorico 3.1.10 Pro suddenly stops working on my Windows 10 (x64) laptop. It hangs in the splash screen during launch and the process is not shown in Task Manager so the only way to stop it is by restarting the machine. The same problem happens with Dorico 2 Pro as well. However, Steinberg Download Assistant starts normally. I already reinstalled the latest version of eLicenser and Dorico and the issue did not go away. I have read a few threads from other users experiencing with the start up issue but did not find one with the similarity. Any suggestions would be appreciated. Thanks.

Could you please zip up following 3 folders and post here? Thanks.

C:/Users//AppData/Roaming/Steinberg/Dorico 3
C:/Users//AppData/Roaming/Steinberg/VSTAudioEngine3_64
C:/Users//Documents/Steinberg/Crashes

Ulf,

Thank you for your quick response. Enclosed is the zip file of the three folders.
DoricoSupport.zip (529 KB)

What version of the eLicenser Control Center do you have, 6.11.x or 6.12.x?

From the logs I can only see that Dorico stops after initialization phase 1, and the audio engine never gets started.

So if you launch Dorico and go to the TaskManager, what does it say about Dorico in there? Not responding?
Please make a right click on the Dorico process and then choose Create Dump File. Follow the on-screen instructions and zip up the result and post here please. Thanks.

ephan, have you also tried running eLicenser Control Center as administrator and allowing it to complete its maintenance tasks? It’s important to run as administrator, particularly after a Windows update.

Ulf,

In Task Manager, Dorico is not listed under the Apps section but I found it now under the Background processes section, Dorico is listed with the status: Running.

I’m running eLicenser version 6.12.4.1275. The old version could not read the license and told me the license data file was corrupted. I don’t remember the exact message.

I think this issue could be related to the license. It started with telling me that Dorico could find the license in the pop up window and gave me the option to enter the activation code. Then I opened eLicenser and it could not read the file so I installed the current version that I have now. The license looks fine with the new version but Dorico hangs.

Daniel,

I followed your suggestion but still have the same issue. Thank you for your help.

EP

Even if it is shown running, please create that mentioned dump file. We need to see where it is hanging or not proceeding. Thanks

Ulf,

I’m not sure I understand what you say about creating the dump file. Dorico just got stuck where it displayed the splash screen. I don’t have the mean to make it crash. The only crash dump file was from more than a year ago. The directory C:\Users<user name>\Documents\Steinberg\Crashes does not exist on my system. I only see C:\Users<user name>\Documents\Steinberg\Crashdumps and it is in the previously posted zip file. Is there a configuration option that would allow Dorico to log more information to give you a better picture? Thanks.

EP

I see, the Task Manager doesn’t let you create dumps on processes that are running. Would you please instead get the free tool Process Explorer, you can get it from https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer
In there find the Dorico process, highlight it and right click, then choose Create Dump > Create Mini Dump. That works at any given time.

Ulf,

Here is the dump file that you have requested. Thanks.
Dorico3.zip (512 KB)

Many thanks, someone from the London team will take a look and we’ll come back soon.

ephan, please go to %APPDATA%\Steinberg\Dorico 3 in Windows Explorer, and find the file preferences.xml. Open this in a good text editor (ideally not Windows Notepad, but something like VS Code or Sublime Text or SciTE). You should be able to find these lines:

		<initELicencerAsynchronously>
			<type>(empty)</type>
			<value/>
		</initELicencerAsynchronously>

Carefully edit them as follows:

		<initELicencerAsynchronously>
			<type>bool</type>
			<value>false</value>
		</initELicencerAsynchronously>

Save the preferences.xml file, then restart Dorico, and hopefully it should no longer hang at the splash screen.

Daniel,

This solved the problem. I would like to thank the Dorico team for their generous support. I’m very happy with the progress and where Dorico is heading. The users have not only the best notation software but also the best support from the team and the community here as well.

EP

Great, glad to hear you’re back up and running now.