Dorico 3.1 audio engine process died

Since downloading 3.1, I have only intermittent audio (the beginning only of each new note) in Dorico. Restarting Dorico only produces ‘Audio Engine Process Died’. Any help would be much appreciated. Kerry

Could you please do in Dorico Help > Create Diagnostics Report, that creates silently a zip file on your desktop, please attach that here.
After looking at that I can give further advice.

Thanks Ulf, but I cannot get into Dorico at all, so where could I now access Dorico Help>Create Diagnostics Report
Kerry

If you’re on Windows start the Task Manager or on mac start Activity Monitor. Look for the ‘VSTAudioengine’ process and kill it. Try starting Dorico again.

Failing that, restart your computer, and you should then be able to restart Dorico again. (Now all three of Ulf, Paul and me have each replied to your post… the complete set!)

Thank you, Ulf, Paul and Daniel, but:

  1. There is no VSTAudioengine in Activity Monitor
  2. Restarting the computer (Mac) and restarting Dorico gives the same message ‘audio engine process died’

Are there any further suggestions from the trio.
Kerry

Then please zip up the folder /Users//Library/Preferences/VSTAudioEngine3

Plus, please have a look in /Users//Library/Logs/DiagnosticReports and see if you can find any crash reports with VSTAudioEngine3 in the name.
Please also zip those up and post here.

Thanks Ulf, this is all I could find. I am quite unfamiliar with the technical processes. Sorry.
Kerry
VST3.zip (1.34 MB)

Sorry, this is not what I was looking for. I’m especially keen on the crash dumps of the audio engine.

Do you know the Console application? Type into Spotlight Search just Console and then return.
The Console app will launch and on the left side click on ‘User Reports’.
In the second column then crash dumps from various apps get shown. Please have a look for the ones that start with VSTAudioEngine3.
Highlight one of them and right click and choose from the popup menu ‘Reveal in Finder’
In Finder then, select all the relevant ones, right click and choose ‘Compress’ from the popup menu.
Please attach the corresponding zip file here. Thanks very much.

Sorry Ulf, with the Console app launched, the left column contained no ‘User Reports’; it had Crash Reports, Spin Reports, Log Reports, however, Diagnostic Reports does contain VSTAudioEngine3 references. What should I do?

To find the right folder, make sure the Finder is active (the word Finder should appear in bold type at the left-hand side of the menu bar, next to the Apple logo). Hold down the Option or Alt key on your keyboard, then click the Go menu. In that menu you will see an entry Library with no shortcut next to it. (This item won’t appear unless you are holding Option/Alt when you open the menu.)

Choose Library from the menu and a new Finder window will appear. From that window, go into Preferences, which is one of the folders shown inside Library. In that list you will see a folder called VSTAudioEngine3. Select it, then right-click and choose Compress VSTAudioEngine3 from the context menu. This will create a zip file called VSTAudioEngine3.zip. Drag this to the Desktop, then attach it to a reply here.

VSTAudioEngine3.zip (1010 Bytes)
VSTAudioEngine3 copy.zip (275 KB)

Hi Kerry, thanks, that data is better, but it also puzzles me because:
The audio engine always keeps logs of the last 10 runs. Now, the logs are all from Sunday from around 11am to 2pm and they all show quite normal behaviour. I can even see start/stop commands being issued. So is it that after 2pm on Sunday that “audio engine process died” started?
I have no explanation as to why this would suddenly happen, since you had many successful runs beforehand. Did you install some plug-in or other software?

Using that Finder trick, as Daniel explained before, could you please find the folder Library/Application Support/Steinberg/Dorico 3 and also zip that one up?

And again, I think you must have audio engine crash dumps. Using again the same trick, please have a look at Library/Logs/DiagnosticReports and see if you can find any file there that starts with VSTAudioEngine3. Please zip up and attach here. Many thanks

Thanks Ulf, you are quite right, the fault occurred on Sunday afternoon, even though I had already successfully begun using Dorico 3.1. I don’t remember installing anything else at that time.

I could not find any file starting with VSTAudioEngine3 in Diagnostic Reports, so zipped Dorico 3_2020-02-18-133002_Kerrys-MacBook-Pro.crash. I hope this is useful to you.

You forgot to attach…

And actually, I would also like to get the zipped content of Library/Application Support/Steinberg/Dorico 3
That also contains important information for us.

Sorry Ulf, I thought I had sent Library/Application Support/Steinberg/Dorico 3. Here it is.https://www.steinberg.net/forums/download/file.php?mode=view&id=50517
Dorico 3.zip (196 KB)

Thanks for the data.

Well, it is really weird, before Dorico worked for you and then suddenly from one minute to the next not anymore.

Let’s see if you can get just the audio engine going. In Finder, go to the Applications folder and right click on the Dorico app, a popup menu appears.
Choose ‘Show bundle content’ (or similar, I don’t have a Mac right at hand). Then navigate further to Contents/Applications/VSTAudioEngine3.app.
Then do a double click on there and a splash screen of the audio engine should normally appear. What is happening?
Also, open Activity Monitor and have a look in the process list for an item called VSTAudioEngine. Is it there and lingering on?

If it is lingering on, also launch Dorico in the usual way. What is happening then? Same error as before?

Hi Ulf, there is no VSTAudioEngine3.app, only Dorico Web Helper (which I have zipped to you.

In Activity Monitor there is no VSTAudioEngine.

Launching Dorico still shows ‘audio engine process died’.

As you say, it is all very weird.

This is more than weird, because I have no idea how you could possibly delete the audio engine from within the Dorico bundle and all this totally unintentionally.

Therefore I propose that you get once more the Dorico installer via the Steinberg Download Assistant and let the installer run again. (Just the Dorico installer, not the 9GB sounds installer)
Hopefully that fixes your issue then.

Or first maybe have a look in the trash can. Is it maybe in there and you can recover it?

Hello Ulf,

I looked in the trash and found this document. Is this what we needed? If so how do I re-install it?