Dorico 3.1 Live midi recording issue on drums

in dorico 3.1 I noticed this issue when recording live midi on drums

1 - I record one bar groove with one open Hi-hat note.
2 - Dorico correctly writes that note with the open symbol over it
3 - When listen back to the recorded groove, playback plays only open hi-hat notes ignoring the closed ones…

how can I fix this?

seem likes there is no CC message that switches the playback back to the closed hi-hat notes after it plays an open one…

That’s not how open/closed hi-hat (normally) works: it’s normally produced by playing a different MIDI note. If you input all of the notes as open hi-hat, then Dorico will play them all back as open hi-hat, too.

Sorry, I haven’t been clear enough

Indeed my groove has several closed Hi-hat notes, but just one open hi-hat note.
When playback plays that open hi-hat note, keeps playing open hi-hat sound over closed hi-hat notes

Does the open playing technique have a duration? When you select it, does it show a red handle further to the right of the note on which it appears?

When I select in write mode the open symbol over the hi-hat note it becomes red and I can move it around the other hi-hat notes…no other handles

In play mode when I expand the hi-hat tecnique lane I can see the closed technique and then the open techniques that spans all over the hi-hat part

I found that If I record a longer drum groove, sometimes the appropriate hi-hat technique is played, sometimes not…and sometime it doesn’t even write the open hi-hat note on the score

perhpps it has to do with the way I input notes with my keyboard, in terms of overlaps or timing in general…

I’ll post two images


Certainly that shows that you have an open technique that lasts for a while. If you want to zip up and attach the actual project file, that will make it easier to diagnose the problem.

here you are:
Drum Issue live midi recording open hi-hat.dorico.zip (461 KB)

in the last two bars of the score you can also see the open technique symbol, but not the actual hi-hat note written that I’ve played (and heard) during recording

anyone?

Patience. It has been less than a day since you posted the file. The Team is pretty good (very good?) about getting back as soon as they can.

I’ve had a look at the file and I can see what the problem is. There is currently a limitation in Dorico that if a note has custom playback position data (eg if recorded from MIDI or dragged in Play Mode), then it may not have the playing techniques applied if the position is before the notated position. There is a simple workaround for this - select all notes (or just the hi-hats) and then select Play > Reset Playback Overrides. It should then play correctly. There’s also a preference: Preferences > Play > Preserve Note Positions where Dorico will just play at the notated position. Alternatively, if you find that everything you record plays slightly ahead of the beat then try changing the Preferences > Play > MIDI input latency compensation.

Thanks for your reply, I’ll try that and I’ll let you know butI guess that doing so, will somehow “quantize” my performance right?

Yes, that’s right. Unfortunately that’s the trade-off at the moment, until we’re able to offset the instructions necessary to play the playing techniques correctly by exactly the same amount as the offset you played.

Ok, I see, anyway I found the “Preserve Note Postions” option was already on.
Reset Playback Overrides on the other hand hepls to fix this out…for some reason sometime I get the open hi-hat symbol over a missing note

Hello, has this issue been solved with the recent updates?

thank you

I’m afraid I don’t think we have made any changes in this are as yet, Jack, sorry.