Dorico 3.5.10 won't launch


I downloaded the 3.5.10 update and have been trying to launch the program for a while but with no success. Uninstalling/reinstalling/“performing maintenance tasks” in eLicenser as admin/rebooting doesn’t help. I’ve zipped up the Dorico 3.5 folder from AppData in hopes that you might have an idea what’s going on.

Thanks for your help in advance!
Dorico (1.44 KB)

I hate to ask this… but did you pay for the upgrade to 3.5?


Of course I did. I’ve been using the 3.5 version with no problem since the day it came out.

Augustin, try downgrading eLicenser Control Center from version (installed by Dorico 3.5.10) to version, which you can download from here.

Hi Daniel!

Just to be sure, first I’ve uninstalled my old eLicenser Control Center, then uninstalled/reinstalled Dorico again so it could install the right version ( together with the program itself, but still cannot open the program. It just gets stuck in the splash screen without any error message.

The issue seems to be the newer one ( I did as Daniel said and downgraded to the previous and it worked for me. Thanks much, Daniel!

Silly me! I’ve misread Daniel’s post and tried to upgrade instead of downgrade…

Thank you so much, Daniel, it worked for me too!

I had exactly the same symptoms that Augustin reported – just the splash screen and nothing else. I had taken all the same resolution steps he mentioned before I saw this posting. I noticed that if I let the splash screen sit for about 10 minutes, it eventually did proceed to the main application.

I have not yet downgraded the licenser, which I will do now.

Downgrading the licenser worked for me as well.

Downgrading works for me, too!

Yep, that did the trick here as well. Phew!

Worked for me as well!

I’m another person who have to downgrade eLicenser from to to get past the Dorico splash screen. Both Dorico 3.5.10 and whatever version of Dorico 3 I still have installed were affected, but Cubase Pro 10.5.20 worked with eLicenser My Dorico licence is on a soft eLicenser, whilst my Cubase Pro licence is on a USB eLicenser (as it has to be).

Do Steinberg need any debugging data from affected systems or is this a known issue?

Yes, the downgrade worked, after uninstalling the most recent elicenser, restarting the computer, and installing the older one. I hate to sound negative, but I’ve spent so many hours trying to make 3.5.10 launch and only discovered how to fix it after figuring how to ask the right question on the forum. Dorico programmers ought to be ashamed of themselves releasing a product with such an obvious bug. I’m a composer, not a computer whiz and after that supposedly nice upgrade from 3.5 to 3.5.1, I couldn’t get it to run! Why do you have to put your clients through such aggravation? Can’t you test your products before you release them?

Bear in mind that there are literally thousands of people who have updated without any problems - I have 3.5.10 running here on two Macs and a Windows machine, all running the 6.12… version of the eLicenser. This isn’t a problem that affects everyone.

The eLicenser team are a separate part of Steinberg to the Dorico team, as I understand it. There was a lot of pressure to get eLicenser 6.12 released as 6.11 has major problems on recent versions of Mac OS. The first attempt at releasing 6.12 (which I think was Mac OS only) had to be withdrawn because it had issues. It seems that this second attempt at releasing 6.12 has issues on some Windows systems, including yours and mine.

It was unfortunate that a problematic version of eLicenser was the latest available when Dorico 3.5.10 was released, so it became the version bundled into the Dorico installer. I track eLicenser releases, so knew 6.12 had released and involved major internal restructuring, so would have gone for downgrading eLicenser to 6.11 even without Daniel’s post. However, many will not have realised, especially if Dorico is their only Steinberg product.

Hopefully the eLicenser team wil soon understand what is wrong with 6.12 on affected Windows systems and will be able to release a fix. I’m happy to reinstall 6.12 and collect debugging data if I’m told what is wanted. I’m also happy to try beta versions of 6.12.

My experience is that 6.12 worked if I waited long enough. On my machine, it might have been a 10 minute wait every time launching Dorico, which obviously is unacceptable. But perhaps others are experiencing a shorter delay that they don’t consider “broken.”

We now know a bit more about this problem. By default, Dorico initialises the eLicenser in an asynchronous fashion, i.e. by kicking off a worker thread instead of blocking the main thread. This works reliably in eLCC 6.11 but not on all machines in eLCC 6.12. We only encountered the problem in our internal testing with virtual machines, and the eLicenser team told us that this was not currently a supported configuration, so we rolled the dice and included eLCC 6.12 with Dorico 3.5.10, because we know from our experience of testing it over the past few months that it renders the problems macOS users have been having with the eLicenser a thing of the past. We didn’t expect this issue to affect Windows users, however.

So we’re currently evaluating what to do. We have a simple Python-based tool that can be used to set the necessary hidden preference to disable asynchronous initialisation of the eLicenser, which will work for Windows users who have previously been able to run Dorico with no problems, which we may release. We may release a further very small update to Dorico itself to disable asynchronous eLicenser initialisation directly. And the eLicenser team are currently looking into the issue as well. I think the second of these three approaches is most likely, but with the summer holidays in full swing we are not in a position to rush out another release just at the moment.

I’m sorry for the inconvenience caused by this problem. Suffice it to say that I will personally not weep bitter tears when Dorico moves away from the eLicenser technology towards a new license management system, which is still very much in the cards but which is not imminent.

Thank you for the update, Daniel. Issues with asynchronous events can be a real pain to resolve. Perhaps the issue arises on my machine as it is relatively powerful (Xeon E-2186M based laptop, which is a 6 core processor). The more cores, the greater the chance of a race condition, for example.

I’ve stepped back to eLCC 6.11 and will stay there until there is a suggested route forwards. Emergency releases can be a bad idea - I got burned by emergency releases going wrong when I was last well enough to work, which was as a software engineer. It is better to take the time to find a properly considered way forwards and I am sure this will happen.

I note that the Windows installer for Spectralayers 7 Pro, which came out in the last few days, contains eLCC 6.11 - though that might have been the latest version when the installer was built a few weeks ago (according to the digital signature).

eLCC 6.12 is more important for Mac OS users, it seems - I know how many times you had to reply to Mac users who were really hurting because of issues with eLCC 6.11. eLCC 6.11 is stable on my Windows 10 system.

Like you, I look forward to the day when I can do away with eLicenser. I won’t be weeping tears over its passing, but yelling hooray!

For me, it will launch, but only after an extraordinary amount of time, measured in hours, not minutes. I’ll try the downgrade.