Dorico 3.5 and NotePerfomer 3

Like several other users, I am unable to use NotePerformer (3.3.1) with Dorico Pro 3.5. Looks like we need a thread on this. Daniel, I’ll send you my diagnostic in a sec.

In the meantime, some users have been able to clear their audio engine cache (Preferences/VST Plug-ins) and restart DP to get back to normal. This did not work for me.

If you already have Dorico 3.0 or 3.1 on your machine then in theory there’s no need to install NP again - it should just work as is. There’s also no need to add to the whitelist as it’s already on the default list.

Here’s some things to check if NP isn’t working for you:

  1. Check you have the latest NotePerformer 3.3.1
  2. In Preferences > VST Plugins, press the Clear Audio Engine Cache button and restart Dorico. This will cause the audio engine to re-scan all the plugins. If you don’t have any custom VST2 paths or whitelist entries then the Reset Audio Engine Data button can be used instead, as this will reset the audio engine settings back to the default state.
  3. Update your video drivers. We’ve seen some reports of crashes within video card drivers in the OpenGL window used by NotePerformer.
  4. Reboot
  5. If the above steps haven’t fixed the problem then please report here exactly what you’re experiencing, with the following:
  • Run Help > Create Diagnostic Report and attach the DoricoDiagnostics.zip file from your desktop here
  • Tell us your OS and whether you previously had 3.0 or 3.1 installed
  • Look in Play Mode - in the VST Instruments panel, does it say ‘!!! NotePerformer !!!’? (this indicates that the plugin couldn’t be loaded)

Today I installed Dorico 3.5 with a pro license under macOS 10.15.4.
I am using NotePerformer 3.3.1 without problems.
I hope Paul’s instruction helps you!

Paul, I am seeing the !! marking on NP. Does that mean I need to reinstall it?

And (sorry) DP 3.1 before the update.

I had exactly the same problem, as have a number of others. First step is check you’re on 3.3.1 – you are so that’s fine! Do what Paul suggests as regards clearing the cache and or reset engine (I think it only worked with the latter for me which meant re-adding another plugin to the “Allowed” list). Done that too by the looks of things so then check the “Blocked Plug-ins list” It is likely that NotePerformer will appear there. Select it and click the arrow to move it to the “Allowed plug-ins”. Does it work then? This sorted it for me and at least one other person following these steps. If not, it’s probably back to Paul and a diagnostic report…

It should not be necessary to reinstall NP as I’m not aware of any case where this has helped (though I might be mistaken)

Thanks dko22.

So NP does not show up on the VST 2 list in the Prefs pane… and I guess I don’t understand why it would have, as it’s a VST 3 plugin… right?

No, it’s a VST2 plugin. It doesn’t need to appear on that list because it’s already on the system whitelist.

Ah! Would rebuilding the VST whitelist be a potential help?

PS: Just reinstalled NP and restarted, nothing doing.

which list – the black or whitelist?

Either.

does the actual Vst2xPlugin Blacklist Dorico 3.5 AudioEngine.xml (in Appdata\Roaming\Steinberg\Dorico 3.5 AudioEngine_64) show it? If so, rename the file as it will be recreated and then check your blacklist in Dorico properties again. Or wait for Paul to come back – my suggestion is among things I tried but comes with no guarantees and is not official.

On slightly tangential issue with NotePerformer after upgrading to DP 3.5:
In several projects I had set Vibrato CC (105 and 106) in Expression map to custom values.
After upgrading to DP 3.5 those setting are gone.
I had to set them project by project anew.

Igor Borodin

The Noteperformer plugin was not loading for me (!! in VST list) until I manually (+) placed it in the Allowed Plugin list. At no time did Noteperformer appear in the Blocked Plugin list.

Prior to doing the above, I did clear cache and reset data and rebooted but this didn’t help. I also reinstalled Noteperformer 3.3.1 but this didn’t help.

Looks like Noteperformer is not being automatically whitelisted by Dorico 3.5, at least not on my system (Mojave 10.14.6)

I had upgraded from 3.1.

Hello all,

The first time I’ve launched Dorico 3.5 I got the noteperformer logo. And no more after the second launch.

Note performer is not displayed in the VST instrument list.
I’ve tried to

  • reinstall noteperformer
  • add C:\Program Files (x86)\NotePerformer\VSTPlugins 64-bit and C:\Program Files (x86)\NotePerformer\VSTPlugins 32-bit (x86) preference /VST

It does not solve the problem.

Any idea ?

Florent

Hello,
I had the same problem with Kontakt not seem in the vst play list, because blacklisted by new Dorico3.5

What I did and solved the problem:

  1. open the file C:\Documents and Settings\anonyme\AppData\Roaming\Steinberg\Dorico 3.5 AudioEngine_64\Vst2xPlugin
    Blacklist Dorico 3.5 AudioEngine.xml
    and delete the section from xxxx to and save the file

2.now run
C:\Program Files\Steinberg\Dorico3.5\VSTAudioEngine\VSTAudioEngine3.exe

  1. Open Dorico 3.5 and I see the plugin and work

Before to solved my problem I came to this topics… so as I installed the NotePerformer as demo I also didn’t see it it in the the new Dorico 3.5, so I try the same thing as above to try for you, and now I see noteperformer and I can opend it but as I didn’t buy it, I have demmo expired.
for you you need to delete in the Xml:













then run once C:\Program Files\Steinberg\Dorico3.5\VSTAudioEngine\VSTAudioEngine3.exe
and after that everything should be ok when you open Dorico3.5

Hope it help
Best regards
Dup

Thanks for your help, but it does not work for me.

Noteperformer does not launch when I start dorico 3.5, there is no Noteperformer entry in the VST instrument list
In the the file Blacklist Dorico 3.5 AudioEngine.xml, the item section come back when I launch Dorico again.

Can you please attach a diagnostic report as described in my post #2 ?

I have the same issue with NotePerformer being automatically blacklisted.
I already have mentioned this and posted a diagnostic report in this thread:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=189201
Ulf is looking at it but I thought I should mention this here too.

Sorry, I still had Noteperformer 3.3.0
I’ve juste upgraded to 3.3.1 and use the Clear Audio Engine Cache function

It works fine now.

Thanks for your help.