Dorico 3.5 Audio engine - Waiting for connection

Hello, I realise there are many references to this problem but I think I have tried all the solutions suggested on this forum so far.
I am running Dorico 3.5.12 on an iMac (Mojave).
Dorico 3.5 was working perfectly for a year after the initial installation until I had my hard drive replaced with a solid state drive.
So the only difference is that the hard drive had a different name (I’ve changed it back to Macintosh HD) and the person installing the hard drive added Logic Pro which I’ve since deleted in case it was the problem.
Afterwards, every app on my computer worked as normal except for Dorico which gets the msg


I have tried the following solutions:
Ran Disk Utility to Repair Disk
Deleted preferences
Killed the VSTAudioEngine process
Killed the Synsopos process

Is the problem with the eLicenser? eLC Version 6.11.102272
Here is the application log:
2022-07-06 17:38:21.106 : Dorico 3.5.12 build 1066 (Feb 15 2021)
2022-07-06 17:38:21.108 : Initializing Printer Services
2022-07-06 17:38:21.115 : Initializing Core Services
2022-07-06 17:38:21.129 : Initializing Cached File Provider
2022-07-06 17:38:21.133 : Initializing Framework Services
2022-07-06 17:38:21.134 : Initializing Preferences
2022-07-06 17:38:21.138 : Initializing Preferences…done
2022-07-06 17:38:21.138 : Initializing Dorico Application Framework Services
2022-07-06 17:38:21.139 : Initializing Diagnostics
2022-07-06 17:38:24.193 : Initializing Localisations
2022-07-06 17:38:24.193 : Initializing Dorico Application Framework Services…done
2022-07-06 17:38:24.193 : Initializing Engine
2022-07-06 17:38:24.193 : Initializing Application phase 1
2022-07-06 17:38:24.193 : Initializing ScoringApp phase1
2022-07-06 17:38:24.223 : Initializing ScoringApp phase 1…done
2022-07-06 17:38:24.852 : Initializing SKI Plugin Controller…
2022-07-06 17:38:25.365 : Initializing SKI Plugin Controller…done
2022-07-06 17:38:25.378 : Initializing Playback Controller
2022-07-06 17:38:25.385 : Initializing Audio Engine
2022-07-06 17:38:25.426 : Launched Audio Engine
2022-07-06 17:38:25.431 : Audio engine: Waiting for connection

I would be grateful for any ideas about how to solve the problem.

Have you tried going to your account at Steinberg to Reset the license?
I expect from your description that you are not using the dongle, but even so, resetting is worth a try.

Welcome to the forum @John_Black .

First I’d check the eLicenser Control Center and see if it shows your Dorico 3.5 license.
Second, after starting Dorico open the Activity Monitor and see if there is a background process call ed VST Audio Engine.
Third, please run the attached shell script, which creates a zip file on your desktop and post it here.
Thanks
CreateDorico35DiagnosticsReport.zip (544 Bytes)

Thanks Derrek, yes I have reset the license and it’s showing eLicenser Control Centre.

Thanks Ulf,
Yes, I have a license for Dorico 3.5 listed in my eLC.
The VST is showing up in the Memory category of the Activity Monitor.
I’m not able to produce a Dorico diagnostics report because the application doesn’t open, or am I not understanding something here?

Hi @John_Black,
I know you are not able to create the diagnostics from within Dorico. That’s why I attached that shell script which does almost the same as what Dorico would do. So please run it in a Terminal window. Thanks

Hi Ulf,
Apologies for being so slow.
I’ve opened a Terminal window and separately downloaded the
[CreateDorico35DiagnosticsReport.zip|attachment]
but I’m not sure how to carry out the procedure you requested.

Same Problem !

Hi @John_Black ,
first you need to unzip the downloaded file. Presuming you do that in place, then CreateDorico35Diagnostics.sh lies in your Downloads folder.
Then, in the Terminal window type

 cd Downloads

and hit the enter key, then do

xattr -c ./CreateDorico35DiagnosticsReport.sh

and enter again, and then just

./CreateDorico35DiagnosticsReport.sh

followed by the enter key.

Hi @Jerry , you also have the same problem with Dorico 3.5 or a different version?
The script I provided only works for Dorico 3.5.

Hi @Ulf , I’m on Dorico Element 4 now (on Windows 10), but still the same problem “Audio engine: Waiting for connection”, it take 2 or 3 mn before it can open. I use the new Steinberg Licensing.

Hi @Jerry , okay, but eventually it does open with you, right? If that is the case, then choose from Dorico’s menu the item Help > Create Diagnostics Report which will create a zip file on your desktop. Please post that one here. Thanks

Thanks Ulf,
I’ll try that tomorrow with my morning brain. It’s late here in Australia!

Hi @Ulf , here is the “Diagnostics Report”.
Dorico Diagnostics.zip (2.3 MB)

Hi Jerry,
thanks for the data. The audio engine logs show some unusual patterns, namely periods of 30 seconds or even longer where it seems nothing is happening. In order to analyze this further I would like to ask you to install some special tool and do a Windows performance recording with it. That would be really fantastic, though it is a little bit of work. But please follow the instructions in this thread and send me the data via e.g. Drop Box or other file sharing service.
Thank you very much

Hi Ulf,
Here is the Diagnostic report as requested.
CreateDorico35DiagnosticsReport.zip (544 Bytes)
Thanks,
John

Hi @John_Black, sorry, but you have attached the wrong file. My shell script creates on your Desktop a file called DoricoDiagnosticsReport.zip. Please attach that one. Thanks
What you have posted is my shell script again.

Hi Ulf,
Apologies for being so slow. I’m much better on the piano keyboard than the computer keyboard…

Anyway I followed your directions and apparently the zip file that you requested has been saved to my desktop however it’s not there. And a search for its name doesn’t find it anywhere on the computer. Here is the screenshot of the Terminal Window.
Terminal dialogue

In the Terminal, try typing:

ls ~/Desktop/Dor*

You should hopefully get at least one line of output, showing the expected filename. Send us a screenshot to show what you’re seeing.

Thanks, I did what you requested but it only opened a folder on my desktop named Dorico which has info I’ve compiled about Dorico shortcuts and techniques etc.
However I did find a file created about six weeks ago when I was trying to solve this issue direct with Yamaha (the people in Australia tasked with handling Dorico help) and found this crash report which has been already sent to Dorico which didn’t yield any results but I’ll include it again here:
Dorico Crash Report.zip (128.8 KB)