Dorico 3.5 Concert Transposition Override not working?

Hi there,

As an experiment with the new transposition overrides, I’m trying to get a sopranino recorder to not transpose the octave in the score.

It seems that there might be some bugs with this new feature however, because after some experimentation, I’m not able to do any concert overrides at all. I tried changing the clef to no avail (even to random clefs), and tried messing with the octaves to no noticeable result.

Here’s a step-by-step process of what I did, I fully admit that since this is a new feature it might be user error:
-Added Solo Player, selected “Sopranino Recorder”
-Right clicked on sopranino recorder on the right side of Setup Mode, selected Transposition Override
-Checked “clef for first staff”
-Checked to the right for concert pitch, changing to “treble clef”
-Checked the bottom right, selected middle C sounds as C4
-Pressed Ok

After doing this, I saw no noticeable changes. In Write Mode, I inputted a C in the middle of the staff, and at the bottom I can see that it’s a C6, where it should be a C5. Middle C is C5, not C4. Also it should be noted that when I go back to Clef and Transposition Overrides it seems my preferences aren’t saving; the only thing that stays checked is “Clef for first staff” on the top left.

Am I missing something here? Please help!

That will affect the part only. If you want the score to reflect this, you need to do the same for the "Full Score’ layout.

Josh, I believe these new features to be working as designed; it sounds like you right-clicked on the ‘Sopranino Recorder’ layout in the Layouts panel, so your settings are in the part layout, not the full score layout. Switch to the recorder part layout and hopefully you’ll see the changes you expect to see.

I added a descant recorder to a new score. It came with a standard treble clef but of course this should have been an octave up treble clef. I had to change it.
The bass recorder was correctly given an octave up bass clef.