Dorico 3.5 Condensing Staff Label Bug

Hello everyone,

sorry if this has been asked somewhere else already, if it has I can’t seem to find it.
Since updating to the newest version (which is great, btw, thanks a bunch to the team!) there seems to be a bug with the staff labels in a condensed score.
I have my engraving options for “Staff labels for identical adjacent solo instruments” set to “Group between staves”. In the new version, Dorico labels each staff separately (cf. the screenshots below). I have tried turning the option on and off again, tried disabling and reenabling Condensing, but with no success. I found that creating new instruments and copy/pasting the music into them fixes the problem sometimes, but not at other times.
My only other options would be to engrave the entire piece again in Dorico 3.1, but before I do that I would rather ask if there’s any better solution or workaround for this.

Thanks in advance,

In general there’s no problem with this in Dorico 3.5, so I think there must be something specific to your project that’s tripping Dorico up. Can you please attach the project, or at least the first few bars of it, so that we can take a look and see what might be up?

Hey Daniel,

thanks for the fast reply! The file is too large to be uploaded here, apparently, so I uploaded it to Google Drive. Here you go:
(PS: Yes, it’s Star Wars, and yes, it’s exclusively for my own education and entertainment :slight_smile:

All the best,

I’ve not checked through the whole cue, but if you can set the horns to be in three custom condensing groups (on the Players page of Layout Options) instead of using manual condensing, then you should get a single grouped label for the three staves. You may also need to set ‘When stacking player numbers for condensed players vertically’ to ‘Ignore stem allocation’ on the Staff Labels page of Engraving Options. Let me know how you get on.

Thank you very much, setting the instruments as custom condensing groups worked perfectly! I’m lucky that in this cue there’s no point where I would really have to have two staves for the horns with 1.2.3 and 4.5.6 sharing one each, for example, else there would’ve been yet another problem.
Thanks a bunch!

I have the same problem too. I tried to open a new file consisting of two flutes. when I try to change the condensation on a random page Doric puts the labels of the separate and not stacked staves as established in the layout window. sauce condensed section tools the problem does not exist. create labels correctly. Thanks

Welcome to the forum, Patrick. Please zip up and attach the project, or preferably a cut-down version that would still allow us to reproduce the problem, and we’ll be glad to take a look.

Thanks Daniel it is a real pleasure to be part of this community. To verify it, I created a new test file and the problem persists. I am attaching the file. As you can see by changing the condensation, apply the labels to each staff on the flute. It should not do this for parameters entered in the Engraver Option. Thanks! (573 KB)

Thanks for sending this in, Patrick. On the face of it I agree with you that this doesn’t look right. I will consult with my colleague Andrew and come back to you.

thanks Daniel.

Hi Daniel, is there any news for my problem? I tried and tried again but the problem remains unchanged.
I would be very grateful if you could update me.
Thank you and excuse me

There’s nothing you can do about this yourself in the software at the moment, Patrick. You’ll have to wait for us to fix this problem.

Ok Daniel! I’ll wait … Thanks

Hi Daniel,first of all I want to congratulate you all for the wonderful work you do. Your support is truly remarkable. I propose another question that always concerns the staves labels. Is it possible to create labels as in the attached figure? To be vertical. (See the word MASCHERE). Thanks and good job.

Not yet, I’m afraid, but it’s something we are planning to add in future.