Dorico 3.5 license not found after Windows Update

My computer automatically installed a Windows update and now Dorico 3.5 says it can’t find a license. I followed the instructions from another thread and ran the eLicenser Control Center as the Administrator to allow it to do Maintenance. It did so successfully.

But Dorico still can’t find the license unless I run it as Administrator. I don’t think I should have to do this. Any ideas?

I crossed the W10toW11 as well. Running the new OS all licenses has gone (CB, HAL,VSTs,… and Dorico too).
I do not remeber exactly wich steps I followed but at the last one, from Steinberg web site I got all new keys and then I put those in the eLicenser and everithings is working fine since a couple of weeks.
it’s not much but I hope it helps

Reinstall/Update the elicenser program has worked in the past for me.

Simply right-clicking the eLicenser Control Center application icon and choosing Run as Administrator, then letting eLCC perform its default maintenance tasks should be sufficient.

This has not been sufficient for me. After doing all the maintenance tasks (as Administrator), Dorico still cannot find the license. The only way I can get it to work is by running Dorico as Administrator.

It gets worse. Apparently, right after midnight licensed Dorico (which only works because I’m running as Admin) becomes unlicensed, and suddenly I can not save my work.

Update: This only happened once. I left Dorico running at midnight the next night and it didn’t lose its license. So perhaps it was simply a coincidence that it happened at midnight the first time. Regardless, it’s still a problem.

I had a similar issue after updating to win 11.
Here the error was in the licenser.
I unplugged it , reinstalled the elicenser software and plugged it another usb port.
That did the trick.

Evan, are you using the USB-eLicenser or the Soft-eLicenser?


I just lost about another hour of work. Tried to save and was unable. This happened in the middle of the day (not at midnight) and appears to be totally random.

I’ve left the program open for days at a time with no issue, and then suddenly Dorico decides it is unauthorized, and saving is disabled. This is while running Dorico as Administrator, since this is now the only way I can get the software to run. Very frustrating indeed. I have never paid for and used any other software in my life that has constantly stabbed me in the back with authorization checks.

Dorico itself doesn’t perform any license checks after it first starts up, but the audio engine, which is a separate process and which runs alongside and in partnership with Dorico, does check its license more often, including while the application is running, and if the license check fails because the eLicenser is unreliable on your system, then Dorico is liable to hang and possibly eventually to crash because its expected communications with the audio engine will fail when the audio engine itself fails its licensing check.

This is obviously an unacceptable state of affairs and is one of the many reason why we are retiring the eLicenser system at the first opportunity, which will be early next year with the release of Dorico 4. I can only apologise for the poor experience you are having in the meantime.

Do you have a USB-eLicenser to hand? If so, I could try sending you a time-limited activation code that you could install on the USB-eLicenser to see if that makes the licensing behave more stably on your computer.