Dorico 3.5 not working anymore "Audio Engine Process Died"

Thanks @dspreadbury :slight_smile:

Here’s the folder:
Dorico 3.5 (1.5 MB)

Unfortunately several of the logs are zero bytes in length, which definitely supports the notion that the engine is crashing! I’ll have to leave this to @Ulf to look at further, because I’m out of my comfort zone with these sorts of things – hopefully Ulf will have some ideas.

Ok, thanks @dspreadbury , looking forward to your reply @Ulf

Hi @chines87 , really unusual your case. All of a sudden it does not work any more.
By any chance, did you happen to try and install Dorico 4? Because that one contains a newer HALion Sonic SE which is not compatible with Dorico 3.5 and would cause problems like you discovered.
If so, then please grab the HSSE 3.4.40 installer from our website and downgrade HSSE again.

Hello again, I have now symbolized the crash file and the audio engine is crashing during scanning of shared components. So one of your installed components is causing the headache.
Therefore, please go to /Library/Application Support/Steinberg/ and see if there is anything in there that you have recently installed or updated. If there is, then please take it temporarily out of that folder and move e.g. to your desktop, and try again launching Dorico. Better?

Hello Ulf ,
I ended up calling support and they suggested I completely delete all Dorioco files and Steinberg/Dorico related products (of course I saved all my projects ). As you’ve pointed out in this thread, trying to install Dorico 4 with my OS (High Sierra) seemed to cause the malfunction of program.
Thanks for your help and quick repy!

Thanks @Ulf and @Ashley_Hribar

I did try to install Dorico Elements 4, as I wanted to see if it would work on my macOS Sierra system, and if it did then I would buy the full Dorico 4 upgrade… but it didn’t allow me to install. It makes sense that that is the issue, thought I mentioned it earlier. It makes sense that the new HSSE would be the issue, but perhaps simply trying to install Dorico 4 is the culprit.

By the way, I checked the Steinberg folder in the Application Support folder, can’t find anything new there that made sense, so I removed all new items to no avail. Then, I tried reinstalling HSSE 3.4, which I imagine would install over the the newer HSSE, but that didn’t work either, so I’m thinking I need to do what @Ashley_Hribar did.

Can you direct me to all the files I would need to remove? I also have Cubase 10.5 which I use extensively, so if I need to uninstall that too then I’ll need to diligent about preserving all my user files and preferences (track presets, preferences, I/O setups, etc.). Dorico doesn’t have any user preferences that I’m concerned about, so I can completely remove it.

@chines87, hang on, you are on Sierra? That’s the problem. Dorico 4 needs at least 10.14. Then most certainly HALion Sonic SE is the troublemaker because you installed the latest HSSE 3.5 which is not compatible with neither Dorico 3.5 nor Sierra. That’s why, go to that Application Support folder and throw out HALion Sonic SE.vst3 and run the installer for 3.4.40. I’m sure it will work afterwards.

Yes, I’m on macOS Sierra (for now), sorry I didn’t mention it earlier, I figured it would come up in the report. I wanted to try Dorico Elements 4 to see if it would work on this system and 3.5 has been working fine.

Anyhow, Removing that vst3 file worked, however installing HSSE3.4 didn’t give me sound in Dorico. And I got a pop up that says it’s missing 3.5 upon opening Dorico.
HSSE 3.5 Missing

  • Installing the Dorico Elements 3.5 Sounds Installer doesn’t resolve the issue.

Now my sounds that were previously working do not sound, and the Halion SE plugin is missing.

However, the installer for HSSE 3.5 will not complete, and creates the VST3 file that prevents Dorico from opening. So, I’m thinking there must be a specific Halion Sonic SE 3.5 version that I was able to use from before on my system?

Thanks so much for your help, we’re almost there!

Here’s a screenshot showing that my previously working Halion SE plugin no longer is found, even though I installed HSSE 3.4. I only have the Halion Sonic plugin (no SE)

Viola from HSSE that worked before doesn't load

@chines87 , are you sure that you installed HALion Sonic SE and not on HALion Sonic? Where did you get the HALion Sonic SE installer from, from here?
If you have a look at /Library/Application Support/Steinberg/Components , is there not a HALion Sonic SE.vst3?
If you did run the installer, where did that HALion Sonic SE.vst3 get intalled with you? Could you please search for it on your harddrive. If you find it (with the correct version), then copy it over to /Library/Application Support/Steinberg/Components and try again with Dorico.

It looks like it isn’t getting installed with that installer. The 3.1.10 installer installed a folder (doesn’t load the plugin though) and the 3.5 installer installs the file that prevents Dorico from opening. However, the 3.4.40 installer doesn’t install that file. I made a 40sec video showing the installer running without installing the file, but the forum doesn’t let me upload it or post a link… but it isn’t installing that file. I searched my CPU as well, and no file is there after I run that installer.

Hi @chines87 , yeah, I just had the same experience with another customer. The installer of 3.4.40 does “think” it is already installed and therefore does nothing. I ended up transferring the plug-in by hand to the customer’s machine and now it’s working. Tomorrow I will check if we have an uninstaller somewhere for HSSE, so please hang on a bit…

Hi @chines87 , a download link for a HSSE 3.5 uninstaller is here. Please run that and then the installer for HSSE 3.4.40.

Just replying to let you know that worked. Thanks! @Ulf

1 Like

Archive (50.3 KB) (672.3 KB)
Hi Ulf,
I’m responding now to your reply on 21 Jan and have included as requested the two zipped files (Dorico and VST AudioEngine3) extracted from the System reports tab using the Console app. This is because the problem with crashing, constant rainbow spiral and need to force quit issue has started again. Incidentally, my original post “Dorico 3.5 not working anymore “Audio Engine Died”” came about before knowing about or installing the Dorico 4 version. So it appears that this problem is not related to Dorico 4. Although strangely, after deleting everything meticulously as outlined in the email from Dorico support, then reinstalling Dorico 3.5, the program, it worked fine for a few days. Then only today I’m experiencing the same issues again. I also killed the VST audio engine in the activity Monitor, but as soon as I reloaded Dorico the crashes came back again which also makes the fan in my Mac is noisy working extra hard.
I look forward to your reply and hope this can be resolved.
Best wishes, Ash

Hi Ashley, could you please also do in Dorico ‘Help > Create Diagnostics Report’ and post the corresponding zip file, too?

@Ashley_Hribar , I apologize, at first I did not read your posting carefully. Can you open Dorico 3.5 at the moment or isn’t it starting up at all?
In the two archies you’ve sent there are plenty of diagnosis files there are plenty of hang and dia files (they get created by the OS if a process is not responding anymore) but there are no crash files at all, which makes me wonder of the nature of your problem. I think it can’t have anything to do with the previous installation of Dorico 4. That seems to be all cleaned up. But something else is holding your computer back somehow…

Dorico (515.4 KB)
Hello Ulf,
Here’s the zipped file.

No worries!
Yes, it could be another problem. Occasionally I load an SSD card with Spitfire audio samples, (very big files) and did this just briefly as a test on some earlier Dorico

projects a few months ago. But when the SSd card is not plugged in I still get the issue with crashes. Mostly, when I try to close the program it hangs then I force quit. Here’s a screen shot of the activity monitor when it hangs. High CPU% and fan very loud

26 posts were split to a new topic: Dorico crashing on start-up