Dorico 3 always fails on my system in any file that's ever been connected to VE Pro

Apologies for such a lengthy post, but I’m trying to err on the side of not leaving important info out.

I have purchased every version of Dorico on the day each was released. Dorico 1 and 2, I purchased as an investment of faith in the team, even though they didn’t have the features I had been most hoping for ever since it was announced that Steinberg had hired the team. I like the direction Dorico is heading in so far, and I have high hopes for its future (and unlike other notation softwares, these hopes are based not on desperation, but on an actual track record). To date, Dorico is by a very wide margin the notation software that least often makes me want to throw my computer out the window.

Dorico 3, I bought because it finally included many of the features I’d been waiting for since before Dorico had been given a public name. I was looking forward to being able to use it a lot more frequently.

Unfortunately, on my system, since day one Dorico 3 has been a problem child with any project that has ever been connected to Vienna Ensemble Pro — which is literally every project I create. VE Pro is essential to my workflow and though its integration with Dorico has never been 100% trouble free, earlier versions of Dorico have been virtually trouble-free, whereas Dorico 3 runs into issues 100% of the time on my system.

I haven’t reported it earlier because I wanted to make sure I did everything I could on my side before bothering the team so quickly after release day. I had hoped to find a pattern that would allow me to address the issue myself, or at least would be a helpful clue when reporting it. Unfortunately, there’s no pattern I can discern other than:

Each and every project I create in Dorico 3, and each and every Dorico 2 project I convert to Dorico 3, if it has ever been connected to VE Pro (even once for just a few minutes, then disconnected), works for about a day and then freezes Dorico every time I try to open it on subsequent days.

Projects closed and reopened work fine on the day they’re created, but on the following day they cause Dorico to hang, no matter what, even if VE Pro isn’t running when I try to load the Dorico file, even if I have saved the file with the VE plugin disconnected.

Obviously, other users are running VE Pro and Dorico 3 without these issues, so my problems must somehow be intertwined with my specific system. However, with that in mind, the only common denominator I have foundis VE Pro + Dorico 3. I’ve tried various setups (various ways of connecting), including connecting to VE Pro via the Plogue Bidule plugin, connecting to VE Pro via the Vienna Ensemble Pro plugin (as direct a connection as is possible), and even a brief test connecting Dorico to a fully-functional trial version of Reaper using OS X virtual MIDI ports, with Reaper then housing the connection to VE Pro. (This last setup is the one I’ve tested the least, as I’ve never used Reaper before and to date have very little experience with DAWs in general.) Every manner of connection tested runs into the issue(s) I’m describing here.

Sometimes, the first sign of trouble is that on the first day a file is created, I can save the file, but then Dorico will hang when I ask it to quit. (Force quitting Dorico in this context semi-frequently causes VE Pro to crash, unless the timing there is a complete coincidence.) This doesn’t happen every time, but even when it does, I can usually load the file again fine, sometimes after a restart or resetting the SMC and the PRAM, on the first day the file is created. However, whether or not Dorico is able to quit normally on the day a file is created, trying to load a file the next day results in Dorico freezing up.

Force quitting Dorico and VST Audio Engine and Synsopos doesn’t seem to be any different than only force quitting Dorico, from what I can tell. Activity Monitor frequently displays Dorico as “not responding” but seems to think VST Audio Engine is fine. However, in case it’s relevant, when I try to sample or spindump VST Audio Engine, sometimes this only results in a blank white screen instead of returning text.

I’ve been collecting as much diagnostic info as I’ve been able, though I admit it’s been a bit piecemeal and there are gaps. I do hope there’s enough buried in there to shed some light on whatever’s going on. It’s 32.2MB* after compression (!) and along with a couple of representative Dorico files, can be downloaded from here:

https://drive.google.com/open?id=1E1c10ZtA9ux0FTlkMaQvD4MjUAcBftME

(*Why are spindumps so hefty when they seem to be only text?? If they aren’t particularly valuable to track, let me know and I’ll stop generating them.)

Some technical details in case they’re helpful when troubleshooting:

— 2013 Mac Pro 6,1. 3.5GHz 6-core Intel Xeon E5 processor, 64GB RAM. Processors have never been overtaxed, nor has RAM usage ever exceeded ~30% of what’s available.
–– I’m running Mac OS X Mojave 10.14.6, including the first Supplemental Update. (I just learned Supplemental Update 2 was released yesterday, but due to slow internet in my studio, I won’t be in a position to download it until next week.) However, please note that I encountered just as many problems with Dorico 3 connected to VE Pro before I updated to Mojave about a week ago. (Prior to that I was running Sierra 10.12.x (can’t remember the last digit)).
–– I’m running the latest version of eLicenser control center, 6.11.8.9256. I perform maintenance tasks every time I have to launch that app.
–– I’m running the latest version of Vienna Ensemble Pro 6, build #6.0.17966.
–– All of my endpoint configurations are renamed to very short names to circumvent the known issue described in other threads.
– Dorico is not being flooded with MIDI data, unless this is somehow happening without being reflected by the green light provided to indicate this.


Unfortunately, for me a notation software’s integration with VE Pro is as essential as engraving itself. Until the culprit is found and whatever’s going wrong has been fixed, I’m back to pen and paper full-time instead of just for first drafts.

“Help me, Ulf Stoermer; you’re my only hope …”

Have you seen this thread:

https://www.steinberg.net/forums/viewtopic.php?f=246&t=167822

Yes sir, I have. As mentioned in my initial post, all of my endpoint configurations have been given very short names to avoid that issue. But thanks for trying to help; if you have any other ideas, I’m all ears!

Obviously D3 is incompatible with both VEPro and VIPro. It’s consistent on Windows too. I assume Steinberg has access to the software to verify it themselves. No problems with D2.2 on the same hardware…

I looked at some of your files. Your endpoint configs are not all short names. At least in the file “endless crashing.dorico”.

In the other files your endpoint configs have several !! characters in the names. I wonder if this is causing a problem. I had no problem moving around these other files once opened. I didn’t connect to VE pro for these as I don’t have your configs.

I don’t find this to be the case. I have several quite large VE Pro based files that are working quite well with D3.

Thanks for looking into it dbudde, though I can’t fathom how the names could have possibly gotten that way. I’ve never named anything with any special character such as “!” … the names as I recall them were Vln1 and Strings. Since you can apparently open them, would you mind renaming the configs again and uploading so I can see if they will then load on my setup?

Fratveno, I’m sorry but I can’t tell if you’re being sarcastic or something? From what I can tell, plenty of other users are running D3 and VEP without running into issues … so I assume it must be something weird on my particular system? (Especially now that it seems my endpoint configs aren’t actually getting named what I’ve set them to.)

It’s all very confusing and I appreciate everyone’s willingness to help!

files.zip (1.23 MB)
Here are the updated files.

Well Dave (I presume?), thanks for all your efforts trying to help out. On my end, still having problems with the files you kindly sent. Weird that they all work on your end.

– First I loaded the divisi template I’d started, and so far this is the only one that loads consistently. It will be interesting to see if it loads tomorrow, especially after I add more endpoint configurations.

– Can’t remember what order I went in anymore, but I also tried the one called “endless crashing.” It seemed to load okay the first time, though it was weird to note that it hadn’t saved any of the expression maps I’d assigned, instead listing only “default”. (Unless it didn’t truly save the last time I saved it, and is therefore an earlier version. The past few weeks it has occasionally happened that I save a file, quit Dorico and when I return to it see that the changes didn’t save, even though Dorico had appeared fine and had quit without hanging.)

Every time I’ve tried this file since the first time, it causes Dorico to hang.

– The file with the excerpt from Roy Harris’ 3rd symphony loaded at first, but as soon as I tried to connect to VE Pro, VEP crashed immediately (no beach ball or “not responding” preceded it) and a moment later Dorico froze. Every time I’ve tried to load this file since, Dorico freezes upon startup.

As I came here to post this update, I had the one newly-working file loaded, and got an eLicenser error which froze Dorico (and VE Pro hung up a few moments after force quitting Dorico). Not sure if it’s related to the other problems I’ve described, but my VE Pro license is on the same USB key as my Dorico license, and I’ve never gotten eLicenser errors when VE Pro is running by itself or connected to another app besides Dorico. I get these semi-frequently since Dorico 3 (feels like approximately once or twice every 10 days, but I haven’t been keeping a log).

Pardon my ignorance, but is it significant that when I try to take a spindump of VST Audio Engine, it never generates any output?

Interestingly, on at least two occasions after trying dbudde’s re-kajiggered files and having to force quit Dorico, when I went to force quit VST Audio Engine, it was already gone, though no error message or dialog had ever come up, as usually happens when a “parent” app like Dorico or VEP crashes or is force quit.

Here’s the most recent crop of diagnostics (~6MB) –

https://drive.google.com/open?id=1R8KHAjKKDqYe1eFijMEiXptCI7BtsBwo

Many are from this afternoon, testing out the files dbudde sent. A few are from earlier; I hadn’t realized that there are apparently two different places Mac OS puts these logs on a default install (crash reports apparently go into ~username/Library/Logs/DiagnosticReports, whereas hang reports seem to default to Macintosh HD/Logs/DiagnosticReports.)

I just noticed you’re running VE Pro 6. I am running VE Pro 7. So that’s a difference. Otherwise I don’t have a clue what is going wrong on your end.

What I said above is based on this observation: I just launch D3 and apply Vienna Ensemble Pro 7 as the only VST. (I don’t have to connect it to the server, but if I do it makes no difference.) I then quit D without doing anything. In the Task manager the Dorico process disappears, but the VSTAudioengine process is not terminated. If you want to restart D without rebooting this process must be ended manually.

Doing exactly the same on the same machine 2 seconds later using instead D2.2.20: The VSTAudioengine gets terminated normally.

This only happens with VEP. All other VSTs behave as expected. Also, it is not related to UVIWorkstation (which works fine on Windows) or shortening names in the Endpoint dlg.

I don’t have this problem. VST Audio Engine always quits when Dorico quits.

I have a question for both of you, Is your Dorico license on your USB key or are you using soft elicenser for Dorico?

I am using soft elicenser for Dorico. If yours is on the USB key, does it make a difference if you change ports? Are you using a powered hub?

My Vienna licenses are on a key (obviously) but it’s plugged into a USB-C port which has better power delivery than USB-A. So I am wondering if some of these issues are elicenser key related.

Thanks for confirming that you don’t have that problem! My license is on a USB key, but Dorico 2 reads the same license off the same key without the problem, so to my ears it sounds more like a Windows problem… I’ll dig deeper into it tomorrow.

USB key, directly plugged into one of the Mac Pro’s USB 3.0 ports.

Nope, I’ve tried it on all four USB ports over the past month, and there’s no difference. I think all four ports are on one bus, if that’s relevant.

I actually have two Steinberg USB keys (an older one and a newer one; the older is longer, the newer stubbier), and I’ve tried both. No discernible difference in behavior between them on my system.

If that’s part of it, it still seems that Dorico is the common denominator. As mentioned earlier, I’ve never had a problem running VE Pro or anything else authorized on those keys when Dorico isn’t running.

I’m reluctant to go the soft licenser route because I still haven’t decided whether I want to run Dorico from the Mac Pro or from my iMac. I was going to decide which was master and which was slave after I finished building a ridiculous VEP+Dorico template. (To clarify, I haven’t used a master/slave setup with Dorico 3 yet; all of the issues I’m running into are happening on a one-machine setup.) And last I heard, it was still the case that if you go soft licenser, you lose the option to go back to physical key.

This is my experience as well, on Mac OS.

I don’t know if I’ve been paying close enough attention to make a statement about “always,” but my experience with VST Audio Engine is definitely much closer to what fratveno describes than to your experience. At a guess, I’d say that on my system, things behave the same as fratveno described at least 60% of the time.

At least we know from fratveno that whatever’s going on probably isn’t specific to Mac OS … and it seems unlikely to be related to VEP 6, since he’s running VEP 7. I guess at some point I can download the VEP 7 trial and see if it seems to make any difference, but I won’t be holding my breath. (And if it did solve the problem, it would kind of suck to have to $pend on VEP 7 when it doesn’t add anything I need or want from VEP.)

My thanks to both of you for brainstorming with me about this. With any luck, the team will have some ideas for us to try after the weekend.

Sam, you’ve got this muddled up. Once the licence is on the physical key, you can’t return to the software elicenser. It’s a one-way street and you’ve already driven down it.

Okay, perfect; I never wanted soft licenser. I just want Dorico 3 to work with VEP on my setup. If it turns out that the soft licenser is generally behaving better with VEP, I’m sure the team would find that unsatisfying, as they are committed to supporting both soft- and USB licensers as each user prefers.

Besides which, we don’t know if the problems this thread is about are licenser-related, nor to what extent even if they are. As mentioned, the problems I’m having occur literally every time I try to open a file; whereas I’ve only seen a licenser error 2 to 4x times since buying Dorico 3.

Yesterday, I was able to open one of the files dbudde kindly sent, without Dorico failing.

I succeeded in opening it once earlier today, which at first glance seemed like a good sign compared to what I’ve been experiencing the past month. However, this file only had one instance of VE Pro, and as soon as I tried to add another, it caused VEP to crash immediately upon clicking the “connect” button.

(Hopefully needless to say, VEP is designed to run multiple instances. Many VEP users need, not just prefer, to run more than one instance. Certainly in my case, a single instance isn’t possible.)

I tested it in a brand new project, and as soon as I tried to load a second VEP instance, VEP again crashed immediately (no hanging or spinning beach ball, just gone.)

In both cases, even though no error message was generated, VST Audio Engine crashed around the same time VEP did. (It disappears from Activity Monitor but apparently doesn’t generate a crash report.) When this happens, Dorico appears to continue running fine (can make edits to the score, etc.), but as soon as I hit save or try to quit normally, Dorico hangs.

The latest batch of diagnostics from today is at this link: https://drive.google.com/open?id=1Z9WCfFF2WJYFGgq8eFkJn2VXTGyUG5sI

Does anyone think it would be worth trying a reinstall of Dorico 3? If so, should I uninstall first, or just run the installer again?

This is all very disheartening.

Reinstalling Dorico won’t help. I don’t know enough about what might be going on here to be able to advise you further. You need Paul and Ulf, and I’m sure the three of us will put our heads together tomorrow and see how we think we should proceed from here.

Some further findings… my problem with VSTAudioengine3 not being terminated automatically only occurs on W7, it behaves normally on a W8.1 machine I just installed it on. I tried it both before and after upgrading the 8.1 machine to VEPro 7, and it made no difference. I’m fully aware that neither of these OS’es are officially supported, but would still be interested in finding a solution for W7 :slight_smile:

Sam,

It might be useful to review your VE Pro instance preferences. Make sure you leave at least one core free for Dorico. Also make sure you specify enough ports but not too many. Same for outs.

Also, are your running preserved/unpreserved and coupled/decoupled instances. Shouldn’t matter, but worth trying to change these. And I only ever use one instance (with as many ports up to 8 as needed). Also shouldn’t matter, but might be worth a look.

For what it’s worth, I always run unpreserved, coupled. And my instances preferences are 6 threads, 8 MIDI ports, 2 inputs and 2 outputs per instance. Again I only specify at most one instance. So I have one core (2 threads) available for Dorico.