Dorico 3 always fails on my system in any file that's ever been connected to VE Pro

Okay, I hear you loud and clear. The hub is always blank for me since I don’t connect music computers to the internet, but I will keep an eye on the blog.

FWIW, [Not sure how much this relates to this thread but in case its of help I’ll post]

I have VEPro 7 running under Dorico 3 on my Hacintosh running OS 10.12.2. Oddly, I am able to run Synchron Pianos inside of VE Pro with Dorico 3 although I am unable to select Synchron Pianos by themselves as they don’t show up as an option in the list. Synchron Player shows as does VE Pro and within VE Pro I can then run Synchron Pianos. I wish I could just select Synchron Pianos by themselves though as it would simplify my setup.

Any idea why Synchron Pianos doesn’t show up in the VST Instrument List?

In anycase, its wonderful to have my Synchron Pianos playing inside Dorico 3 via VE Pro. I’m a little closer to heaven, though being an older guy, I’m not sure how much I should be celebrating… :slight_smile:

Synchron Pianos is only available as VST2, so you’d need to whitelist it to get it to show up.

VE Pro and Synchron Player are VST3 devices.

Hi Sam,
you provided us Dorico crash files and among them were also crash files of VEPro.
We got in contact with our friends in Vienna and asked them to take a look.
Now they came back and said that it is was 2 plug-ins that brought down VEPro,
namely Flux Spat V3 and Plogue Bidule.
So you should get in contact with the makers of these 2 plugs and tell them
that they crashed VEPro with you. You can also provide the same crash files
to them. The respective developers will know how to get relevant information out of there.

That’s interesting, because both SPAT v3 and Bidule get validated by VEPro 7 itself on my system… Did the good folks in Vienna have any opinion on why it’s all fine in Dorico 2…?

That they get validated does not mean everything. Same with our own plug-in scanners, they just load a plug-in and do some basics checks. If that passes they are marked as good, but they still might crash later on, so it is by no means a guarantee.
And every system is different. On one computer a plug-in just runs fine, on another the same one might crash immediately, or depending on the way it is used. And it could also be that it was just luck that it was running earlier. Already small changes in the timing of calls can reveal lurking design flaws.

Yeah, you’re probably right… after all I’m a very lucky person…

Hi Ulf,

Thank you for the update. Unfortunately, this does not address the main problem I’m having. As I noted in an earlier post, when I moved from a one-computer-localhost setup to a two-computer-master/slave setup, the VE Pro crashes stopped.*****

I chose the wording in the the thread title carefully: before reporting the problem, I tried literally every Dorico file I have ever made, as well as new ones which I created to test & troubleshoot. As a consequence of this testing, I have also tried every VEP server project I have ever made, ~75% of which have never contained any instances of Spat v3 nor Plogue Bidule.

The main problem still plagues my system: any Dorico 3 project I connect to VE Pro (even completely blank VEP projects without any plugins loaded in them) will not open after saving the Dorico project and restarting Dorico. When I try to open such a file, Dorico hangs (spinning beachball, “program not responding”) for as much as three hours if I leave it that long before force quitting.

I will of course share the relevant crash reports with those plugin developers, but could you please reassure me that addressing the main problem I’m faced with is still on the team’s to-do list? (I’m stuck on Dorico 2 until I can reliably connect Dorico 3 projects to VE Pro.)

(Also, is it still the team’s recommendation to hold off on trying Dave’s idea about wiping my boot drives bare and performing clean installs of OS X and all apps? Last week Paul recommended to wait on trying this; just making sure that recommendation hasn’t changed in the interim.)

My thanks to you, Paul, and the rest of the team for your efforts to fix this.


*****(Note that due to some weird forum bug, the post where I wrote about this has disappeared. However, my original post is quoted in post #906332 above, where due to said weird forum bug, Paul’s reply showed up under my name, and the words Paul quotes show as written by dbudde, even though it was I who wrote them.)

The very definition of “careful what you wish for …” ! :laughing:

Not Ulf, but just another thought…I wonder if you could remove the two offending plugins from the component library and then just use Dorico 3 happily until the problems are resoved? Not sure if it will work, but at least if it gives you a shot at working with Dorico 3 until then, so it may be worth a try.

Also, re: wishing to use VSL Synchron pianos (ha ha), the dynamics playback very differently than the NotePerformer piano which has worked well with scores I’ve realized. So there is a bit tradeoff between quality and effectiveness. I’ll have to experiment more. I should try realizing Tcherepnin’s “The Fisherman’s Tale” :open_mouth: as its both for piano and orchestra.

To the OP:

Prepare a new system volume and install macOS High Sierra, then test the issue again.
I strongly believe that the notarization system in Mojave (since 10.14.5) is keeping current builds of VSL plugins from behaving well.

P.S.: Dorico 3.0.10 and Studio One (the latest build) are Catalina-compatible builds.
I’ve heard a similar issue with Studio One, and he finally downgraded his system to High Sierra to bypass the VSL issue.
I hope that my opinion helps you.

With the 3.0 release there were a few separate issues that were obscuring what was happening on your system, which made it hard for us to isolate what was really going on. The 3.0.10 update fixes a number of those and introduces extra logging in other areas that may help us pin down other problems. If you are continuing to have problems then we’ll need to get new crash reports or spindump reports (in case of hangs), which hopefully will get us closer.

We would certainly advise to not jump in and reinstall your OS just yet.

Thanks Paul. I’m in the midst of a project I had to start in v2 that eats up the majority of my time, but I’m downloading the latest update tonight and will generate some reports for you when I get a chance sometime in the next week. Just to clarify, you didn’t mention “sample process” so I take it there’s no point in bothering to run those for you, correct?

Thanks Shiki. If you don’t mind I have a few questions, as I know from your comments in other threads that you understand the ins and outs of the operating systems better than I do.

When I upgraded to D3 and started experiencing this problem, I was on Sierra 10.12.2. I had problems there for about 3 weeks before upgrading to Mojave in the hopes that might fix the problem. Given that I had the same problem on Sierra, do you still think it’s worth trying High Sierra?

If so, I think I would install it on an external SSD to boot from for testing, so I could keep my existing install as a backup until everything settles. (EDIT to remove incorrect information. I was mistaken; installers for 10.12 and 10.13 are still officially available from Apple. I was looking under their “Downloads” page but that’s apparently the wrong place. If anyone needs to find these, search for “How to upgrade to [name of Mac OS]” and the first result will be a page on the Apple site with a link to download the installer.)

Any further thoughts/advice much appreciated, thank you!

Gregory! Didn’t even realize it was you the first time you posted. It’s good to run into you. Well, you don’t know who I am but I’ve enjoyed a lot of your posts on redbanned (and occasionally on the “trash fire” forum, but I don’t go there very often as 90% of the time I find that place depressing).

Thanks for the ideas, I’m certainly willing to try anything and will do so when I get a moment to catch my breath. But forgive me, I’m not sure I understand the logic behind the suggestion. (I’m very much a dots-on-paper guy still struggling to get up to par on all the audio engineering/computer tech side of things. In an ideal world, I could leave all of that to a collaborator who actually enjoyed messing with it, rather than just saw it as a necessary evil like I do.) Anyway, if you wouldn’t mind helping me learn something here: since I have the problem in all VEP projects (most of which have never had the offending plugins loaded), how is it that removing the plugins from the plugin folders might help? Are you saying their mere presence on my system might create problems even in projects that’ve never been pointed to them? I would’ve thought projects were largely “deaf and dumb” to any plugins that hadn’t been loaded. But if I’m understanding you correctly, I really should spend some time pruning my plugin folders (I’ve downloaded lots of free plugs over the years that I don’t really use, but I defaulted to keeping them around “just in case they ever come in handy” … never realized any one of them might be silently sabotaging my efforts!)

Someday I’m sure we’ll be able to set different dynamic responses directly in Dorico for each xMap. Won’t get rid of the need for experimentation in cases like this, but it will greatly simplify the process! I don’t have Synchron pianos but I would imagine that tweaks to the mic mix might frequently enough necessitate further experimentation to fine-tune the dynamic curves for each mic-mix context. I’m sure you can do the dynamic response tweaks in the Synchron pianos player itself, but it’ll be really nice to store it all in Dorico someday. I’m not sure if you can save your custom presets directly in the Synchron piano interface (I imagine you probably can), but if not that’s one advantage to running it within VEP; VEP will save all your settings so you can just connect up different VEP projects depending on the context you’re going for.

After you’re done experimenting with the Tcherepnin, please tackle Ravel’s left hand concerto. I’d love to hear the results! Not that I have money for Synchron pianos any time soon, but hey … living vicariously …

There were some fundamental changes between Sierra and High Sierra.
Considering your situation, the rest of my suggestion is to contact VSL.
(If I were you I may contact Apple Support to ask for the installer of High Sierra. However, apparently you don’t want to do it, hence the inappliability of this possible workaround which probably doesn’t work.)

Sorry for causing confusion; it’s not that I didn’t want to do it, it’s that I didn’t even realize that was an option. However, I’ve today discovered that I was entirely mistaken, and the installers for Sierra and High Sierra can still be easily obtained from Apple. (I’ll edit my earlier post to remove the incorrect information.)

So, I’ve grabbed those two installers and when I have time I’ll create external SSD boot installations for testing. This will also allow me to try out Gregory’s suggestion, as I’ll only install essential plugins on an as-needed basis.

Hi Paul,

I’ve finally had some time to generate new reports. I created bootable external volumes to be able to test every OS back to Sierra, just in case that was contributing to whatever’s happening. Unfortunately, the problems persist in every OS version. I’ve uploaded reports for each OS in case helpful to compare them, but if not useful, obviously just don’t download whatever you don’t need.

New info: same problems as 3.0, but with slightly different wrinkles in 3.0.1:

  1. Any project that runs the VEP plugin directly in Dorico, hangs upon quit 100% of the time, similar to what’s described in this thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=170631 … when testing under this setup, I was usually able to open the project again after force quitting everything.
  2. Any project that runs the VEP plugin within Bidule quits just fine, but 100% of the time hangs upon attempt to re-open the project.

!) Please note:

Bidule itself is not 100% of the problem.
– In Dorico 3, problems are only encountered when a VSL plugin is part of the mix. Using Bidule to run any plugin that isn’t VSL (e.g. Kontakt, Halion, etc.), works 100% smoothly.
– In Dorico 2, no problems are encountered running Bidule in any configuration.
– If the two problems described above are at all related, the common denominator seems to be Dorico3+VEP(+ unfortunately, my unlucky system). If the two problems are actually completely separate issues, using Bidule somehow circumvents the first problem listed above, while sadly introducing the second.

I also don’t encounter running Bidule within any other application. Nonetheless, I’m sharing the relevant spindumps with the Plogue team on the off chance they spot anything they can address.

Diagnostics from various OS versions
(note: the one marked “Mojave dirty” is from a system bought in 2013 and updated sporadically along the way, with no preventative maintenance done; it includes any “cruft” that may have become encrusted in the interim. “Mojave clean” is a barebones-from-scratch install which I ran booted from an external SSD. All the other OS versions were also barebones clean installs booted from external SSD.)

OS X 10.12 Sierra: https://drive.google.com/open?id=1-cuYckio36-jsoxm1_aLgsbx6tz9jPQj

OS X 10.13 High Sierra: https://drive.google.com/open?id=1FwgA1FPDqbCDIuG5yMhGxZvTd9ugUqg7

OS X 10.14 Mojave clean: https://drive.google.com/open?id=1-cuYckio36-jsoxm1_aLgsbx6tz9jPQj

OS X 10. 14 Mojave dirty: https://drive.google.com/open?id=1UwkjymqZyyIEodkGLg9OQLpMAcZyFncM

I hope this is helpful in some way. I know you guys are working very hard to track down and fix a number of things lately, and I appreciate the efforts the team is making.

Cheers,
Sam

Certainly we have plenty of data that suggests that the hang on exit – which is really caused by the audio engine crashing – only occurs when using Vienna plug-ins. We don’t yet understand the problem, though we are working hard to understand it. For the time being we believe you will find Dorico runs more reliably if you remove Vienna plug-ins from the equation, though obviously I understand that for you the Vienna plug-ins are a key part of your workflow and that perhaps it might even be the case that you’re not interested in using Dorico without them. However, until we have resolved the problem one way or another – which might require changes to Dorico and possibly also to Vienna – you will probably find Dorico unworkable.

I apologize if I made you feel you needed to repeat yourself, Daniel. As noted previously, I am on Dorico 2 until this gets fixed (VEP isn’t really a preference per se, but I’ve invested so much design into a system dependent upon it, that to rebuild from scratch simply isn’t practical at this point). I only posted the new diagnostics because I was under the impression that Paul had asked for them, in post #p908446 which I quoted in my response. If they aren’t of any value, please simply ignore them.