Dorico 3 Elements doesn't recognize Kontakt 5 or 6

Hello folks,
you might have seen this thread:
The issue with that guy was a line ending thing, just carriage return without a linefeed.

You may also try this out, though from my perspective, this is different to your case here.

Unfortunately, we did not get much further on the case, please be a bit more patient. Many thanks.

Sorry Paul, no dice for me on this.

Sadly Dorico 3 fails to recognize Kontakt even when I’m not using a whitelist. For now I am working through VEP, so not a pressing matter, but still inconvenient.

Today I got a clean MacBook with 10.14.6, installed Dorico 3 and then Kontakt 5 and 6 with the latest version as provided by Native Access. Then started Dorico and both Kontakts appeared.
Kontakt 5 has here with me version 5.8.1(R43) and Kontakt 6 is v6.1.1 (R66). What version of the plug-ins are you guys running?

Also, I want the mac users to try the following:

  • Open a Terminal window and do

cd /Applications/Dorico

and then

./vst2xscanner -p /Library/Audio/Plug-Ins/VST/Kontakt\ 5\ 16out.vst

and if you have Kontakt 6 then also

./vst2xscanner -p /Library/Audio/Plug-Ins/VST/Kontakt.vst

What does happen?
Here with me, after a few seconds it spits out following text:

<?xml version="1.0" encoding="UTF-8"?>

/Library/Audio/Plug-Ins/VST/Kontakt 5 16out.vstInstrument5653544E694F376B6F6E74616B7420355653454E694F376B6F6E74616B742035Kontakt 5 16outNative Instruments GmbHVST

With the lines above you just invoked the plug-in scanner manually. This is exactly that, what Dorico resp. the audio engine also does for every plug-in that it finds in the search path. So it is the output of this, that decides if a plug-in gets blacklisted.

On Windows this works similarly, but putting in the paths is more complicated and you have to know what you are doing.

I have problems with the UVIWorkstationVST being blacklisted, so I did the following:
./vst2xscanner -p /Library/Audio/Plug-Ins/VST/UVIWorkstationVST.vst

The output is:
Killed: 9

So definitely this is not what should happen.

Okay, thanks for confirming. Yes, that should not happen. How about the version of UVI, is it up to date?
And does it load in Dorico 2, but not in Dorico 3?

Also to anyone else who does the manual execution of the vst2xscanner:

Before launching the vst2xscanner, please run the Console app.
Then, while the vst2xscanner is doing it’s job, have a look under ‘Mac Analytics’ or ‘system.log’ if there are events from the respective plug-in appear.a

One of our engineers has the suspicion that it could have to do with Apple’s new ‘hardened runtime’.
On the other hand, Windows users are also affected, but could be just that we are chasing two issue.

In any case, please report also the OS version number you are on.

My UVI version is the latest: 3.0.5
It does load fine in Dorico 2
MacOS Version 10.14.6
There is a crash log written in User Reports, where shall I send it?

Please send to ‘u dot stoermer at steinberg dot de’. Thanks

With the help of user fauvel we got a little bit further, at least on the case with UVIWorkstation.
The vstscanner crashes because of a codesigning issue and therefore blacklists the plug-in.
We prepared Dorico and all it’s components for OSX Catalina and therefore enabled hardened runtime.
Under these circumstances, when the vstscanner loads a plug-in, the hardened runtime checks for a proper code signature of the plug-in.
If it does not find one, it simply bails out. That’s what seems to happen with UVIWorkstation.

Consequently, we would be grateful if also people with Kontakt or Play on Mac could do the same check (manually invoking the vstscanner from terminal, as described earlier in the thread), so we can establish that it is the same issue.

On Windows this all does not applya, though also on Win Kontakt might not load, but that is a different issue where we are still in the dark.


I’m running windows 10, so not applicable to me in this case. But happy to test on windows if you provide directions. I am an engineer by trade so hopefully won’t hose my system :slight_smile:

I tried this for Play 6 and got the “Killed 9” result.

Here’s what Mac Analytics in console had to say: (running Mojave 10.14.16) vst2xscanner UNBUNDLED ||| ??? (0) UNKNOWN NO YES
SenderMachUUID: 235D1132-04A1-31E2-98BB-E70F134324FC

Again a posting for the Mac users only:

User fauvel sent me a zip with his UVI plug-in and that passes the vstscanner here on my MacBook with 10.14.6, no problem. Btw, user fauvel is also on 10.14.6.
And also a download from UVI results in no problems.

So the fact that the same bundle passes the vstscanner on one machine but fails on another, leads me to the assumption that there must be a switch or setting in the OS that causes this.
Is there maybe something that you applied to your OS (maybe via System Preferences or so) that you could imagine having the described impact?

Hello Mac users,

I’m happy to announce that we have found the cause of the issue.

With 10.14 Apple introduced System Integrity Protection.
Part of this protection is, that every app and bundle need to be code signed in order to get executed.

UVIWorkstation is code signed, but must have got modified after the signing procedure, so the code signature is wrong.
Our vstscanner runs in that protected environment and when loading UVIWorkstation the wrong code signature gets detected and consequently bails out.
Therefore UVIWorkstation ends up on the blacklist and will not get shown in Dorico.

So for a proper fix UVI has to properly code sign their plug-in bundle.
We will get in touch with UVI and notify them about it.

There were reports about Aria Play also not loading in Dorico.
I downloaded the latest version of Play and that works fine here, so I assume that affected people are on an older version of Play.
Please do an update to the latest version.

If you can’t wait for a fix from UVI, there is a workaround, but it is a bit risky, so we can’t officially announce the workaround here.
Should you still want to know that workaround, send a mail to ‘u dot stoermer at steinberg dot de’ and I will provide you with further information.

So much for the Mac, next I will focus on Windows and see if we can also find a workaround on that platform. Stay tuned.

By the way, here the answer from UVI support:
“This behaviour is related to PACE which is used by UVI products, and it seems it will be fixed out with next PACE updates hopefully.”

I have Dorico 3 installed on both MacBook Pro and Windows10 PC. Mac is able to connect to Kontakt 5 but PC is having the trouble. I do not know if it makes any difference but I upgraded from Dorico 1 to 3 on Mac and from Dorico 2 to 3 on PC. When I tried to whitelist again Kontakt this did not help. Actually Kontakt 5 that previously worked in Dorico 2 stopped working in both versions. This site is a little bit messy because of different operation systems and Dorico versions. How to proceed with Dorico 3 on Windows 10 Pro platform with Kontakt 5 issue?

As I mentioned, we are still working on a solution for Windows. Please be a bit more patient. Thanks

Hello Kontakt users (on Win),

I’d like you to test something on your computers. First, you need to find where actually Kontakt is installed on your computer.
I just found that I have 3 different versions installed and each is in a different location.
So please open a File Explorer window, navigate to C:\Program Files and then at the right top put into the search box the string Kontakt 5.dll (or just Kontakt.dll for version 6)
It takes a while but eventually show you a list of Kontakt DLLs, also for Kontak 5 16out.dll and Kontak 5 8out.dll. Anyway, important is the path to it.

Then please open a Command Prompt window. To open that, right click on the Windows icon on the left of your taskbar and from the pop-up menu choose Run.
Then type in ‘cmd’ and return, a Command Prompt window shall open.
In that window do type

cd “C:\Program Files\Steinberg\Dorico3\VSTAudioEngine\Components”

and then

vst2xscanner -p “C:\Program Files<full path to Kontakt dll>”

In the above replace with that what you have found in the search in File Explorer before.
To give an example, this is what I would type in my case:

vst2xscanner -p “C:\Program Files\Native Instruments\VSTPlugins 64 bit\Kontakt 5.dll”

Now, once you press the return/enter key, what does get output to the Command Prompt window?
In my case - and that is the good case - it puts out:

<?xml version="1.0" encoding="UTF-8"?>

C:\Program Files\Native Instruments\VSTPlugins 64 bit\Kontakt 5.dllInstrument5653544E694F356B6F6E74616B7420355653454E694F356B6F6E74616B742035Kontakt 5Native Instruments GmbHVST

But since you complain that Kontakt does not get listed in Dorico, I expect that actually nothing comes out with you.
If nothing gets put out on your computer, then please type in the following command:


As response just a number gets displayed. With me, because everything is fine, it is simply 0.
But in an error case it may be any other number.
Now, I want you to report me that number that turns up there with you.

Thank you very much for your collaboration.

Hi Ulf,

my Command Prompt window puts out the same as yours does. Also the “0”.

Here is the output from my PC:


<?xml version="1.0" encoding="UTF-8"?>
<vst2xplugin><path>C:\Program Files\Native Instruments\VSTPlugins 64 bit\Kontakt.dll</path><subCategory>Instrument</subCategory><cid>5653544E6924446B6F6E74616B740000</cid><editorCid>5653454E6924446B6F6E74616B740000</editorCid><name>Kontakt</name><vendor>Native Instruments GmbH</vendor><sdkVersion>VST 2.4</sdkVersion><vendorVersion></vendorVersion><latencySamples>0</latencySamples><canDoublePrecision>0</canDoublePrecision><audioInputBusCount>0</audioInputBusCount><audioOutputBusCount>59</audioOutputBusCount><mainAudioInputArr>0</mainAudioInputArr><mainAudioOutputArr>3</mainAudioOutputArr></vst2xplugin>

Kontakt 5

<?xml version="1.0" encoding="UTF-8"?>
<vst2xplugin><path>C:\Program Files\Native Instruments\VSTPlugins 64 bit\Kontakt 5.dll</path><subCategory>Instrument</subCategory><cid>5653544E694F356B6F6E74616B742035</cid><editorCid>5653454E694F356B6F6E74616B742035</editorCid><name>Kontakt 5</name><vendor>Native Instruments GmbH</vendor><sdkVersion>VST 2.4</sdkVersion><vendorVersion></vendorVersion><latencySamples>0</latencySamples><canDoublePrecision>0</canDoublePrecision><audioInputBusCount>0</audioInputBusCount><audioOutputBusCount>59</audioOutputBusCount><mainAudioInputArr>0</mainAudioInputArr><mainAudioOutputArr>3</mainAudioOutputArr></vst2xplugin>