Dorico 3 Elements doesn't recognize Kontakt 5 or 6

Well, Kontakt 5 was available in the VSTi list, but not Kontakt 6 (I bought the upgrade with the black friday offer), and I did struggle. Just thought it could be useful for you to have some feedback about this kind of little problems in the doc :wink:

Marc,
Did you already have the Kontakt Player? When I purchased Kontakt 6, it just overwrote the Kontakt Player (also called Kontakt in my list). I had to check the “About” menu item to be sure it was indeed Kontakt 6.

I had Kontakt 5, and I still have it. Maybe my setup is strange, I don’t know (I don’t think I’ve done anything wrong though). But the doc is not accurate, that was the only purpose of my post :wink:


Capture d’écran 2019-11-24 à 18.33.16.png

What I have heard is that NI decided to call Kontakt 6 just Kontakt to avoid users’ having to make changes (such as in the WhiteList) to access Kotakt each time a future upgrade becomes available. I suspect it is, in this one instance, causing a small amount of confusion as it initially did in my case.

To be absolutely clear, this is by no means the problem I was pointing. The help file clearly points to a folder that belongs to Dorico 2 instead of Dorico 3 (/Users/username/Library/Preferences/VSTAudioEngine2 instead of /Users/username/Library/Preferences/VSTAudioEngine3)

I’ve alerted Lillie to the issue.

Thanks Daniel.

Was there ever a fix found for the issue with Kontakt 6 being blacklisted in Dorico 3? I am struggling with this issue and none of the proposed solutions in this thread have fixed the issue.

I have tried adding “Kontakt” to the whitelist (being careful with EOL encoding), I have even tried copying the Kontakt entry from the blacklist XML file to the correspondng whitelist one myself.

Running vstscanner manually seems to work:

c:\Program Files\Steinberg\Dorico3\VSTAudioEngine\Components>vst2xscanner -p "C:\Program Files\Steinberg\VSTPlugins\Native Instruments\Kontakt.dll"
<?xml version="1.0" encoding="UTF-8"?>
<vst2xplugin><path>C:\Program Files\Steinberg\VSTPlugins\Native Instruments\Kontakt.dll</path><subCategory>Instrument</subCategory><cid>5653544E6924446B6F6E74616B740000</cid><editorCid>5653454E6924446B6F6E74616B740000</editorCid><name>Kontakt</name><vendor>Native Instruments GmbH</vendor><sdkVersion>VST 2.4</sdkVersion><vendorVersion>6.2.0.0</vendorVersion><latencySamples>0</latencySamples><canDoublePrecision>0</canDoublePrecision><audioInputBusCount>0</audioInputBusCount><audioOutputBusCount>59</audioOutputBusCount><mainAudioInputArr>0</mainAudioInputArr><mainAudioOutputArr>3</mainAudioOutputArr></vst2xplugin>

Nothing new on this at all? This is a major problem for my use of Dorico 3, as all my orchestral libs have been resaved to Kontakt 6 format. :frowning: Any potential tips on solving this would be greatly appreciated. I had the same issue with Cubase blacklisting Kontakt, but here it was a simple case of adding it to the whitelist. That doesn’t seem to do anything at all in Dorico.

Sorry Jesper, just saw your posting now. Could you please attach a diagnostic report here, so I can first get an overview?

No problem. I have attached the diagnostic report.
Dorico Diagnostics.zip (900 KB)

Thanks for the data. Very strange that Kontakt 6 gets blacklisted. Please try following:
Navigate to C:/Users/Jesper/AppData/Roaming/Steinberg/VSTAudioEngine3_64
and delete the two files ‘Vst2xPlugin Blacklist VSTAudioEngine3.xml’ and ‘Vst2xPlugin Infos VSTAudioEngine3.xml’
and then restart Dorico. That will trigger a rescan of all VST2 plug-ins.
Because once a plug-in is on the blacklist, it won’t get scanned anymore.
So chances are, that then Kontakt 6 will get recognized, because as you wrote, manually invoking the scanner does produce the expected output.
If it still gets blacklisted, please create a new diagnostic report.

No dice. I have actually tried that already, but gave it another go now, unfortunately with no luck still. I cannot attach the new diagnostic report because it is too large (2.28 MB).

I have also tried removing the whole VSTAudioEngine3_64 folder, also without it fixing the issue.

There is a Memory Dump File in the Crash folder in the report, is that a clue?

Here is the diagnostics report with the Crashes folder removed.
Dorico Diagnostics.zip (887 KB)

Why did you remove the crashes folder? Please leave it in.

See above. File too large to attach with the crashes folder included. :frowning:

Another thought, is that Kontakt.dll the real file, or is it maybe only a symbolic link? Our scanner has problems following symbolic links.

It is the real file, not a symlink.

And just the crashes folder zipped up is also too large?

Ah, no. That was just me being dumb. :slight_smile:

I have attached the report with only the crashes folder in it.
Dorico Diagnostics.zip (1.42 MB)