Dorico 3 Elements doesn't recognize Kontakt 5 or 6



What is in your whitelist? If I recall correctly, then for Kontakt 6 you only have to put “Kontakt” in there.
What is the path to your Kontakt installation?

In Dorico, please choose from the main menu ‘Help > Create Diagnostic Report’, that will create a zip file on your desktop. Please post it here so I can take a look.

Here is my whitelist:

Omnisphere
Superior Drummer 3
Kontakt
Kontatk 5 16out

Here is my Kontakt installation path:

C:\Program Files\Native Instruments\VSTPlugins 64 bit

I suspect the issue isn’t the whitelist since Kontakt worked fine for Dorico 2 without explicit whitelisting. I am going to try moving the Kontakt dll into a path Dorico 3 is already searching, since the likely real issue here is that Dorico 3 doesn’t honor new VST paths when set (they are reset back to the defaults on restart).

Diagnostic report can be downloaded here (was too big to attach to forum): https://1drv.ms/u/s!AkJKS0bhzKxZrXTNnONLe3yEXu0K?e=IFwyo9

Moving the dll didn’t work. But actually I found something interesting. The following file:

Vst2xPlugin Blacklist VSTAudioEngine3.xml

contains the following entries:

<item>
                     <obj class="FNPath" name="path" ID="363384304">
                        <string name="Name" value="Kontakt 5 16out.dll" wide="true"/>
                        <string name="Path" value="C:\Program Files\Native Instruments\VSTPlugins 64 bit\" wide="true"/>
                        <member name="FileType">
                           <int name="MacType" value="1936223330"/>
                           <string name="DosType" value="dll" wide="true"/>
                           <string name="UnixType" value="dll" wide="true"/>
                           <string name="Name" value="Module" wide="true"/>
                        </member>
                     </obj>
                     <int name="is32bit" value="0"/>
                  </item>
                  <item>
                     <obj class="FNPath" name="path" ID="363385264">
                        <string name="Name" value="Kontakt.dll" wide="true"/>
                        <string name="Path" value="C:\Program Files\Native Instruments\VSTPlugins 64 bit\" wide="true"/>
                        <member name="FileType">
                           <int name="MacType" value="1936223330"/>
                           <string name="DosType" value="dll" wide="true"/>
                           <string name="UnixType" value="dll" wide="true"/>
                           <string name="Name" value="Module" wide="true"/>
                        </member>
                     </obj>
                     <int name="is32bit" value="0"/>
                  </item>

Why are these Native Instrument paths blacklisted?

Interesting…try to delete that blacklist file and run Dorico again. Does the file get recreated with the same content?

And also, from the diagnostics files you sent me, I can see that your installation is missing the xml file for the VST2 paths. I attached a new one here, please put it into the same folder as where the blacklist.xml is. But first unzip it. I had to zip it, otherwise could not attach here.
Vst2xPlugin SearchPaths VSTAudioEngine3.zip (578 Bytes)

I can confirm the following:

#1 Launch new install of Doric 3 and all VST paths are reset to the following:

At this point the Vst2xPlugin Blacklist VSTAudioEngine3.xml contains no entries.

#2 Next, I add the path for Kontakt:

#3 Finally, I click “OK” and Dorico freezes for a moment.

I discovered while it was “frozen” it was actually detecting Kontakt.dll from the path I added, and then putting it on the blacklist instead of the whitelist.

This happens even when I manually move the entries from the blacklist to the whitelist and restart–they are reverted to the blacklist and Kontakt is unavailable.

Hm, very strange. I need to discuss tomorrow in the office with my colleagues what can cause Kontakt to get blacklisted. Please wait.

I can confirm that using this file means the following path:

*C:\Program Files\Native Instruments*

Shows up on the VST paths dialog between Dorico 3 restarts. However, even in this case a blacklist file is created and/or entries are created for Kontakt. It doesn’t matter if I delete the blacklist file or simply remove the entries manually. Even when I confirm “Kontakt” is on vst2whitelist.txt, and even when I manually move the entries from Vst2xPlugin Blacklist VSTAudioEngine3.xml over to Vst2xPlugin Whitelist VSTAudioEngine3.xml, for whatever reason, Dorico continues to blacklist Kontakt.

Hm, very strange. I need to discuss tomorrow in the office with my colleagues what can cause Kontakt to get blacklisted. Please wait.

Ok, I look forward to a resolution, I’ve got homework to finish! :slight_smile:

We are still not sure, why Kontakt gets blacklisted. Anyway, let’s try and whitelist it again. The whitelisting refers to the plug-in scanner, not the other whitelisting you do via Dorico.

Attached to this posting is a zip file containing 2 xml files. Please copy those two files to /Users//AppData/Roaming/Steinberg/VSTAudioEngine3_64 and let it override the existing ones.
And, at the same location you find the file ‘Module Cache.xml’, simply delete that one.

Then, open Dorico and start with a project from the piano template. Go to Play Mode and check if Kontakt does appear in the list of available VST-instruments.
If it does, then choose Kontakt. Does it crash? I would not wonder, because there was a (still unknown) reason that the plug-in scanner did blacklist it before.
whiteblacklist.zip (972 Bytes)

I’ve just tried this with Kontakt Player 6 and it loads for me without problems. Dorico already whitelists ‘Kontakt5 16 Out’ and ‘Kontakt’ so you shouldn’t need it in your own whitelist file.

I’d suggest:

  • copy your current whitelist file and edit it to remove the Kontakt entries from it
  • delete C:\Users{username}\AppData\Roaming\Steinberg\VSTAudioEngine3_64 directory
  • start Dorico again so it recreates the default configuration
  • Open a project in Dorico then in Preferences > Play edit the VST plugin paths again to add C:\Program Files\Native Instruments\VSTPlugins 64 bit
  • Restart Dorico

I’m also trying to get Kontakt 6 into Dorico, but Im still in Dorico 2. Earlier I managed to get the Aria Player on board (I think it was Dorico 1 when I did that), Again I follow exactly the steps in the video of Anthony, but nothing happens. Has something changed in-between Dorico 1 and 2 regarding this white-list-nerdiness? I’m on Mac. Is there an updated step-by-step guide for Dorico 2 and whitelisting?

Whitelisting became much easier in Dorico 2. Go to the Dorico preferences dialog, choose the Play tab and scroll all the way down. There are two buttons, ‘Edit VST2 Whitelist’ and ‘VST2 Plug-in Paths’.
Editor windows will open where you simply add the plug-in’s name that you want to whitelist or add the path to the path list, if it is somewhere located outside the standard paths.

Thanks ! That has become way more easy. It would be a good idea that this video get’s an update. (btw I don’t see a button ‘VST2 Plug-in Paths’…)

That button only appears on Windows, since there is only a single system-defined path for VST 2.x plug-ins (and indeed VST 3 plug-ins) on macOS.

I don’t know if this relevant but the second picture in your post shows the new path for Kontakt as:

C:/Program Files/Native Instruments/VSTPlugins 64 bit

instead of:

C:\Program Files\Native Instruments\VSTPlugins 64 bit

Forward slashes are illegal in path names if you use Windows, unless Dorico automagically corrects the “/” to “”.

Just a thought.

I think the forward slashes in the path shouldn’t be a problem - we do convert them internally.

I’ve been looking at the logs that you uploaded and found a couple of things that may have clouded the picture. There are a few crashes in there, and so it could be that setting the VST paths didn’t ‘stick’ because the engine crashed shortly after. Firstly, I would advise disabling the ‘suspend audio device in background’ option because we’ve found cases where it can cause problems. Secondly, I see that you’re using the ASIO Generic Low Latency device rather than the native ASIO drivers for your devices, so I would change to use the proper ASIO driver. Once you’ve made those changes, then hopefully that should stabilise things a bit so we can work out what’s going on with Kontakt.

Confirmed, changing my audio settings solved the VST path sticking problem after completely deleting the VSTAudioEngine3_64 folder. Thank you!

Kontakt still not available unfortunately.

I’ve now bee testing with no whitelist at all, but the problem persists. For what it’s worth, Kontakt gets put onto the blacklist immediately after clicking “OK” in the VST2 paths dialog, no program restart required (but I still tested this anyway). My next test is to completely remove Dorico 3 and reinstall.

I’m afraid I don’t think uninstalling and reinstalling Dorico will have any bearing on this – the question is why Kontakt is getting blacklisted on your system. For the answer to that question I’m afraid I think you need to wait for Ulf to come back to you.

Your fears are confirmed. Full removal and reinstall did nothing to address the problem. I’m stumped!