Dorico 3 freezes when hiting playback


Installed Dorico 3 pro (upgraded from 2.2) on Surface Pro running windows 10 Pro with 4GB Ram.

Successfully converted a couple of 2.2 projects, but none will play; Dorico 3 hangs, then I get a Not Responding message. Same happens with a new project.

I’ve tried uninstalling Dorico 2. Also uninstalled and reinstalled Dorico 3, but no joy.

Also tried a good old OS reboot.

Any suggestions?

Could you run Help > Create Diagnostic Report and attach the file from the desktop?

I’m having same problem. For awhile I couldn’t get 2 working either. But it seems to be working.

I tried a small new project string quartet. Notes enter, but no playback as you enter them, and hitting the green play button does nothing but hang at the beginning – doesn’t move.

One error message I noticed was “Audio engine is dead” I don’t think that’s a good sign.

Could you also please create the diagnostic report as described above?

Also I’ve seen a couple of users say that they had a freeze on playback until they went into Edit > Device Setup, reselected their device and set the sample rate, so try that.

I’m getting this too. Interestingly on one project that had a video in it, it played the soundtrack for the video, but the image in the video didn’t move. It didn’t render any of the notation (so just video soundtrack). And was still hung although stop button worked.

Here it is.
Dorico (302 KB)

here’s the report, happy hunting.
Dorico (1.29 MB)

Device setup used to be at the bottom of the drop down box. Can’t find it now.

Thanks for the quick response Paul,

I can’t create the report after hitting play (because its frozen) but can before hitting play … so zip is attached.

2019-09-05 22:06:38.490 : Executing command: Play.StartOrStop?PlayFromLocation=kLastStartPosition
2019-09-05 22:06:38.566 : notifyPostCommandExecute: Play.StartOrStop?PlayFromLocation=kLastStartPosition (76 ms)
2019-09-05 22:06:44.407 : Executing command: Play.SetPlayheadToFlowStart
2019-09-05 22:06:54.996 : WARNING addEventsForAudition() timeout - audition events won’t be sent
Dorico (264 KB)

P.s. I saw my own custom VST in there so I removed it from the whitelist and tried again - just to make sure it wasn’t that. No difference.

Went into Edit > Device Setup … explored but the only thing that gave me more than one option in the drop-downs was the sample rate … so I changed this from 48000 and back - and now I have playback, but no sound. :slight_smile:

Hitting notes in the onscreen keyboard in halion se gives me sound, but not when using the playback button in Dorico.

UPDATE: After closing an opening the project - I now have sound. Looks like triggering the Device Setup window did the trick. Thanks for the tip.
Dorico (283 KB)

Okay,I found device setup, but it’s greyed out, and not a usable control.

Another thing I notice, is even though Dorico 2 works, it also has a greyed out control of device setup like 3

Only Dorico one has a non greyed out control for device setup.

Dorico 3 still not working.

playing in device setup worked for me. It’s greyed before you choose a project, but not once you’ve done that

Thanks, but that didn’t work either.

Even weirder, when I open a project and then close going back to original opening screen, the device setup on the edit menu is gone altogether!

Okay, finally got in Device manager, did nothing but flip the control panels back and forth, certified that only one sample rate was avalible,

As I said, basically did nothing, but now dorico doesn’t hang and plays. ???

Seems a little sluggish compared to 2 though but at least it’s working! So far… crosses fingers.

Please watch the Dorico playback troubleshooting video between around 12:00 and 14:30 - you may need to set the system sample rate and turn the exclusive mode off.

EDIT: oops, forgot the link: Troubleshooting Playback Issues in Dorico | Support - YouTube