Dorico 3 Freezing After Doing Anything

I installed this yesterday, started using it today…or tried to. But it freezes pretty soon after starting anything. Loading a document from a previous version and using playback–stalls. Loading said document again and saving–stalls. Opening new document and trying to import notes from old document–freezes. I’ve attached the diagnostics report.
Dorico (238 KB)

It looks to me as if the audio engine is hanging or dying, but what’s odd is that no crash logs are produced. I’ll ask Ulf if he has any suggestions for what troubleshooting steps you might take.

Could you please take a spindump when Dorico becomes unresponsive? Open Activity Monitor, select the Dorico process, and from the cog in the menu, choose Sample Process, then save the resulting text file, zip it up and attach it here.

Also, what if you start a new proejct from let’s say piano template?
If you just add some arbitrary notes, does it play back?
And can you save and reload that simple project?

And please do the same for the process ‘VST Audio Engine’.

I’ve attached the two requested files. Thank you for taking a look.
Sample of VST Audio (29.4 KB)
Sample of (34.7 KB)

I also created a new project with a piano template. When I first input notes and try playback, nothing sounds (and I checked what I could to make sure it was all working). But when I saved and reloaded it, it decided to work then just fine.

Thanks for providing the spindump files. I can see where the code is spending the time, but I can’t see why. I’ve tried to reproduce the conditions that I’m seeing in your log but it’s working fine for me.

Do you get the hang with every project? If it only happens on a specific one, are you able to send it to us? (p dot walmsley at steinberg dot de) If you load that project and wait for a couple of minutes does it finally show the plugin windows and let you play back?

Sorry for the delay in getting back to you - we’ve been incredibly busy. One thing I can see in the audio engine log is that the very last entry was ‘deviceWasRemoved’. What hardware do you have installed? Is everything ok if you remove any MIDI input devices?

I think we might have an explanation for this - we’ve had reports from another user where there’s some invalid data in an old project that can cause a hang similar to yours. If this goes wrong with some specific files then I can take a look. You can either attach them here or mail me at p dot walmsley at steinberg dot de.