Dorico 3 GUI does not respond

Dear users and developers,

Today I have experienced odd behaviour which I have never had.
Please see the link below:
https://www.dropbox.com/s/enr3gblyesn97j0/Dorico%203%20GUI%20bug.mov?dl=0

Has anyone had similar experiences?
How could I resolve the problem?

Best,
prko

Yes I have had this on my Macbook. I went to Preferences>Note input and editing. There is a checkbox next to Mouse input, Enable note input using the mouse which I clicked off then back on, then everything seemed to work again.
Might not be related to your problem, I was in Write mode and could not do anything, but the menus functioned and buttons looked like they should work.

This does not resolve the problem.
I have realised that it happens after changing applications by pressing cmd+tab.

I have the same problem on my system.
Here’s the response I got from Daniel Spreadbury (@Daniel at Steinberg) :


“Yes, this has been reported a couple of times. If you’re using any VST instruments with sufficiently long names that they don’t appear in full in the VST Instruments panel in Play mode, try hiding the panel to see if that helps, or if not, try shortening the name of the plug-in by renaming it in the Endpoint Setup dialog.”


I tried it on my system but I wasn’t concerned with this long names problem.

Oh,
I almost resolved it by removing the following VST from the VST Instruments slot:

07 !! UVI..ationVST !!

This is UVIWorkstationVST, and it is currently not recognised in Dorico 3 and 2.
It worked with Dorico 2 previously. It is bizarre. Hm.

Now, Dorico 3 GUI responds much better, but the problem occurs still.
What I could is the followings:

  1. invoking a new window by pressing cmd+shift+t when GUI does not respond correctly.
  2. closing the window in which I worked previously.
  3. working in the new window.

That with UVI is a known issue and has been already discussed here: https://www.steinberg.net/forums/viewtopic.php?f=246&t=167593&p=899454&hilit=uviworkstation#p898991

Hello,

Dorico 3.0.10 still has the problem described in the first post of this thread…
Anyway, I can select a button in a dialogue box by pressing tab, enter key and space key…
Hope the mouse click works in the next release…

This is likely a silly question, but are you moving the mouse off the button (to go somewhere else) before releasing the mouse button? Some clicks respond only on release, and moving from one part of the screen to the other too quickly can move the mouse off the button before the end of the click “takes.”

Sorry, your question is here not appropriate.

I experience this kind of GUI behaviour only in Dorico 3.
In Dorico 2, I did not experience it.
I use the mouse button always in the same manner.
Why does this behaviour only occur when using Dorico 3 if I misuse the mouse?

I’ve the same problem since v3.0. Haptic clic works; repeated tapping eventually works; but just a first tap most often is not working, in particular in Write mode.

As sort of a corollary, you are not tapping anywhere, and when moving the mouse pointer you are actually selecting a zone.

Hope there is a solution, because it’s not easy to work when you don’t know if something is not working, or you have not tapped precisely.

Paolo
(using an Apple Magic Trackpad II)

Same problem than ptram since version 3 :thinking:

I want to add that with v3.0.10 things may have gone even worse. Now you may just tap anywhere between the staves, and the grabbing hand appears, making the trackpad drag the score. You can only return to pointing mode by haptic-clicking.

Paolo

I video-recorded my actions when using my trackpad with Dorico. Please note the trackpad works fine with any other app.

Since QuickTime Player shows clicks/taps while recording, I can see that tapping is not always recognized. Sometimes it is misinterpreted.

http://www.studio-magazine.com/video/sw/dorico/dorico-fuzzy-tap.mov

Paolo

I don’t normally use the ‘Tap to click’ setting on my own Mac, but I’ve tried it here and I don’t reproduce the problem. Can you reproduce the problem in a trivial project consisting of e.g. a single piano instrument and a few bars of music?

Unless one is using the non-Retina MacBook Air or any MacBook Pro model prior to January 2015, I strongly suggest not-to-use tap-to-click.
There is a reason that Apple developed the force-sensitive trackpads: Ergonomy.

Daniel, I tried with a simple piano score reproducing the first three bars of Bach’s first Inventio. No virtual instrument selected. Nothing else than notes, without ornaments or dynamic marks.

Unfortunately, the behavior is the same: tap to click behaves fuzzily. Tap to click is not immediately recognized even in some UI button, or when choosing the Add Single Player command in the Setup page, or when trying to select the Write tab (the others seem to respond immediately).

Out of the Dorico window, everything works fine. Dorico menus are selected immediately. Everything works immediately in the other apps.

http://www.studio-magazine.com/video/sw/dorico/dorico-fuzzy-tap-2.mov

@ShikiSuen: Actually, I find having to click as with a mouse very unnatural with a trackpad. I see a trackpad like a tablet: you do everything on a flat surface, without any mechanical part involved (real or simulated).

In any case, we got choices, so we are free to work as we feel more natural.

Paolo

Paolo, all I can say is that there’s something unique about your setup (or perhaps there’s something that differs depending on which Apple device you’re using).
I’ve just tried replicating everything you do in your videos - both of them - and I can’t reproduce any of it. I promise I’m tapping the trackpad on my Macbook, not pressing down on it, and it always works correctly. I’ll admit I have seen (and reported) the issue whereby a click is recognised but the release isn’t, which can result in an item inadvertently being selected and dragged, or a marquee selection being drawn, but on my machine it’s exceedingly rare.