Dorico 3 is laggy, unresponsive, and won't play.

Hey guys. Not sure exactly what happened here.


A while back, about 2 weeks ago I upgraded from Dorico 2 to 3. It worked beautifully and I got my NotePerformer working perfectly.


Now, all of a sudden, even after computer restarts, Dorico appears to be fully broken. The menus are laggy and unresponsive, and I can’t use playback! It’s not that I’m not getting any sound, it’s that I can’t even initiate playback. The play button is greyed out (seemingly so) and both ‘P’ and the spacebar have no effect on the application. I have attempted to reset/change my playback device settings but the menu is so laggy it causes windows to detect an unresponsive window. I have restarted the application and my computer and nothing seems to work. Perhaps it’s also worth noting that also, Dorico is no longer loading back to the main menu after closing out of a score, but rather running in the background (have to close it in Task Manager). I have tried all of my VST profiles and none of those work either. I am out of ideas unless this is some feature added in 3.0.


Any help here would be greatly appreciated, thanks.

Are you on Mac or Win?

First we need to get a clearer picture, therefore please choose in Dorico from the main menu Help > Create Diagnostic Report.
That creates a zip file on your desktop, please attach it here.

Second, if you are on Mac, then when Dorico is slow and unresponsive, open Activity Monitor and highlight the Dorico process.
Then click on the little cogwheel at the top of the window and choose ‘Sample Process’. Save to a text file and also attach here.
And do the same for the process VSTAudioEngine.

If you are on Windows, please do following: Download Process Explorer (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer)
and run it. Similarly, when Dorico is sluggish, choose the Dorico process, right click on it and then choose ‘Create mini dump’.
And again the same for the VSTAudioEngine process.
Zip up the two dump files and attach here.
Thanks very much.

It could be that somehow Dorico is being flooded with MIDI data and that’s locking the application up. Do you see the little green MIDI indicator light in the bottom right-hand corner of the project window showing up constantly green? If so, that is an indication that all is not well. Try going to the Play page of Preferences and clicking the ‘MIDI Devices’ button, then uncheck all MIDI input devices that you’re not actively using. If that doesn’t help and you still see the indicator fully green all the time, try performing a factory reset on your MIDI keyboard.

I’m on Windows.

I attached the Diagnostic Report from Dorico, but the zip file containing both dump files is “too large to attach.” Let me know if there is another way to get those files to you.

I find it strange that the play button (in the upper right) is greyed out indicating this isn’t a glitch or bug.

Thank you.

EDIT: The MIDI indicator light is not on, and I currently have no MIDI devices plugged into my system. No changes to the issue.
Dorico Diagnostics.zip (370 KB)

I had a quick look through the diagnostics, and it appears that something is wrong with your project promptpiece. The audio engine constantly is trying to load plug-in states, it’s very unusual. I will send you in a private mail a login to my ftp site, where you can upload the dump files.
It would be also nice if you could upload that promptpiece project as well, so we can have a closer look.

And what if you start a new project, let’s say from a piano template, add some notes. Is that also sluggish and won’t play?