Dorico 3 very slow to launch (Windows 10)

I’ve had a recent phenomenon of Dorico taking a long time to launch from when I click the icon. I’ve uploaded a video here (note: it’s not exactly riveting watching so maybe just skip to 00:52 when it opens).

I don’t think this started with the launch of Dorico 3, though it is possible that it coincided with one of the subsequent maintenence updates. I can’t be certain.

That seems very long, and it’s not the case with any other software I run.

Any thoughts?

Dorico (1.25 MB)

It looks like at least 45 seconds is spent looking for printers that are presumably switched off, or are perhaps network printers that are unavailable. If you have printers that are unavailable, I believe there’s a way in Windows to mark them as disabled so that Dorico won’t try to poll them when it starts up. At the moment my guess is it’s timing out waiting to hear back from them.

If anyone knows how to disable printers in Windows, let us know!

Ah, I think I know what’s happened (and this perhaps explains why Dorico wasn’t slow at first and then slowed down some time after I installed v3). The Conservatoire at which I work recently installed new wireless printers. For some reason, unlike other printers, Windows doesn’t seem to immediately detect when they’re not connected, e.g. when I’m at home. It hasn’t affected other software that I’ve noticed, but going by what you’ve said, it seems that Dorico spends a bit of time looking for those printers at launch. This also explains why when I was at work Dorico seemed to open much quicker.

I haven’t found a way to merely disable the printers without removing them (which would likely take more time than simply waiting for Dorico to open), or to instruct Windows not to look for them. I thought that maybe setting another printer as default might help, but it had no effect.

I guess I’ll have to assign the minute or so that it takes to launch as a cup-of-tea-making window. Thanks for helping solve the mystery.