Dorico 4.0.2 Audio Engine shoots to a 100% CPU

Hi tem,

this is new since today… I DID install cubase 12 though…
Upon loading a project, the VST Engine hovers at 100% CPU loading in the Task Manager, and everything slows to crawl…
If I apply the Silence template, the loading doesn’t take place, but with the regular VST setup, the dignostics files are too big… Now what?


Has Cubase installed masses of VSTs?

No, it hasn’t.
My VST library is of average size, only big brand names, everything updated and for every instrument one or two items.
No VSL or anything.


Can you send me the diagnostics, @YourMusic.Pro ? Thanks

To the email I have?


Yes, please

1 Like

On my way… :sunglasses:

Just to close this thread: ASIOGuard was switched off and my rather old machine together with a very small buffer size just gave up.
Stupid, but had this been Cubase, the audio engine settings would have been the first place for me to check… :expressionless:

Sorry, and have a great evening,

A final update concerning high cpu usage and audio software:
Unrelatedly, a recent Windows update probably broke the FireWire compatibility of my system using an old but great-sounding A&H ZED R16 mixing board.

I seized upon the opportunity to upgrade my studio machine to an ASUS Z690 motherboard, an i5-12600K, and a nice RME USB soundcard, which now bundles ADAT connections from the mixer and various preamps.

I now can, if need be, run 32 buffers at 48kHz without ASIOGuard and no overt drop-outs, which is important for recording drums through a sampler like SD3.
Interesting what a jump forward of 9 (!) processor generations can do along with retiring ancient interfaces… :roll_eyes::relieved:

Happy Easter everybody… :rabbit2::egg::star_struck:
Cheers, Benji

I didn’t think Dorico had ASIO Guard, only Cubase. How can that be the problem with the Dorico audio engine? I’d be interested to hear.

That’s what I thought… :wink: ASIOGuard in Dorico is alive and well!


Where are the settings?

It’s in the preferences dialog under advanced options. But you can only switch it on or off. The parameters are all set to default.
ASIO Guard was always on in Dorico since version 1, and only since version 4 we have the on/off switch. It should only be switched off, if users have trouble with the audio performance like crackling or drop outs.

1 Like

Wow, I thought this was only in Cubase. That’s great.

Hello @Lillie_Harris is that worth a mention in the manual? May help people with audio issues. I was unable to find it, and a manual search for ASIO guard showed nothing.

It’s in the preferences dialog on the Play tab… Scroll all the way down and then under Advanced Options.