Dorico 4.0.31 - Mixer window not showing up

When I click the mixer window button in D4 (or press F3), the mixer window won’t show up, no matter what I do (doesn’t matter if it’s an existing project or a completely blank one). All I get is an indication of an (empty) mixer window in the taskbar, but clicking on that doesn’t reveal anything either. Looks something like this:
image

I already tried reinstalling Dorico, including completely wiping all user files in the ‘roaming’ folder, but this hasn’t helped.
This is on W10, using 4 screens (3x 1080p, 1x 4k) FWIW. Latest version of Dorico
I appreciate any help!

EDIT: while writing this I made another weird discovery: I had my 4k monitor turned off while D4 was running. When I turned the 4k monitor back on (with Dorico still running and the mixer being ‘opened’), the mixer window suddenly appeared! But after restarting Dorico, the same issue was back and I also couldn’t reproduce the behaviour with turning on and off any monitors.

1 Like

Are some of your displays set to use a different display scaling setting than others? If so, then I’m afraid this could be the problem: the Qt framework that Dorico is built on has some unfortunate bugs when a mixture of different display scaling percentages are in play.

If you are able to try setting all of your displays to the same scaling percentage, you may find that the Mixer then appears correctly – at least give it a try as an experiment to see if that is borne out.

Hi Daniel and thanks for the reply!
Yes, my 4k screen is set to 150% (it’s only a 28 inch, otherwise things would be way to small), while all others are at 100%.
I just tried setting everything to 100%, restarted my PC just to be sure, and then launched D4, but the issue is still there.

Does the Mixer appear OK in the lower zone within the main Dorico project window?

Yes, in the lower zone it shows up just fine! On the play page as well.

Not exactly the same problem, but kind of related: I have noticed on the last desktop version that the mixer shows as empty after some time (just as a screen saver). Pressing p to playback the file would make everything appear again, but I don’t recall having experienced such behavior before, nor do I think it’s expected. Just thought it could be useful to give you some feedback.

1 Like

I just ran into this same issue. My 4k screen is different scaling than my secondary monitor like OP. I can’t get the mixer to show up, just the indication of a window open from the taskbar with no content in it.

Hi @Omnus , did the mixer window maybe just slip off the visible area? Does the trick from this thread maybe also help in your case?

1 Like

Yes this did work! It took a few tries to get the right-click menu to actually show up. But when it did I pressed the up arrow key and the mixer appeared, very large for the screen size. I right clicked the title bar and used the “Size” option to resize the screen down to something manageable again. Thanks Ulf!

1 Like