Dorico 4.1.10 - The update broke MIDI-thru

I have MIDI input and MIDI thru enabled in preferences. When I highlight any staff in the score, Dorico used to send MIDI out data on that staff (i.e. I can hear that instrument respond to my playing). Since updating this morning to 4.1.10 this behavior ceased, Dorico no longer sends out MIDI out on staff selection.
I re-installed the previous version and the expected behavior returned. Re-installed the latest update once again - and it’s gone. Are there any additional steps I might try? Unticking/re-ticking MIDI input/MIDI thru had no effect.

It works here: what OS are you using?

Have you checked the Auditioning settings in Preferences?

I am on Windows. Checking the preferences settings once again, both “Enable MIDI input” and “Enable MIDI thru” are on.

Well, I have now tried re-installing/un-uinstalling 4 times on my Windows 11 machine. Dorico 4.0.31 restores MIDI-thru reliably and without fail. Dorico 4.1.10 consistently break it. Unless there something else I need to do to restore this functionality, the new update is pretty much unusable for me. :disappointed_relieved:

Seems broken for me too, although I never would have noticed as I always leave MIDI Thru off and use a standalone piano VST. If you have a standalone piano VST and want to try a similar setup you basically just need a way to route the MIDI signal to your VST and Dorico simultaneously. One solution could be:

  1. Create MIDI ports specifically for Dorico and your standalone VST using the freeware program loopMIDI.
  2. Assign Dorico and your VST to your newly created ports, then use some program to route the signal to both ports at once. I use Bome but MIDI-OX still works and is free. There are quite a few other software MIDI routers available.

With this setup and MIDI Thru turned off, any time I touch my MIDI keyboard while inputting it will sound like a piano, but the project of course will play back with all the loaded sounds. Not sure if that’s helpful or not, but that’s how I work with MIDI Thru off and still hear everything.


What about this?


What is it they say about doing the same thing over and over and expecting different results? :grinning:

If once doesn’t fix it, then it’s something else.

Perhaps see if any other Windows users are affected…

1 Like

LOL, yes! In fairness, I tried overwriting first, then un-installing properly before installing again and then following all kinds of restart prompts, etc. Interestingly, there’s a thread up right now on MIDI keyboard not working that might be related - the OP was promised their issue would be solved with this latest update. It might have been - at my expense!

As for the screenshort - it seems the preferences options are different in Windows version. I had these settings work reliably before.

Auditioning is under Note Input.

Yes, there were some fixes to auditioning; let’s hope they haven’t spoilt anything.


1 Like

There’s definitely something that has changed from 4.1. If I load my orchestral template (all sounds coming from VEPro) into 4.1 then everything works normally, but with 4.1.1, I cannot audition my instruments. If I punch some notes onto a stave with my keyboard, it plays back, but I can’t hear what I’m playing in…
I tried creating a new project from scratch in 4.1.1 and added a VEPro instance into the rack and hooked it up in the normal way with my expression map etc, and it suddenly works as expected. So it is working, it’s just not working with my old template for some reason…I could recreate everything again, but would rather not. Nothing has changed in my preferences.
I wonder if anyone else is experiencing this with instruments hosted in VEPro?

I was the one who worked on the fixes for auditioning, and everything is working OK here. Admittedly I don’t have VE Pro to test with, but I’ve certainly tested it with the VST instruments I have available to hand, and everything works fine.

@Grainger2001, @ebrooks, you’re using controller keyboards, i.e. those that don’t provide built-in sounds? You don’t hear anything echoed back either during note input, or simply when you play notes on your keyboard after having selected something in a staff or selected a track in Play mode?

I use a MIDI controller keyboard that sends MIDI to Dorico. When I highlight a staff, Dorico usually sends MIDI out along the routing used for that staff. (I do not use VST’s with Dorico and only get it to send MIDI data via virtual cables), and I am always able to see that data being sent out, here:


With the upgrade this morning, I am not hearing anything “after having selected something in a staff”, to answer as precisely as possible. There is no MIDI data being sent out by Dorico in this scenario - all the values remain blank.

I remember pressing existing notes on a staff and it auditioned correctly (the note played back). I haven’t tried note input audition.

I’ll try to set something up to test this tomorrow. I can’t think of any reason why the fixes we’ve made would have any impact on sending data out via MIDI, but I’ll try to figure it out.

1 Like

Yes, I am also using a controller keyboard with no built in sounds. In both of the cases you describe above, I am not hearing anything echoed back. The little green light blinks when I play a note on my keyboard controller, but the midi is simply not getting though to the VEPro Server Instances.
I happen to have an empty slot in the middle of my other VST’s in the VST Rack…I have discovered that if I add a new VST into that slot in the VST rack, then the auditioning returns…I don’t have to assign it to anything…Somehow, just by creating a new entry in the rack it apparently opens up the midi thru or midi out which is somehow stuck…This appears to nudge it into life again. Not sure whether this is the same issue that ebrooks is experiencing…Maybe he can try adding a new VST into the rack and seeing if that does anything…

Here is a diagnostic report in case it can be of any use. The file this report was produced from is one where the auditioning does not work.
Dorico (3.4 MB)

The work around described above does seem to fix the problem…I simply have to delete a couple of entries in my VST rack to ensure there are no empty rack spaces, and then create them again. This is not too much work.

I’ve got to the bottom of this problem this morning. It was caused by a fix we made to ensure that Dorico is always able to set up the MIDI monitor when a project is activated after opening and plug-ins have to be reloaded. Unfortunately, due to an oversight, this means that it is currently unable to set the endpoint to an external MIDI device at all. I’m very sorry for the inconvenience.

This will be fixed in the next update, which is coming relatively soon. I hope you can live with this impediment in the meantime.


A tangential point, for which I apologise Daniel - but is there any plan to support WinRT MIDI in Dorico? This has been added as an option to Cubase/Nuendo 12. A key reason for wanting this is that it adds support for Bluetooth MIDI.

A good question, but I don’t know the answer – I believe that would be something that @Ulf and the audio engine team would have to work on.

This is a good illustration of the ripple-effect of changes and why no added features is “simple to add.”

Congrats on the sleuthing and for all the detailed work the Development Team does on our behalf.


Hi everyone, yes WinRT MIDI is something that we will “inherit” from Cubase. It will come with the next major update of the audio engine.