Dorico 4.1.10 - The update broke MIDI-thru


1 Like

There’s definitely something that has changed from 4.1. If I load my orchestral template (all sounds coming from VEPro) into 4.1 then everything works normally, but with 4.1.1, I cannot audition my instruments. If I punch some notes onto a stave with my keyboard, it plays back, but I can’t hear what I’m playing in…
I tried creating a new project from scratch in 4.1.1 and added a VEPro instance into the rack and hooked it up in the normal way with my expression map etc, and it suddenly works as expected. So it is working, it’s just not working with my old template for some reason…I could recreate everything again, but would rather not. Nothing has changed in my preferences.
I wonder if anyone else is experiencing this with instruments hosted in VEPro?

I was the one who worked on the fixes for auditioning, and everything is working OK here. Admittedly I don’t have VE Pro to test with, but I’ve certainly tested it with the VST instruments I have available to hand, and everything works fine.

@Grainger2001, @ebrooks, you’re using controller keyboards, i.e. those that don’t provide built-in sounds? You don’t hear anything echoed back either during note input, or simply when you play notes on your keyboard after having selected something in a staff or selected a track in Play mode?

I use a MIDI controller keyboard that sends MIDI to Dorico. When I highlight a staff, Dorico usually sends MIDI out along the routing used for that staff. (I do not use VST’s with Dorico and only get it to send MIDI data via virtual cables), and I am always able to see that data being sent out, here:


With the upgrade this morning, I am not hearing anything “after having selected something in a staff”, to answer as precisely as possible. There is no MIDI data being sent out by Dorico in this scenario - all the values remain blank.

I remember pressing existing notes on a staff and it auditioned correctly (the note played back). I haven’t tried note input audition.

I’ll try to set something up to test this tomorrow. I can’t think of any reason why the fixes we’ve made would have any impact on sending data out via MIDI, but I’ll try to figure it out.

1 Like

Yes, I am also using a controller keyboard with no built in sounds. In both of the cases you describe above, I am not hearing anything echoed back. The little green light blinks when I play a note on my keyboard controller, but the midi is simply not getting though to the VEPro Server Instances.
I happen to have an empty slot in the middle of my other VST’s in the VST Rack…I have discovered that if I add a new VST into that slot in the VST rack, then the auditioning returns…I don’t have to assign it to anything…Somehow, just by creating a new entry in the rack it apparently opens up the midi thru or midi out which is somehow stuck…This appears to nudge it into life again. Not sure whether this is the same issue that ebrooks is experiencing…Maybe he can try adding a new VST into the rack and seeing if that does anything…

Here is a diagnostic report in case it can be of any use. The file this report was produced from is one where the auditioning does not work.
Dorico (3.4 MB)

The work around described above does seem to fix the problem…I simply have to delete a couple of entries in my VST rack to ensure there are no empty rack spaces, and then create them again. This is not too much work.

I’ve got to the bottom of this problem this morning. It was caused by a fix we made to ensure that Dorico is always able to set up the MIDI monitor when a project is activated after opening and plug-ins have to be reloaded. Unfortunately, due to an oversight, this means that it is currently unable to set the endpoint to an external MIDI device at all. I’m very sorry for the inconvenience.

This will be fixed in the next update, which is coming relatively soon. I hope you can live with this impediment in the meantime.


A tangential point, for which I apologise Daniel - but is there any plan to support WinRT MIDI in Dorico? This has been added as an option to Cubase/Nuendo 12. A key reason for wanting this is that it adds support for Bluetooth MIDI.

A good question, but I don’t know the answer – I believe that would be something that @Ulf and the audio engine team would have to work on.

This is a good illustration of the ripple-effect of changes and why no added features is “simple to add.”

Congrats on the sleuthing and for all the detailed work the Development Team does on our behalf.


Hi everyone, yes WinRT MIDI is something that we will “inherit” from Cubase. It will come with the next major update of the audio engine.


could it be that it only occurs when there are gaps in the VST Rack? I checked out a VEP project and had no such issues. Anyway, looks like those affected won’t have long to wait for the fix.

No, the problem is specifically with setting the MIDI monitor to an external MIDI device. It will always fail in Dorico 4.1.10.

I don’t understand what is the difference between my situation and @Grainger2001 for instance here as we are both using external MIDI controller keyboards. It doesn’t really matter but just curious.

Unless I have misunderstood, you are feeding MIDI into a VST within Dorico whereas the users affected by the MIDI Thru bug are feeding MIDI into a VST hosted within another application that is responding to the MIDI input. The 4.1.10 MIDI Thru bug is that Dorico is not feeding MIDI to any output ports, whether virtual or hardware ports.

1 Like

Thanks, @David_W, my VSTs are also hosted in VEPro so my understanding is that my MIDI device, which is being hosted in Dorico, should also not work. But I must have got the wrong end of the stick somewhere – as I said, the bug has been fixed so I guess it doesn’t matter anyway.

UPDATE I can only assume that the reason is I have a MIDI input device but not a MIDI instrument.

Hi - I also am experiencing the same loss of MIDI-thru auditioning after I upgraded to 4.1.10 from 4.1. I use a Roland RD-2000 digital piano for note input and auditioning. Perhaps an unrelated issue, but until I opened the full transport pop-up window (F2), I was not able to activate the audio engine at all. In my migrated project, I also had to reload every VST in their respective third-party players (Spitfire Audio player, Orchestral Tools Sine player and Kontakt). This meant I had to re-do my selections for all the mic and other player settings I had set for each of the 23 instruments in the piece. However expression maps, and the VST rack were not impacted. I have no MIDI instruments in the MIDI rack.

All my VSTs are in Dorico. I stopped using VEPro and other VSL products because I want all my software to run in native Apple silicon mode.

The current status of the migrated project in 4.1.10 is the audio engine is staying activated after exiting and returning to Dorico. In 4.1 I had to wait for the play button in the mini-transport to change to green, but in 4.1.10, the wait is for the audio engine activation button to be ready. After the VST’s have loaded, I can playback and hear the piece. I can select an individual note on a staff and hear the appropriate sound. That’s all great. But MIDI-thru does not work, even though the MIDI indicator in the bottom right corner indicates Dorico is receiving a signal.

If I create a new test project in 4.1.10 with a solo Kontakt VST piano and using the same preference settings that are used for the migrated project, I do hear MIDI-thru auditioning.

May I ask when the MIDI-thru fix will be released? I really miss it. Can I provide any additional details that would help with the code regression analysis?

We’ve already fixed the problem in our internal builds, and we’ll get the fix out as soon as possible. We have another release planned that will reintroduce the percussion editor in the new Key Editor, and this fix will be included in that release.



I too have lost midi thru. Any old (pre the last updates) session play back but Selecting and playing on the staff does NOT work.

I also have a weird Reverb Bug. I am using VSL Vienna Pro and with that hosting my instruments in DORICIO there is always reverb. Even when the channel is Muted ( the one in Dorico) I can still here reverb. !!