Dorico 4.1.10 - The update broke MIDI-thru

could it be that it only occurs when there are gaps in the VST Rack? I checked out a VEP project and had no such issues. Anyway, looks like those affected won’t have long to wait for the fix.

No, the problem is specifically with setting the MIDI monitor to an external MIDI device. It will always fail in Dorico 4.1.10.

I don’t understand what is the difference between my situation and @Grainger2001 for instance here as we are both using external MIDI controller keyboards. It doesn’t really matter but just curious.

Unless I have misunderstood, you are feeding MIDI into a VST within Dorico whereas the users affected by the MIDI Thru bug are feeding MIDI into a VST hosted within another application that is responding to the MIDI input. The 4.1.10 MIDI Thru bug is that Dorico is not feeding MIDI to any output ports, whether virtual or hardware ports.

1 Like

Thanks, @David_W, my VSTs are also hosted in VEPro so my understanding is that my MIDI device, which is being hosted in Dorico, should also not work. But I must have got the wrong end of the stick somewhere – as I said, the bug has been fixed so I guess it doesn’t matter anyway.

UPDATE I can only assume that the reason is I have a MIDI input device but not a MIDI instrument.

Hi - I also am experiencing the same loss of MIDI-thru auditioning after I upgraded to 4.1.10 from 4.1. I use a Roland RD-2000 digital piano for note input and auditioning. Perhaps an unrelated issue, but until I opened the full transport pop-up window (F2), I was not able to activate the audio engine at all. In my migrated project, I also had to reload every VST in their respective third-party players (Spitfire Audio player, Orchestral Tools Sine player and Kontakt). This meant I had to re-do my selections for all the mic and other player settings I had set for each of the 23 instruments in the piece. However expression maps, and the VST rack were not impacted. I have no MIDI instruments in the MIDI rack.

All my VSTs are in Dorico. I stopped using VEPro and other VSL products because I want all my software to run in native Apple silicon mode.

The current status of the migrated project in 4.1.10 is the audio engine is staying activated after exiting and returning to Dorico. In 4.1 I had to wait for the play button in the mini-transport to change to green, but in 4.1.10, the wait is for the audio engine activation button to be ready. After the VST’s have loaded, I can playback and hear the piece. I can select an individual note on a staff and hear the appropriate sound. That’s all great. But MIDI-thru does not work, even though the MIDI indicator in the bottom right corner indicates Dorico is receiving a signal.

If I create a new test project in 4.1.10 with a solo Kontakt VST piano and using the same preference settings that are used for the migrated project, I do hear MIDI-thru auditioning.

May I ask when the MIDI-thru fix will be released? I really miss it. Can I provide any additional details that would help with the code regression analysis?

We’ve already fixed the problem in our internal builds, and we’ll get the fix out as soon as possible. We have another release planned that will reintroduce the percussion editor in the new Key Editor, and this fix will be included in that release.



I too have lost midi thru. Any old (pre the last updates) session play back but Selecting and playing on the staff does NOT work.

I also have a weird Reverb Bug. I am using VSL Vienna Pro and with that hosting my instruments in DORICIO there is always reverb. Even when the channel is Muted ( the one in Dorico) I can still here reverb. !!



Sorry forgot to mention , MIDI playback is fine in newly created scores. Click on the staff, Hear the instrument No Problem



Ed: Have you tried adding a new VST into your rack? It doesn’t have to be hooked up to any instruments, but I found that just by adding a new VST into the rack, it enabled the midi thru again. I’d be interested to know if this worked.

Your suggestion worked for me. Thank you!