Dorico 4.2 Slow on MacMini 2020

Longtime Finale and Sibelius user who is new to Dorico.

I’m working with a score with 435 pages, about 4.7 MB. I didn’t create it but it’s running really slow. When I move items in the full score, it takes 10-15 seconds to execute. Any speed tips as this is not workable to do these parts this way.


If your work is divided into flows, have you tried creating a special working score layout that you can attach to one flow at a time for editing and then attach to the next flow to edit that? (Make sure it is the only layout open at the time, no tabs for other layouts.)

Also, setting the playback template to Silent in Play mode may speed up editing.

Can you expand on this a bit? What’s the nature of your mac mini - intel? How much memory does it have? What is the OS version? Also, how many instruments are you working with? You didn’t create the score so is it a native Dorico score or an XML import from either Sibelius or Finale?

See this thread here:

Welcome to the forum, @Ray_Tarantola. It would be interesting to know more about the setup of your project – if you feel comfortable posting it here, that would be ideal. If not, you can send it to me privately, e.g. via a direct message here on the forum or via email to d dot spreadbury at steinberg dot de.

I’m running a MacMini M1 with 16GB RAM, Monterey 12.5.1.
It’s not an XML import. All of the parts and score show up on the right side if that’s what you mean by flows.
I’m working on the piano/vocal score and am under a deadline (yes, I dove in the deep end without fully understanding Dorico). I don’t know how to create a special working copy and don’t want to mess anything up right now. I did turn off playback but that doesn’t help much.
I appreciate the responses.
Once the PV is done, I have more time to get the score and parts done.
I’ll check out the thread you posted.

You can just send me your project in its current form. It would be instructive to see it.

While you should definitely take Daniel up on his offer to send him your file, here is a diagram that may help explain what I was talking about. Clicking on it should give you an enlarged version.

Hi Daniel,

I’ve attached the file. Thanks for the offer to take a look at it.
00 Noche de Posadas 092322.dorico (3.6 MB)


Thanks for attaching the project, Ray. The project is maybe a little sluggish, but I don’t find it too bad. I’m running an M1 Pro with 32GB RAM, so not hugely different in specification to your Mac. You’re talking specifically about nudging items graphically in Engrave mode? Each nudge does take around 750ms, which feels a bit slow – I will ask my colleagues why that might be.

1 Like

Hi Daniel,

Thanks for taking a look at it. Since I posted, the piano/vocal has become more responsive so I’m not sure what was causing the 10 second delays, but it seems to have worked itself out. I will be editing the score next and I’m curious to see how that responds. I will be turning off the playback to help.

Thanks again,

Hi Daniel,

I’ve moved on to editing the score and I’m back to waiting 10 seconds after every edit. If I nudge, edit or do anything on this score, I’m waiting 5-10 seconds. I’ve attached the file again. Actually file is now over 4MB and is too big.
Any work arounds would be useful. If the parts are like this, I don’t know what I’ll do.


I tested your file (from your original post) on my iMac Pro (Xeon W - 8 cores, 64gb RAM). I noted that the score is in condensing mode and in that state things are very sluggish. In ‘write’ mode moving a note up or down takes over 10 seconds. The same is true in ‘engrave’ mode for moving things like slurs etc. If I turn off condensing things are very much more responsive. Moving notes in ‘write’ mode is instantaneous and adjusting slurs in ‘engrave’ mode is smooth and responsive. In ‘engrave’ mode I tried moving some notes horizontally with condensing on and off and with it off the movement was very responsive if not instantaneous - certainly less than a second. I think it’s considered best practice to fine tune elements of the score with condensing off for this reason.

Have you tried doing save as (something different), then restarting Dorico and working on the new file? I’ve had some success with that approach.

Thanks. That’s it but I don’t see how I fine tune things with condensing mode off and then put it on as it then will mess up a lot of the layout and I can’t predict how’s it going to interact with the choral staves. I want to see exactly what I’m editing. Thanks for the reply. Ray

I’ll try that, thanks. Ray

Ray, you can email the current version of your project to me at d dot spreadbury at steinberg dot de.

That helped a lot. It’s still slow and a delay when I move things but it’s way better than 10-20 seconds. Thanks.