Dorico 4.3 keeps crashing

Right before the crash I heard a cracking noise (which is when I left the room😒), in about 15 seconds the computer restarted.

Oh, it was a hard reset then. In that case no wonder that we don’t see crash files, because the OS did not even have time to do that any more.
So yes, this is not a software problem, this is a hardware problem. It’s difficult to say from remote if your Apollo is the culprit or something else. Could be also sparks on the the power line. In that case it is impossible for us to help… (10.9 KB) (1.1 MB) (3.6 MB)
Activation (123.4 KB)

Meanwhile I purchased an USV power strip, because I thought that could be a problem/solution. For some days it worked fine, now I got another crash. While working on Dorico 4.3 I suddenly heard a long, super high and super loud noise. After about 15 seconds the computer restarted.

If this is a computer problem, I would love to hear some guesses what the problem might be. Here in Berlin an Apple verified store (Betterworx in the Prenzlauer Allee) was not able to locate any problem, I brought my iMac there like 5 times already. So if anyone happens to know an Apple store in Berlin where they actually know what to do, I would be super thankful!

I read some reports on Apollo Twin X, could it be that? I have the latest driver, I run Monterey.

Unfortunately there are no actual crash logs in the zip file you’ve uploaded that supposedly contains crash logs, so Dorico itself isn’t crashing.

If your computer is restarting spontaneously, I really don’t think it can be due to Dorico or its audio engine.

Makes sense. BUT it only crashes when I use Dorico. Baffled…:cry:

I can only assume that there is some interaction between the audio engine and your audio hardware that is triggering some subtle but very nasty bug. Have you tried disconnecting your Apollo interface and just using your Mac’s built-in audio hardware for the time being?

1 Like

I have tried it occasionally, but still haven’t found the logic behind the crashes, since the mac does not create crash reports.

I have found these two reports in the web with similar issue and they are even on Windows:

So I believe it is an issue with the Apollo and I would approach UA on this.

1 Like

Thank you so much Ulf, I will contact UA!

1 Like

Activation (124.1 KB) (3.6 MB) (15.0 KB) (943.6 KB)

Ok so now I don’t use the Audio Interface at all, and this happened. This time the computer did not reboot or make that horrible noise, but still not nice. Do the crash files tell you what the problem is? Makes sense to remention that the power supply is a USV power strip, so it shouldn’t be an electrical problem.

This time I got a report from Apple, in case it helps anything.
Apple_CrashReport_2023_01_08.pdf (75.8 KB)

Activation (125.0 KB) (3.6 MB) (23.0 KB) (975.8 KB)

And again.

Certainly not nice, but these two incidents were “just” crashes of Dorico. The audio engine on the other hand did not crash. And since Dorico does not touch the audio hardware at all and leaves that completely to the audio engine, I think it is fair to say that these are separate issues. However, Daniel will certainly have a look at the Dorico crash files and check what was going on behind the scene.

Thank you Ulf,

ok…I will send my Audio Interface to be repaired, I hope that solves the original problem.

Looking fwd to hearing, what the crashes were about…feels a bit challenging right now.

Actually, both of the Dorico crashes do appear to be audio engine-related, inasmuch as they both show a crash in the inter-process communication between Dorico and the audio engine.

Hi Daniel,

thanks for checking that!

What does it mean practically…? E.g. what do I have to do/fix in order to make things work?

Unfortunately I don’t have an answer for you there at the moment.

Hi @JarkkoR , I also don’t know, yet, but I have just had a look at the resolved crash files. What I noticed was, that in both cases Dorico crashes while responding to a notification that a change on the MIDI Input Devices happened. Do you remember, did you plug in or out a MIDI device around the timing of the crash?

Activation (119.6 KB) (3.6 MB) (7.5 KB) (933.9 KB)

Another hard reset. All I can say this time:
It happened during or right after the daily backup. This happens with CarbonCopyCloner onto an external SSD. I must add that this routine is like a month old, I have the problem since a year.

  1. A telltale was that a moment before my bluetooth mouse stopped working, and my Stream Deck rebooted.

This my terminal info from today, don’t know whether that helps.

Last login: Thu Jan 12 13:40:32 on console

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit

Jarkko-iMac:~ jarkkoriihimaki$

[Restored 12. Jan 2023 at 17:57:08]

Last login: Thu Jan 12 17:57:06 on console

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit

Jarkko-iMac:~ jarkkoriihimaki$

Hi @JarkkoR ,
thanks for all the new data, but there is nothing that indicates that your problem has anything to do with Dorico. The logs just stop at some point in time, there is no indication that you did something special. Also, Dorico would have no influence on the running of the BlueTooth mouse or the rebooting of StreamDeck. So I dare say that you have a hardware issue there with your Mac.

BTW, that message about z-shell is totally unrelated to your problem. I also get it on my old iMac. I simply can’t be bothered to adapt to zsh.

1 Like