Dorico 4 impossibly slow during online lessons

I’ve loved using Dorico to demonstrate revisions for students during online private lessons. However, after switching to Dorico 4, the response time to do ANYTHING in Dorico is impossibly slow. I’ve shut down all other programs, made sure that only one Dorico document is open at a time (all my students’ recent projects have but a single flow), and made sure that my browser didn’t have extra tabs open. Nothing seems to help.
Here are a few things about my system:
Processor:|Intel(R) Core™ i7-6700 CPU @ 3.40GHz 3.41 GHz
Installed RAM:|32.0 GB (31.9 GB usable)
System type:|64-bit operating system, x64-based processor
I’m using Vivaldi Browser (same as with Dorico 3.0 and 3.5 where it worked great), and use Google Meets to screencast. Oh, and like many, I require Voicemeeter Potato to share audio.
Any help would be appreciated! It takes so long to make an edit with Dorico 4 that I feel like I’m ripping off my poor (fortunately patient–at least so far) students.
Thanks in advance!

I’m not sure what the problem is but I think the first thing a Steinberg employee will do is get you to open the project and select ‘Help > Create Diagnostics Report’ and attach the corresponding zip file here, along with the project file (stripped down if larger than 4mb)

Also, while program is open, open Activity Monitor and click on the little cog-wheel at the top of the window, a pop-up menu appears from where you choose ‘Spindump’. Save the output of the Spindump window, zip it up and attach here.

I pasted all that info so hopefully it’s correct! :joy:


I’m attaching two crash log files, one while online and one offline. That said, Dorico worked fine while I was trying to reproduce the problem. (The problem has happened all three times I used Dorico 4 for lessons since updating.)
Also, I can’t figure out what you mean by activity monitor. The app you refer to seems to be something for Mac; I run PC. The only activity monitor for PC I could find would tell my parents if I’m being naughty online. My mom is in her 80’s and I don’t want to concern her. :slight_smile:

1 Like

Dorico Diagnostics online but no sluggishness this (749.2 KB)
Dorico Diagnostics (758.8 KB)

I believe it’s Task Manager on Windows.

1 Like

Task manager I know. But I’d have to get the problem to happen again, and I just failed to reproduce it on a Google Meeting with my wife. She’s just a mile away (in Michigan). Both students I had slowness issues with are on the west coast. I wonder if that matters?

Depends on what you mean by “slow”. Is this slowness perceived by the student? Or does your machine struggle to cope with running dorico and live streaming at the same time?

If it’s the student end, then in all likelihood it’s just due to streaming across a continent.

Slowness? I try to select a note using the mouse. 3-5 seconds before it turns orange on my screen. I use the ALT key plus the up arrow to transpose that note up a step. 5-7 seconds before the note moves. That’s what I call slow.
The students can hear my keyboard/mouse clicks. One even laughed at how long the program took to respond.

Well of course. I wasn’t doubting that something was wrong. I was just trying to get clarification on what precisely was slow and in what context, because saying “dorico is slow” doesn’t tell us much.

Right. “Impossibly slow” is relative. Depends on what you expect, I guess. Good news is that my student for tomorrow morning had to cancel, so I have until Tuesday to figure this out.

You can still use 3.5 until you figure this out …

I wonder whether the issue is that when you are running your live sessions, additional audio and, perhaps most importantly, MIDI devices are present on your system: I don’t use Windows (you only have one life to live, after all, and I choose to avoid Windows) but I wonder whether Voicemeeter is creating additional MIDI ports when it runs?

If so, go and check the Play page of Preferences and take a look at the MIDI Input Devices section. It’s vital that you don’t have any MIDI output device also selected as a MIDI input device – that will create a feedback loop that will clog up Dorico and make it very slow to respond. A tell-tale symptom of this is if you see the green indicator in the bottom right-hand corner of the project window on continuously rather than only when you play a note on your MIDI keyboard.


Thanks, Daniel.
My MIDI setup seems to be correct. The input device is my Focusrite external soundcard. The audio device is the Voicemeeter AUX Virtual ASIO. I’ll recheck this and the Voicemeeter configuration during a Google Meets session. I’ll also try running a Google Meets session using Chrome rather than Vivaldi. I just remembered this morning that I have had occasional issues with Vivaldi not playing sound on YouTube. Perhaps there’s a conflict between that browser and Dorico?
So I guess that I’m the only person with this odd behavior? (That Dorico 4 works great when I’m not running Google Meets.)
Until later,

We use screen sharing all the time when running Dorico: it’s our standard way of working these days, since we’re all still remote. We use Dorico in both Microsoft Teams and Zoom on a daily basis with no such problems. I feel almost completely certain that there will be something peculiar to your configuration causing the performance problem, though I’m not sure yet what it might be!

Right, though it only started with Dorico 4. It’ll be interesting to find out what caused the sudden conflict. I’m trying to get another session with a student who experiences slowness. I’ll be in touch.

So I tried to reproduce the horrid slow response time using the same documents with the same student from yesterday, and … everything worked perfectly. The trouble has happened 3/3 times I’ve used Dorico 4 in lessons. Just can’t seem to recreate the issue when I want to troubleshoot. I’ll monitor the behavior and follow up with a report. Many thanks to everyone who pitched in to try and help!
all best,

I think we found a solution that will make a difference! A friend of mine helps me with my computer when I get stuck and he can find time. He noticed that dragging the score in either Write or Engrave mode was making a high memory demand. (Can’t remember if he was concerned about the CPU number as well.) He ended up forcing Dorico to use the integrated graphics card rather than the discrete graphics card. We noticed a huge improvement not only when I am running a Google Meet session, but also when not. I’ll have to double-check later this week when I have online lessons, but this looks promising.
Thought you’d appreciate an update. Any comments or suggestions are, of course, welcome.