Dorico 4 Install: eLicenser issues

After downloading and installing the Dorico 4 update (from 3.5)
And after downloading and installing the latest eLicenser.

I am still unable to activate the product.

Also asked on FB here: Redirecting...

Sorry to see this, Michael. If you quit everything (Steinberg Download Assistant and eLicenser Control Center), then check in Task Manager that Steinberg License Engine and Synsopos have quit properly, then try running Steinberg Activation Manager again, are you able to proceed if you enter your Download Access Code again?

Unfortunately this doesn’t work, nor does a system restart.

So even if you don’t start eLCC yourself manually, SDA gives the same error and says it can’t launch eLCC?

That’s right.

And when I try to activate manually I get this fun message

It really does suggest that somehow it’s not the right version of eLCC. Can you try manually installing the latest version for Windows from this page?

Already have, and it didn’t work, so I uninstalled it, downloaded it again, and it still doesn’t work…

With that being said… I just got a suggestion to manually open the Steinberg Activation Manager, and this direction seems promising!

After doing this, I was able to open Dorico, create a bunch of notes and save the file successfully.
So I think this is resolved…

It’s not quite resolved, alas, because that “Verification Pending” means that your existing Dorico Pro 3.5 license in your eLicenser hasn’t been successfully “consumed” for the update. So we do need to figure it out.

Could you please zip up the Download Assistant folder in /Users/your-username/Library/Logs/Steinberg/ so I can pass them on to the SDA team and see if they have any idea what might be up?

However, I should add that there’s no immediate time pressure now: your “verification pending” license will work for 30 days, so we should be able to get it sorted comfortably in that time.

1 Like

I don’t have such a folder, I’m running on Windows. Could the path be different?

The “eLicenser too old” message is a symptom of putting a DAC into the eLicenser Control Center. Could you try entering the DAC again using Steinberg Download Assistant?

See the photo in my original message for the error message that I get when putting the activation code into the download manager…

Classic. “eLicenser too old” is the misleading message you get if you input the Download code into eLicenser.
You need to input the download code into the Steinberg Download Assistant (click button top left that says Activate).
Then you will get an Activation code you can send to elicenser.

  1. I really thought the new licensing system would fix this get-a-code, input-a-code, get-another-code flow for digital purchases from the Steinberg store
  2. elicenser should at least recognise download codes and give a more helpful error message

Does not work unfortunately.

Sounds like you need to contact Steinberg support who will have you report system specs, uninstall, reinstall, wipe licenser with a special .exe, reactivate licenses etc etc until you give up and go away, or achieve success in ways no-one fully understands.

1 Like

I’ve sent you a PM with an activation code to try.

1 Like

Looks like it worked. See my PM.

Many Thanks!

Great - I’m going to close this thread so I know it’s done. :slight_smile:

1 Like