Dorico 4 prevents OS sleep

On my Windows 11 laptop, Dorico being prevents the OS from going to sleep. Not just automatic sleep after X minutes, but even when I actively try to put it to sleep, it refuses.

This has bitten me twice before I realized Dorico was the culprit, resulting in a dead battery and a blazing hot laptop in my bag. :confused:

Hi Dan, with me this does not happen. Do you just close the lid or do you put it to sleep via Start > Power > Sleep? And in the Windows settings, what is your power plan?

I have the same issue on my Win10 desktop.

No other app causes it, only Dorico.

Hi Ulf, the power settings are set correctly. It doesn’t matter whether I close the lid, press the power button, or let it sit for the selected number of minutes… it won’t go to sleep if Dorico is launched.

When Dorico is totally closed out, it goes to sleep as expected.

I’m only raising this because I recall other users saying Dorico 4 finally allows their machines to sleep automatically, but for me it doesn’t.

Dorico won’t allow your machine to sleep automatically, e.g. after the machine is “idle” for a period of time, because the audio engine’s high-priority thread(s) means that the machine is never idle.

But you should be able to make your computer go to sleep by explicitly commanding it to do so. If it doesn’t, chances are, it’s some kind of audio device driver issue.

I was about to create my own post about this, when I saw this.

I don’t know what the technical options are, but I’m pretty sure that a thread’s priority can be changed. Your explanation sounds suspect. For example, if I run a YouTube video in a browser window, neither the computer nor the display goes off until I pause the video—then it shuts off after the idle time expires, because the people who write browsers figured out how to handle this kind of thing. I have other programs that use audio and I haven’t seen them exhibit the same problems. I simply can’t believe that Dorico is the only program that I run that uses a high-priority audio thread.

Dorico doesn’t just prevent my computer from sleeping—it prevents my display screens from turning off.

Note that the issue exists even if only the Steinberg Hub is running. As far as I know, the Hub doesn’t need to play audio.

When I walk away from my computer, I don’t always know if it will be a few minutes or a few hours. If Dorico is running, I need to decide. And because the Hub appears a few seconds after I exit a score file, I sometimes come back to the computer with both displays blazing away because I walked away and forgot to fully exit Dorico.

Yes, I could manually put the computer to sleep—but then, I’m pretty sure you could fix the problem on your end if you really wanted to.

If you use File > Exit, you can close both the program and Hub together. Letting the computer sleep while a program is running is always a risk. Nothing bad may happen, but it can.

1 Like

I always do a save if I have any unsaved work before I step away. Actually, my motto is save early and save often. The risk of data loss from sleeping is negligible. I’ve been doing this routinely for years with a range of programs and no problems.

Dorico’s audio engine inherited that property from Cubase which needs it for unattended long time audio recordings. Therefore it is hard coded into the engine.
Of course, we can switch this off, but since Cubase and Dorico’s audio engine share a lot of code, it is not that easy. It is in our backlog to make this configurable but we have had no time, yet, to implement it. So yes, the Dorico user’s voice is heard, but still has to wait unfortunately.

7 Likes

This is a much better explanation than Daniel’s–not that his explanation is incorrect, just incomplete.

Thanks.

I would think Cubase users would have the same complaint. Could you make the Cubase engineers do the work? :slight_smile:

I think Cubase users would be outraged if they start a recording, play in the best solo they ever did and then realizing that it is suddenly cut off because the computer went to sleep.

And yes, it is the idea to let the “Cubase engineers” do the work, but they are also busy with other Cubase specific tasks…

4 Likes

Things may be different now, but putting a music computer to sleep was always a no no

2 Likes

Well, I bet it’ll go straight to the top of the list now! :rofl: :roll_eyes:

3 Likes

I wasn’t thinking one would use a stupid algorithm to do this. You don’t allow sleeping when you shouldn’t (in the middle of a recording). You allow it when you should (when there’s been no activity in a while—recording is an “activity”). You don’t rely on the OS.

Netflix has the same problem. Users would be outraged if they started watching a movie, only to have the computer enter sleep mode in the middle. At the same time, users might also be outraged if they paused their movie and walked away for a few hours, only to find that their the pause image had been burning away on the screen. So they made it work well in both situations.

Again, it depends on how it’s managed. Relying on the OS is where I think a lot of the problems come from. It can be intelligently managed (see Netflix example above).

Finally, it still remains a user’s decision. On Windows, you can set your computer to never sleep if you feel you can’t risk it.

Great! :roll_eyes: Perhaps I didn’t state it the best way, but Daniel’s comment was along the lines of “it can’t be done”—I should have just said, “yes it can”.

1 Like

??? LCD/LED screens don’t burn as far as i know

1 Like

OLEDs do.

1 Like

… and I would have replied - hold on.

Even in my limited configuration, there is quite a bit more to it with real time (or near real time) audio devices plus other software than either of your Netflix and Browser examples. To keep my Audio Interface, a S/PIDF pre, two Midi keyboards, a Buffalo Drive, VEP, Sonarworks, SMPTE lock, Focusrite control, etc. reasonable happy, and avoid a cascading failure because some piece of hardware/software can’t get what it needs at some instant…

I won’t argue with choice and having different needs - but I absolutely know my visibility into the issues are naive compared to the Steinberg team.

2 Likes

See How to Fix Screen Burn-In on TVs: Plasma, LCD, and OLED

Fair enough. But I’m not sure that, for example, keeping the computer from idling will prevent a disk drive from sleeping. You prevent a disk drive from sleeping by telling the OS not to let it sleep (or simply keeping it busy). Most hardware stays running if the OS doesn’t sleep. Hard drives and displays and a few other things often have their own sleep code. I was surprised that Dorico doesn’t just keep the computer on—it keeps the screen on.

I’m pretty sure my external MIDI keyboard is not going to sleep no matter how my OS is set up—and if it did, I’m not sure the OS could prevent it (not without some active keep-MIDI-awake code which I’ve never heard of—but then, I’ve never heard of MIDI devices sleeping).

We don’t all work in the same environments. On my tablet PC, I have two power configurations—one for when I work with REAPER (my DAW) and am performing music and one for the rest of the time. For me, most of Dorico’s composition features don’t require that it be permanently running any more than my word processor does. I agree that it shouldn’t shut down during a long recording, nor while playing. I can’t think of any other times when it would be necessary to keep it running despite my sleep setting (which I could always set to “never sleep”).

I’m not asking anyone to let their computers sleep. I’d just prefer it wasn’t enforced on everyone. Keeping the display on is particularly irritating.

I don’t mean to be glib, but there’s always the old option to simply quit Dorico when you aren’t using it… solves your problem right away. I use lots of heavy programs that I quit when they aren’t my active focus, because I don’t want them to be resource hogs nor to corrupt an open file over the course of multiple sleep/wake cycles. Just close dorico.

5 Likes