Dorico 4 Pro not starting on Windows 10 with Blackmagic DeckLink Recorder 4K video card installed (1.0 MB)

Paging @dspreadbury : The audio engine looks like starting up normally but the Dorico logs are always breaking off after “Loading All Parts of Default Library”. Any idea?

By the way: Dorico 3.5 Pro is still running fine on the same computer.

Is your PC up to date? I think Dorico 4 needs Win 10 20H1

In fact it requires Windows 10 21H1 or later, but that is probably not the issue here. I’m still looking into it!

Good morning, no it isn’t. I’ve got the latest updates for Windows 10.
Perhaps it helps to mention, I’ve got the following Software installed:

Dorico 3.5 PRO
Dorico 4 PRO
Samplitude Pro X 7
Kontakt 5 (with several libraries installed)
Guitar Rig 5
Davinci Resolve 17 (with Blackmagic DeckLink Mini Monitor & Mini Recorder 4K cards)
Filmora X

The Windows 10 computer is in my studio. At home I am using Windows 11 and mostly the same software but without the Blackmagic cards. Dorico 4 PRO runs fine on that machine.

Could you please zip up a fresh copy of the Dorico 4 folder in %APPDATA%\Steinberg and attach it here, @rick2703, so we can get a look and see if the Windows update has changed anything?

Sorry, Daniel, my post was misleading. You said “that’s probably not the issue here”.
“No it isn’t” the issue. I already had all the latest updatest installed when I posted the folder yesterday. Sorry again for the confusion.

Thanks for confirming, @rick2703. The point at which Dorico is stopping is at the point at which it’s assembling all of the various files that constitute the default library, so perhaps there’s a problem with that subfolder of the Dorico 4 installation, somehow.

As a next step, just to rule out an installation problem, would you mind going to Programs and Features and choosing to uninstall Dorico 4, then try reinstalling it again?

If that doesn’t help, I guess the issue could be that Dorico is trying to write a binary cache of the files it’s assembling and somehow it doesn’t have access to the folder it’s trying to write to, but let’s try the simple fix first.

If the problem is something to do with Dorico’s temporary file cacheing, another thing to try is to delete %temp%\Dorico 4.

Very strange. I did all you told me to do, reinstalled Dorico 4 - with no success.
Then I tried to start the app several times - over and over - and - voila - it started 1 time. See attached Dorico 4 folder (application.6).
I closed Dorico and tried again with no success. One time not even the splash screen appeared (application.1) - had to kill the Dorico task.
I’m very confused.
Dorico (24.7 KB)

At the moment it keeps crashing at:
2022-01-14 14:39:28.870 [info] Audio engine: Running
2022-01-14 14:39:28.871 [info] Initialising dorico-extractaudio
2022-01-14 14:39:28.872 [info] Initialising dorico-extractaudio…done
2022-01-14 14:39:28.873 [info] Initializing Playback Controller…done
2022-01-14 14:39:28.873 [info] Initializing Video Engine Controller…
2022-01-14 14:39:28.984 [info] Initializing Video Engine Controller…done
2022-01-14 14:39:28.984 [info] Initializing Application phase 2
2022-01-14 14:39:28.985 [info] Initializing ScoringApp phase2

When Dorico does not start, have a look in the TaskManager for a VSTAudioEngine background process. If you find one, kill it and try again to launch Dorico.

No success. Now it crashes at different points. See attached logs.
Dorico 4 (2).zip (24.3 KB)

Could you please also zip up the folder C:/Users/your-name/Documents/Steinberg/CrashDumps ? Thanks

There is no such folder.

Strange. And you are sure that Dorico is crashing? It is really gone from the TaskManager?

Actually TaskManager is a bit unreliable in showing really all running threads. May I ask you to download Process Explorer - Windows Sysinternals | Microsoft Docs. It’s free, it’s really small and much better than TaskManager. Please check with that one the running state of Dorico or VSTAudioEngine.

I installed Process Explorer. Dorico4.exe is showing while the splash screen is visible. Then the splash screen disappears and the process is gone. VSTAudioEngine is still running after that.

I was able to catch some screenshots: