Dorico 5.1.10 Fermatas Playback

Hello Dorico team,
I hope you are all doing well there! :slight_smile:

Here I would like to report a fermatas related bug that I have noticed.
Somehow, the insertion of any sort of fermata symbol always leading to note length shortening in Played Durations.

Here is a video about the issue, so you could reproduce it yourself:

Dorico 5.1.10 - Fermatas Note Length Bug

I hope it could be fixed in the next update! :slight_smile:

Best regards,

It’s not a bug. It’s the new behaviour. The tempo is reduced during the pause, so the actual note length is greater.

1 Like

Hi @Janus ,

Well, this behavior is completely not understandable to me…
If I do not activate Properties → Hold Only it shortens the played note duration, which isn’t musically correct. So something unexpected.
By nature Fermatas are supposed to extend the note and pause duration (by slowing the tempo in software environment). The Breath marks are supposed to slightly shorten the note length in order to allow the player to take a breath before the next phrase.

What if one just would like to add fermata, without touching anything else? He / she will get as playback check wrong note durations.

So, this new behavior isn’t a good idea since it forces one to take further actions in order to fix it.

Best wishes,

I think it is more common in practice to have a break after a fermata than no break, even with no breath mark. Properties offers individual control, of course. But if you don’t ever want a break, you can set the Gap duration % to 0 in Playback Options > Timing > Pauses.

(Thanks for prompting me to investigate these new features!)

1 Like

Hi @Mark_Johnson ,

Well, the break may be a common practice after Fermatas, but it’s not uncommon the opposite, as well.
Still Fermatas should not act as Ceasuras.
By the way colla parte should be also included for those instruments which perform during Fermata and Ceasura.

Best wishes,

P.S. Regarding the thread title: Just because the feature isn’t doing what you want does not warrant calling it a “bug”. It seems to be working exactly as designed.


If it’s by design, then it can’t be called bug, but it’s not what I want, or not, it’s about what Fermatas are by nature. They aren’t supposed to act as pauses. They are only note and pause duration extenders, nothing more.
These are the most commonly used practices for fermatas and ceasuras (in case we would like to have pauses after the performance):

Even the double barline could serve as a sign for expected pause (the example in bar 12)

Currently the Fermatas in Dorico do more than what they are supposed to do. Which can be considered unexpected behavior, in other words - problematic behavior.

Best wishes,

P.S: I don’t mind this new behavior to be optional, in case someone wants it, but definitely not the default one. :slight_smile:

Hi @dspreadbury ,
I hope you are doing well! :slight_smile:

I would like to ask about addition of feature related to the Fermatas in the Playback Options, that will allow us to globally define the default behavior for every project.
For example I don’t want the fermata to shorten the played duration, because this something out of it’s nature. There could be people who find it fine the fermatas to do more than they are supposed to. I’m not against the various possibilities, just I would like to be able to define them as program defaults.

Best regards,

1 Like

P.S: Here is another situation that Dorico doesn’t holding well.

Here Fermata is set to Hold Only in the Properties and Ceasura - Gap duration % to 200.

In this situation the Fermata should hold the whole note as long as I need, then the Ceasura (a.k.a. the Grand Pause) should stop the playback and hold it as long as needed (according to the percentage).
The Ceasura symbol should appear at the end of the bar in the Key Editor, not at colliding with the Fermata.

I hope these things can be improved in a future update!