Dorico 5.1.30

Thanks for the update - and for the impromptu notice in last nights ASMAC zoom.
When I installed I got some odd error messages - see screenshot - before the instal (via Steinberg download assistant) completed.
Have any other users experienced this ?
Is there something I should check about my instal? (I’m on a MacBook Pro, Intel silicon, and I was about to say I had avoided update to OS 14.4 (as per John Baron’s advice) but just noticed my automatic updates got the better of me and I am now on 14.4, so the question - were the errors a consequence of automatic update to 14.4?


thanks

This is a long-standing issue where .vstsound files don’t get installed by the Library Manager because of a problem with file permissions.

What happens is that the the SLM can’t move the file to the correct installation location (usually inside /Library/Application Support/Steinberg/Content/, and instead creates an alias to the .vstsound that remains in the Downloads folder.

You may find that running the Terminal commands here will fix it, and you can then install the files correctly.

I looooove the fact that the properties for space size is the default set in Layout options and not 1,75 like it was before. (This was a long-time feature request of mine, and I am so glad it made it to the top of the pile!)

16 Likes

Yes, this is great!!!

To help Dorico SE users understand what benefits they would get from upgrading to Dorico Elements, the menus in Dorico SE now show items that are present in Dorico Elements, indicated with a special lock icon.

I enjoyed that Dorico SE had a reduced, or “easy mode” interface for learning to use the core features, even when owning a paid version.

Hi,
Thanks for the help.
I am not a user of terminal commands - so I copied and pasted in the first line
sudo chown sophia:staff /Library/Application\ Support/Steinberg/Content/HALion/VST\ Sound/*

and input my password and got the response:

chown: sophia: illegal user name

so … should I substitute my username for sophia? or sophia:staff? or is it user instead of staff? and how do I find out?

Thanks

Ah: yes, sorry - substitute an admin user name for ‘sophia’.

1 Like

New update for iPad CRASHES ON OPEN for me. I’ve tried re-installing, rebooting, no dice. Tried just the icon, also opening via a dorico file.

DO NOT UPDATE ON IPAD.

Hoping y’all can get this fixed shortly?

Hi @Andy_Hunt and welcome to the Forum!

I cannot confirm this behavior: on my iPad Pro (10.5-inch) Dorico 5.1.30 works nicely. I am still running iPadOS 16.3.1 though.

Which iPad model are you using? And which iPadOS version?

Sorry to hear that, Andy (and welcome to the forum). Could you please take a look in Settings > Privacy & Security > Analytics & Improvements > Analytics Data and find any *.ips files whose names begin “Dorico”, zip those up and attach them here?

Thank you Dorico team! Noting that the Version history is up to 131 pages for Dorico 5 and its updates alone….

Sure thing: iPad 6, iOS 17.3.1. Zip file of most recent ips attached (there were a bunch)
dorico.zip (8.0 KB)

thanks!

I’m not really sure what might be going on here. The crash log seems to indicate that Dorico is being shut down by the watchdog process on iPadOS because it’s taking too long to display the window. However, Dorico itself should start up quicker than this. When Dorico starts up, do you see anything at all? Do you get the dark grey Dorico logo that appears while the app is loading, or does it seem to crash directly back to Launchpad? Does Dorico get far enough that you get a spinner while it’s trying to open a project, or does it get as far as showing the Hub?

Hey – I get the gray “D” logo, nothing else. No spinner, no hub, nothing. Here’s a zip of the rest of the IPS files if that helps.
dorico_all.zip (79.1 KB)

It would be really interesting to get a look at Dorico’s application logs, but I’m not sure how to extract them if the app can’t start up. My colleagues who are more knowledgeable about this have gone for the day, but I’ll ask them first thing tomorrow what our next steps should be. Please hang in there.

Thanks. Yeah, kinda dead in the water here. Have tried rebooting, re-installing, etc… Plenty of disk space, nothing else running. Worked fine until this latest update.

It may be cold comfort, but it works on my iPad Pro.

On Win 10 it crashes the audio engine.

What does? 5.1.30? Certainly not on my Win10.

Hi @JoPiano , please have a look in your Documents folder, there is supposed to be the subfolders Steinberg/CrashDumps.
In there please look for any recent Items from today or since the update to 5.1.30.
Please zip them up and send me.
Thanks

1 Like