Dorico 5.1 - no playback sound

I just updated to Dorico 5.1 Pro a few moments ago - from Dorico 4.3 Pro.
I downloaded and installed all files as required. At first Dorico 5.1 was taking a very long time to start and giving errors that the audio interface was taking too long to start. Then gave an error that Groove Agent wasn’t installed. After reading some threads here in the forum I Cleared Audio Engine Cache (in Preferences, VST Plug-ins) and restarted Dorico and didn’t get the Groove Agent error anymore and Dorico started.

Then I created a simple test solo piano piece (4 bars) and there was no sound while playing back. I made sure it is instantiating the Halion Sonic 7 plugin and that the plugin is getting MIDI in (it is) and the plugin also indicates it is producing sound (the VU moves both in the plugin output and in the mixer) but no sound is routed outside of the plugin. I tried resetting the Audio Engine Data (in Preferences, VST Plug-ins) and restarting Dorico 5 but then I got all sorts of problems starting Dorico once again and after trying to start Dorico 5 for 10 minutes and restarting the computer it finally started again. But still no sound.

Interestingly, at some point I was enabling and disabling channels in the mixer (Instruments, MIDI, Video, etc.) and I got sound! But the happiness was short lived as after I closed and reopened the score I was back to square zero (not sound again) and no amount of fiddling with the mixer would bring it back. I tried resetting again the Audio Device (in Preferences) and once again it took a lot of restarts to make Dorico 5 start again.

I am using Windows 11 Pro for Workstations 22H2 (OS build 22621.2861) running on an i9-9900K 64GB RAM with an audio interface RME Fireface UFX+ connected via USB 3.0. Just as a side note, the system works absolutely perfectly with Dorico 4 Pro, Cubase 12 Pro, VST Live Pro, Studio One 6, Ableton Live 11 and my other audio software.

Any help will be appreciated.

EDIT: I continue to explore this problem and I have an update that may help somebody with the same problem - a workaround. This time I went to the mixer in Halion Sonic 7 and I changed the output of the channel where my piano was instantiated (channel 1) to channel 2 and I got sound! Then I changed it back to “Main” and it kept playing. So one of the possibilities is that there can be some bug in the initialization of the output channels of Halion Sonic 7.

After I got it working (around) I once again exited Dorico 5 Pro and restarted Dorico. I once again got twice the Audio Engine was taking too long to start but after a few attempts Dorico 5 Pro started again and had no playback sound. But if I go again to the Halion Sonic 7 plugin and change the Output of the MIDI channel where my piano is to Out 2 then back to Main. It works. Here it goes. At least the “fix” works consistently.

I’m reasonably certain that a team member will ask you for a Diagnostics Report to examine.

Thank you for your reply, Daniel. I have since made an edit to my post - I managed to work around this problem. But I certainly can send the Diagnostics Report - I am not sure how but if they can kindly let me know I will do it.

Help > Create Diagnostic Report and attach the zip file.

Thank you, Daniel. I send attached two diagnostic files. One taken after just opening the score (no sound output) and the other taken after changing back and forth the Halion Sonic 7 output (as mentioned in the first post) where the sound output is restored.
Thanks once more.

Dorico Diagnostics - before going back and forth on Halion Sonic 7 (994.3 KB)
Dorico Diagnostics - after going back and forth on Halion Sonic 7 (994.6 KB)

Thanks for the data @Intini .

From the logs and data I can not tell why you had trouble in the beginning, looks all fine. Is now everything working as it should, or still problems?

Or is it this problem that you are facing?

Thanks, Ulf!
I still have to go back and forth (as described) in the output of Halion Sonic 7 for it to produce sound - this is every time I open a score.

I tried running the fix you mentioned (plugin-presets-installer-win.msi) but sadly it did not change the situation.

Ah, you mean in the HALion window on the Mix tab, you need to reeassign the outputs? How does it look like initially with you? Can you post a screenshot?

Thanks once more.
HALion has all channels, including the only one that I am using (channel 1) set to Main. Please see the attached screenshot.
All I do is change the output of channel 1 to Out 2 and I already get sound. Then I change it back to Main and I still get sound. Just going back and forth solves the issue. Maybe some initialization file that Halion is reading that may be broken?

Thanks, I see now. Yes, indeed, must be the initialization patch of HALion Sonic that got corrupted or is missing. I don’t know right now where that would be, but I’ll find out and come back.

Thank you so much, Ulf! That would be fantastic.
For the records, I tried re-installing Halion Sonic 7 from the Download Manager but it did not solve the issue.

What is in the folder C:\Program Files\Steinberg\Dorico5\playback\DefaultPluginStates with you?

Hi, Ulf.
I attached the files in the mentioned folder. (1.7 MB)

Yes, I have the same ones. There must be something more to it then…
How do you create new projects, via the piano template or just an empty one and then add player(s)?

Ok. Well, I just used the opening Hub, then selected the tab “Create New”, then selected “Solo”, then “Solo piano”.

Then I’m running out of steam and need to ask @dspreadbury for maybe some more ideas.

It looks like perhaps you have saved your own default state for the HALion Sonic 7 plug-in – the preset drop-down at the top of your screenshot seems to show a user-defined name. I’m not sure how to get rid of this preset, but that would be the next thing I would try.

@Intini , have a look under C:\Users\[yourusername]\Documents\VST3 Presets\Steinberg Media Technologies\HALion Sonic
That’s where the user presets of HALion Sonic get saved. If you have a preset there, move it out and see if then the default plug-in state gets used again.

Thanks, Daniel and Ulf.
I am sorry for the delay in replying - I am in a different time zone.

The mentioned folder “VST3 Presets” has nothing in it at the location mentioned.

I located another “VST3 Presets” folder with that has the mentioned subfolder “Steinberg Media Technologies” (at D:\OneDrive\Documents) that has two subfolders “Halion Sonic” and “Halion Sonic SE”, but both are empty folders, too.

Another information that could be useful: When using Dorico 4.3 Pro, everything works fine. Another possibility, could perhaps Dorico 5.1 have some audio routing issue when instantiating Halion Sonic? Some parameter not initialized (audio outs)?