Dorico 5 and Swedish Characters

Working on a Swedish choir piece and I suspect that it’s the use of ä, ö in filenames, that makes Dorico 5 crash. This particular file has crashed 6 times, never happened before:

Is there a solution?

I’d be surprised if that in itself could cause Dorico to crash. After all, my arrangement of Gläns över Sjö och Strand has never crashed and there must be countless German files for instance using the same characters in the filename. Is there a particular place or situation in which it crashes? Are there for instance any keyboard shortcuts which are not working because of the different keyboard mapping or conflicts. Do other files using these characters crash (if you don’t have any then simply create a new version with the Swedish characters in the filename for testing purposes).

Have you tried renaming the file, just as a test?

Are you saving to a cloud storage? Some of those give trouble.

Have you tried replacing the ä with an æ? It has the added benefit of looking much more civilised :wink:

Edit: joke aside, I try avoiding non-ascii characters when i can. Usually for most programmes everything works perfectly, but then you have the fun little random hiccups that straight up destroy the file (or more commonly refuses to load or similar). Have you tried ctrlVing everything to a new file, or making a copy?

Well I don’t quite understand your response. The video shows exactly where the crash occurs, and it happens over and over again. Trying to edit the “recipe” and then clicking “ok”. Crash :wink:
Dorico doesn’t like that filename, what could else be the reason?
I use a extensive Metagrid Pro set-up and have been working with Dorico full-time as a copyist/composer/arranger since ver. 1 and I have never experienced this before. That’s why I wonder if filenames with , and ? + Swedish characters could be the reason.

I have all my scores locally, I will try to save it with another name, and yes I have never experienced this with Danish characters :wink:

Thanks a lot for your interest.

1 Like

ok, if you show the video in YouTube and in full screen and you manage to get it sharp then you can see that it crashes when you try to save an edit to the filename recipe when trying to do a .pdf export. That’s something pretty specific which you could have said at the outset. I tried to replicate this with my own file but didn’t have the same problem. So you need to be a bit clearer a) whether it only crashes this particular file b) if it only crashes when trying to edit the recipe or does it also crash when just exporting to .pdf without editing the recipe and c) as already suggested if any affected files are renamed if the problem still occurs?

What is a “recipe”?

Mac or Windows? What regional setting?

On Windows you cannot use ‘?’ in a filename. Refer here:

As to ‘Swedish’ characters, aren’t they just accented characters as found in German and many European languages? Is there some unique character in Swedish?

I don’t know anything about Mac.

You have not said Mac or Windows yet. From the vid it looks like Windows.

On my Windows 11 system I can save the following filename with no crash: “äëüö.dorico”. But I cannot save a file with ‘?’ in it. I think your title has a question mark. The Microsoft guidelines I linked to are very clear on this point. So I can’t see how you saved the file in the first place if it has the name shown in the title in the video. That would be weird.

You said it is only this file. That would indicate you have gremlins in the name - unintentional invisible control characters for example.

Again, what special characters does Swedish have that distinguish it from other languages? Isn’t the language fully covered by Unicode?

Post the file here for others to duplicate the error?

Trying to learn more about this, from Wiki:

The Swedish alphabet (Swedish: Svenska alfabetet ) is a basic element of the Latin writing system used for the Swedish language. The 29 letters of this alphabet are the modern 26-letter basic Latin alphabet (A to Z) plus Å, Ä, and Ö, in that order. It contains 20 consonants and 9 vowels (a e i o u y å ä ö).

That means standard Unicode covers it, and that these are all valid characters for Windows filenames. So it’s gremlins or something else unique to that file. I cant get Dorico 5 to crash with any of those characters.

the only character in Swedish which is not found in German is å and this is not found in the actual filename. Agreed that if it’s really only one file which shows the problem, it might be useful if this was posted!

I’m betting it’s a question mark. What is the filename? The OP has not yet stated. It’s not necessarily the song title.

OK. Even with å in the filename I cannot reproduce this crash. We need the project file in order to help.

I imagined that the video would be self-explanatory, agreed it’s a screen recording from a 43 inch but on YouTube it’s okay sharp I think.
No it’s not Windows it’s a Mac, I also thought that would be obvious from the screen recording.
And no there are no conflicts in key commands, and yes only this file is not working, and no it doesn’t crash exporting to PDF and I don’t understand this:

I don’t often post files in this forum, I have send it to Daniel and hope he can suggest something.
In the meantime I have changed the file name and the changed it back again and now it works.

Then that’s gremlins, as I suspected. Invisible control characters unintentionally there. Isn’t the issue now solved then? So what was the filename, may I ask again?

This is interesting and I have learned a little about Swedish.

Please do Help > Create Diagnostic Report and attach the resulting diagnostic file here. It might also be necessary for you to provide us with the actual project file, but I’ll let you know that once I’ve seen the diagnostics.

After fiddling around with the file yesterday evening I no longer have the crash, so no diagnostic report, sorry.
But I may have found the reason, that Dorico choke.

From this screenshot it’s clear that the name of the project contains the ? in the end. Nevertheless is the line next to the preview WITHOUT the ?, here and replaced by two dashes.
I have tried with another project named Test? and it also leaves out the question mark in the title and the named of the exported pdf is Test- -.
So: The project is okay with the question mark, but the exported flows will not inherit the ?

Regards Stig

The diagnostic reports keep track of the ten last crashes, so I don’t understand this statement. Please send those when they’re kindly requested, unless you specifically don’t want to solve the problem :wink:

1 Like