Dorico 5 : Black screen

Congrats with the update !! Looks great. I might stumbled upon a bug. Clicking on ‘velocity’, left under in the key-editor results in an almost black screen. I’m on Mac Montery.

This has unfortunately always been true since the introduction of the new Key Editor in Dorico 4. This menu is (for boring technical reasons) actually a whole new window, and when the parent window (the project window with its embedded Key Editor) is full screen, this new menu “window” also becomes full screen. We’ll be able to fix this when we can eventually use the same UI framework for all of the controls in the main Dorico project window, but unfortunately we’re not there yet.

when I click the tempo button to set the playback tempo and then click the tempo display the formerly small window for setting the tempo opens in fullscreen mode. It shows just the knob to set the tempo without a scale or any numerical information. I have to close this fullscreen window and reactivate the main application window. This happens on a Mac Studio (Ventura 13.4).

@jazztom, this happens for the same reason as described above when using the main project window in full screen mode.

Thanks, yes, I noticed that it was a full screen thing, rather than a version 5 issue. Impressed by pitch contour emphasis en stage template. I’m working on a piano-duo piece now and although I added a lot of dynamic markings in the score, the pitch contour emphasis makes it much more lively!!

1 Like

Thanks Daniel, understood. I’m wondering why I didn’t have this issue in Dorico 4. I checked the preferences and found that in Dorico 4 the “open new windows maximized” option was unticked whereas it was ticked by default in Dorico 5. Could this be the reason that the issue never occurred to me in Dorico 4?

No, the same issue would definitely have occurred in Dorico 4, although maybe not for precisely the same menus and pop-ups. I’ve had another chat with one of my clever colleagues in the team, and he thinks he’ll be able to do something to improve the situation in a forthcoming update. In the meantime, I would suggest just running the project window at the size of the full display, rather than actually in full screen mode.

When Dorico is in full screen mode clicking the tempo slider results in full screen slider.
(macOS Ventura)