Dorico 5 draws time signatures differently

Dorico 5 draws time signatures slightly too far apart vertically compared to Dorico 4 when using Bravura as the music font. I have tested this in a fresh, full factory setting project and it is still the case. It’s quite noticeable with 3/4.

The left and centre are Dorico 5, and the right is Dorico 4. Noticed the gap above the 4 in the first two images.

Yes, this was reported a couple of weeks ago just after Dorico 5 was released. I’m reasonably sure that the new version of Qt that Dorico 5 is built upon is responsible, but we don’t have a solution as yet.

1 Like

Well for whatever it’s worth I prefer the gap. To me the third example looks too crowded.

I also prefer the numerals between the staff lines and not overlapping with them, as this is what I am used to seeing in plate engravings and I think it’s more legible. So I was delighted when I first got 3.5 to see I could easily change my defaults to a slightly smaller point size and space between!

And I could accommodate this difference in 5 in the same way – but if it affects documents saved by previous versions, that’s a problem. Even worse if it affects the line spacing of all multi-line text.

It’s curious that while the 4 stays in the same position in all three examples, the gap between the upper and lower number is bigger for the 3 than for the 5 in the Dorico 5 examples. And. the 3 appears to be shifted upward more than the 5 and has run over the top line of the staff.

I think that best would be that the numbers touch the staff lines without overlapping any of them. Thus the 4 would just touch the bottom line and not sit in the middle of it.

It’s just a bug in the rendering, everybody. While Dorico allows you to define gaps between time signature digits if you want them, by default it’s certainly not meant to move only the numerator and by a different amount at different staff sizes. It’s a rounding error introduced in the new version of the Qt framework, and we will find a fix for it.


Any idea about the date? I have several scores ready to print. I’m wondering if I should wait?

Yes, you should wait. The update is coming soon.


I thought exactly the same. Can we request this “bug” not be fixed?

It is a bug, and Daniel has already stated it is going to be fixed in the next update. He also said there is a setting to control the gap between the numbers.

If you want a gap between the numbers, go to Engraving Options, Time Signatures, Gaps, Vertical Gaps, Gap between numerator and denominator for time signatures on every staff and increase that value.


This has been fixed in the new 5.0.20 update. Just in time for a deadline I had on a project! Thanks for getting this fixed.

The best support in the whole wide world!!! Thanks!