Dorico 5 lost connection to MIDI keyboard

I have been working on an arrangement each evening this week, always in Dorico 5. This evening, Dorico 5 refused to recognize my MIDI keyboard (Nektar Panorama). I did a complete power-off cycle. No joy.

The keyboard worked fine in D4, Cubase and Halion SE stand-alone.

In D5, I created a new score with just a piano staff. That did recognize the keyboard, but seemed to take about 30 MIDI key presses before notes started. When I discarded that file and re-opened my real project, still no keyboard access no matter how many MIDI notes I sent.
I noticed that the “10” update was available, and updated to that version. It didn’t make a difference.

I noticed that Groove Agent SE also displayed that my license had expired. I am using a 30-day trial to the Simon Phillips collection. That license should be good another 27 days.

Ultimately, I went into PLAY and re-applied the playback template. That cleared up the problem.

And after another restart, the GASE license warning stopped appearing.

If you’re not aware of this other thread I’m working on a Percussion Map for the Simon Phillips pack. Otherwise attaching a error dump would be a good idea (Help-> …)

1 Like

Dorico 5 has currently a big bug in the MIDI area. Even 5.0.10 still has it. Good news is, yesterday we fixed it and we will try to get a new version out as soon as possible.


Terrific. I look forward to that solution.

Apart from that., I find D5 a big step forward, and the new ability in 5.0.10 to scrub only the tracks that have selections is another nice feature.

1 Like

Hi Ulf,
When would that be? I have an old m-audio key station 88 and I cannot input any notes in Dorico right now. I’m on deadlines and this is not fun at all. It worked in 5 but not in 5.0.10

Did you try running the playback template? That cleared it up for me.

Didn’t work. Actually, the connection restalished itself for a few minutes, than disappeared again. I ran the playback template after to no avail.

Then the playback template probably didn’t do anything for me either. It was probably just coincidence. It does seem rather random.