Dorico 5 very slow to load

Upgraded on my older Windows 10 machine with no issues so far and every reason to be pleased with the upgrade, but on my higher spec Windows 11 machine the upgraded Dorico takes several minutes (more than 5) to load. After the upgrade Dorico 4 also loads very slowly (over 10 minutes).
How do I fixe this - what do you need to help me fix it?

Does this happen every time you start Dorico 5, or was it just the first time? Dorico needs to scan your VST instruments etc. the first time it starts up, but after that it should run up more quickly.

1 Like

Thanks for that
I have rebooted and tried it again - the stopwatch is currently reading over 5 minutes with the only evidence of activity being a Dorico entry in the Task Manager

Thanks – I guess the issue might be that the audio engine is unable to start and Dorico is waiting for it. Can you please install Process Explorer and see whether the VSTAudioEngine.exe process is running?

After 15 minutes it finally loaded the Hub, VSTAudioEgine showing as running (Actually took over 15 minutes to load). Simple tasks such as removing a Project from the Hub take e very long time and leave the Hub frozen. FYI Dorico 4 also taking longer - staying for a long time on Initializing UI

Just tried it again - now reached the Flash Screen - Wait for audio engine intialization.
VSTAudioEngine5.exe showing in Proc Explorer

Now reading Parsing of online version check failed

That definitely sounds like the audio engine is having problems. Can you try quitting Dorico and the VSTAudioEngine process again, then start up, and once it’s running do Help > Create Diagnostic Report and attach the resulting zip file here?

Dorico (165.8 KB)
I really hope this helps!

This morning I used the SDA to “Install Again”
Still slow to load
Closed it
Ran it As Administrator - said yes to question “Allow program to make changes” very fast to load!
Closed it
Loaded as normal (ie. not run as admin)
Very fast to load

Looks like the problem is “fixed” - but how did that happen -was it the re-install or the Run As Admin?

I’m afraid I don’t know – but I’m glad you’re up and running now.