Dorico 5 very sluggish with M2 Ultra Mac Studio with 128 GB ram

Apologies if this has been covered. I’ve tried it both in Rosetta and without and am using the latest version of Dorico 5. Has anyone experienced this and are there any workarounds? I’m finding it will randomly pause when I’m trying to do things (entering text, moving the screen left or right, etc.) and it’s getting very frustrating. Thanks for any help!

Is this all projects, or just some? Are they particularly large? Is Condensing On? Have you got huge audio VSTs running?

As ever, send a project file to Daniel or Ulf , and see what they can make of it.

(Rosetta isn’t going to make things faster!)

Do you perhaps have auto-save set to a very short interval in Preferences? Try temporarily disabling auto-save to see if that helps matters.

I did have autosave set to every 1 minute as I work fast and don’t want to lose anything in the event of a crash. But you’re saying that even with a crazy-fast computer (and internal drive, etc.) this would still slow things down potentially in the manner described? (just checking). I’ll try setting to every 4 min to see if it helps. And to answer benwiggy: it appears to be in more than 1 project but when I next notice it I’ll send the file along. Thanks!

Another thing you might try if you want to leave auto-save turned on is to turn off “Generate preview thumbnails when saving” in Project Info. For some longer projects the thumbnail generation can turn out be quite time-consuming.

Just an update: it definitely happens but is difficult to reproduce. For example, I opened a 5 min-song length document and tried entering chord symbols; it kept getting “stuck” and then after a pause would show the keys I had vainly been trying to type all at once. I’m using only Note Performer 4; it’s a brand new computer keyboard (and computer)… I tried re-producing but couldn’t. Another thing I noticed that I’m curious if anyone else can re-produce: when I try doing sideways scrolling (either by using my Mighty Mouse or a 3rd party mouse with shift held down): on Logic Pro it works fine and indefinitely. However, in Dorico Pro 5, after it initially works it stops responding predictably after I keep the shift button down and continue scrolling left-right (by moving my mouse up/down) for a while (a similar “start/stop” behavior that I’ve generally been experiencing)…Not sure what’s up with that…I’ve gone ahead and sent the file in question to the “team”…

  • D.D.

FWIW, I have a Mini with an M2 Pro and 32Gb RAM, and I haven’t witnessed any pauses or ‘stuck-ness’. I have auto-save set to every 6 mins.

1 Like

I’ve certainly experienced such laggy experience this week. Something is wrong when I have Dorico 5 and SpectraLayers 10 open at the same time. Would that be a clue? (I don’t have an M2, only a MacBook Pro 16" from 2019 with 32GB Ram)

Another update! The specific “chord lag upon entry” issue ONLY happens when I try to enter chords in “Galley View” - it seems fine in “Pages” view…Hopefully this help narrows the issue down…

1 Like

I have a lowly m1 mini (the original) with only 16gb ram and even I don’t experience slow downs like this, although I will admit my scores tend to be rather modest in scale.

I, too, have a Mac Studio Ultra, though with 64gb. I haven’t found any such problems. My current projects are small-scale chamber music so no condensing and I’m not bothered about playback. I’m happy to try any project on my machine if you want to share something…

1 Like

[Just an update!] Daniel and Paul both kindly got back to me and couldn’t repeat the problem I’m having (which means it’s thankfully not something that’s affecting more people). In my case, I’m starting to take a look at other recently added elements to my system - in particular my Keychron V6 external keyboard which I’ve been using with the Better Touch Tool app (the latter so I can retain a “fine volume up/down key” that seems to not be working anymore otherwise - it’s normally shift-option volume up/down function keys on a Mac as people may know). I’m theorizing that perhaps one of both of these items are causing the slowdown as it seems to improve when I close in particular Better Touch Tool. I will definitely keep experimenting and see what might be causing this (curious if anyone else has ever had issues like this who also use either the BetterTouchTool app or the Keychron keyboard).

Thanks again -

  • D.D.

Shift-Option-volume and brightness are still working for me! Monterey 12.6.
Oh, I hope Apple hasn’t broken it. I use BetterTouchTool, mostly for trackpad gestures.

Sounds like you might have run into a midi loop?

I’m curious - can you elaborate?

  • D.D.
1 Like

search “midi loop” in the dorico forum and you’ll see a number of results.

In brief: some setups end up with a feedback loop where the midi messages start to battle each other (on & off signals pinging back and forth between the keyboard and computer triggering additional events because they are being interpreted incorrectly) and this torrent of traffic drastically slows down the program. You can tell this is happening if the little green light in the bottom right of the Dorico screen stays constantly lit, rather than simply flashing when you press a key.


Don’t think that was it I’m afraid but thanks for the thought.