Dorico and the USB-eLicenser often not talking together

I have had this problem for some time now, and though I can get Dorico up and running by doing some restarts + eLicinser maintenance, it is frustrating that I can’t trust Dorico to work every time.

To solve the problem, I usually do a restart, then open the eLicencer Control Center (version and click maintenance, wait for it to complete, then a restart, then open Dorico ( again. Usually that gets Dorico up and running again. Sometimes I have experienced that I can skip the second restart, but you never know, so it is safest to restart twice, it seems.

My USB-eLicencer is the new type, I guess (short). I have seen that some with similar problem have been told to get a new (short) dongle. A while ago I ordered two new eLicencer control devices (dongles) in case I would have to use the “zero downtime trick”. Would it be smart for me to try to get rid of the old dongle and use one of the new ones anyway?

I would very much like to get help, please ask for information you need and I’ll try to give you precise answers.

MacOS Mojave
Version 10.14.6

Is the USB-eLicenser attached directly to your computer, or via a USB hub? Try connecting it directly to the computer if you can. If you also have an older, longer USB-eLicenser connected to your computer, disconnect that one, even if your Dorico license isn’t on there.

It worked now when I connected the USB-eLicencer directly to the computer. Running out of USB-ports thogh … now I have to use the port on the write-keyboard for the printer! Thank you - hope it keeps working. I’ll test a little… Hope you get notified if I continue here later for more help on the same issue.

Yes, if you post again, I’ll see it, don’t worry. Though I fear I won’t be able to offer much in the way of assistance, I will certainly try.

Hm. Now it happened again. Only difference this time was that it was a bit longer since I used Dorico, and in the meantime I have been working for some hours in Logic Pro X. Message on screen this time: eLicencer Control - Error; Application ‘Media Service’ has caused the following error: The Soft-eLicencer threw an unknown exception. Options: - Click to abort. (Sometimes it’s another message, like: eLicenser Control - Error; Application ‘Dorico LE 3’ has caused the following error: Connection to protection device lost. Options: …(Help/Retry/Cancel). Strange since I don’t have Dorico LE! Another message in these situations is: eLicencer Control - Error; Application ‘LCC2’ has caused the following error: Application ‘’ could not be started. Probably the file is corrupted or incompatible, or file access permissions are set incorrectly. Please download and install the latest version of the eLicencer Control software from http:… (I have done that a few times, I guess)). To me it seems random what kind of message I get when - but probably it’s not…
Does this give you any clue?

I restarted my computer, and launced the eLicencer Control Center. Now something is missing in the window; In the coloumn to the left under “My Licences” there’s only a number with the text “Soft-eLicencer (SeL)” under. There used to be something “USB-ish” also, but that seemes to have disappeared. (?) (I’ve done the Maintenance, with all OK…

If you’re not seeing the USB-eLicenser in the list of licensers on the left-hand side of eLicenser Control Center, that is certainly significant: if the USB-eLicenser is not detected by eLCC, it won’t be detected by Dorico either. It certainly seems that your problem is primarily an issue of intermittent communication failure between your computer and your USB-eLicenser.

What often works for me is, when I see the dialog, I unplug my new USB key from the port on the computer, plug it back in, and then click Retry.


Yes, Leigh, that worked here too. Thanks! And Daniel (or others); Is there a chance that this intermittent communication failure could be solved if I transfer my licence to a new usb device, even though it seems to be of exactly the same kind as my old one?

If you’re already using one of the new, stubby ones, I don’t think you have anything to gain by switching to a different one. Just try to keep it plugged in directly to a USB port on your computer rather than via a hub.

If you’re out of USB ports you might consider using a powered USB port hub instead of an unpowered USB port hub.