Dorico assigning wrong VST to just created VST's

  1. I set up a new Big Band project
  2. Add a clarinet
  3. It gets assigned to default Note Performer, but isn’t sounding when played (a problem I’ve mentioned before)
  4. Decide to assign to BBCSO, add a BBCSO VST which comes up with the proper BBC interface, which I close
  5. Hit the ‘e’ button to bring it up, it brings up Note Performer - can’t get it out of this

Weird huh? Here’s proof


Frustrating, just trying to get some work done and keep running into issues - any ideas? Totally fine if user error but I’m not seeing it

Error.dorico (694.3 KB)

Not happening for me, Dan,

I’ve walked through the steps you’ve posted - the only difference was that I had to assign Note Performer (it’s not automatically loaded) after loading the Dorico BB Template - and before I added the clarinet. The clarinet did play back OK from NP. When I added the BBCSO VST it all worked as it should…

ETA: I loaded up your file. What’s happening here? NotePerformer 64? I just get two instances of NotePerformer.

Note Performer 64?

NotePerformer has 16 MIDI channels set so is maxed, per OP when I added the clarinet it added a second NP instance - NotePerformer64 (later I deleted it and reloaded it trying to get things to work). The clarinet should route to that channel 1 - but NP doesn’t figure it out. That’s when I gave up and tried adding BBCSO - which was fine but led to the second problem per OP that it brings up the wrong VST.

Doing this from scratch on your machine won’t help which is why I included the project, if you have these VST’s, when you click on ‘e’ for BBCSO what does it bring up?

I keep getting into these internal rewiring issues with recent versions, don’t know what’s going on.

It’s not clickable under the Track Inspector and when I click on it under VST and Midi it bring up the NotePerformer 3 window (click here to learn more…)

If I do what you’ve done, the Big Band template opens up two instances of NotePerformer - the 17th track (2nd instance) being DrumSet (Sticks). The 18th track is then the added Clarinet. I don’t know what NotePerformer64 is, or why NotePerformer would bring up two different named instances of its VST. NotePerformer64 is not listed under Wallander Instruments as a VST for me. Is it for you?

Your file is misbehaving for me - I’ve just seen an NP window appear without clicking on anything. Also, when I go back to the Play page and click on things, it’s very sluggish.

I’m wondering whether the problem isn’t your drums track. It doesn’t load in the NP VST’s. Is there something in that track, or the way you’ve set up that track, that NP is struggling with?

ETA: On second thoughts, maybe not - maybe it’s just that it’s the 17th track and Note Performer is having a problem with loading the next VST.

If - using your file - I reset the Playback Template to Silence and then set it again to NotePerformer all works just as it should for me. Is that the case for you, too? If not, I’d be tempted to reinstall NotePerformer and see if that fixes it.

1 Like

Thank you David! That works fine … I keep forgetting about the Playback Templates because they’re under Play and not Library, I wonder why they are there? Anyhow, that fixed it. OK so lesson learned, the VST system can get wedged but the easy fix is just to reset it via the Playback Templates and it’ll sort out.

1 Like

Realized the answer to my own question, the Templates are under Play because they aren’t available unless the Playback engine is running, Library is for always available settings. Or maybe not, I’m not sure now, anyhow …