Dorico beach balls w/ IAC endpoint setup

macOS 10.15.7 / Dorico 4.1.10.1082

  1. Create an IAC device in Mac Audio Midi Setup
  2. Open another audio application (e.g. Reaper) and create a track with IAC input
  3. Create an empty Dorico project, choose Silence playback template
  4. Add a sketch treble instrument, input some notes
  5. Go to play mode, add the IAC driver to VST Rack MIDI instruments
  6. Route the treble instrument to the IAC device
  7. Play the project

At this point, Dorico successfully plays the project. However, it does not play any notes while inputting them - it will only play back notes that have been input. I believe the endpoint needs to be configured with the channel and assigned instruments to audition them while inputting (play notes during input and MIDI thru are both enabled).

Also, I’d like to save the endpoint so that I can add it to a playback template and reuse it later.

  1. Click the gear icon next to IAC device to open endpoint setup
  2. Set number of MIDI channels - Dorico will automatically create a line for the treble instrument on channel 1
  3. Navigate notes in Write - they still play back fine
  4. Press play…
  5. Beach ball of death

Note: I have used this exact setup successfully in the past. I’m not sure exactly when it stopped working, only that it’s not working now.

Edit: I notice that if I add a VST instrument rather than a MIDI instrument, and set the track to use that instrument, the Endpoint Setup is already configured with the channel and assigned instrument. I tried using another inter-application MIDI device (Renoise midi-in) and got the same beach ball behavior. So it seems that perhaps there’s something wrong with endpoint configuration with MIDI instruments generally, not IAC specifically.

That’s usually caused by an “infinite loop” - Dorico is sending out MIDI signals and then receiving the same signals. Make sure that IAC isn’t an input in Preferences.

If that’s it, I don’t think it’s my fault:

Alright I am seeing something weird in 4.1.10… I’ve done a bunch more experimentation, here’s what I found:

  • IAC worked as expected on a different machine, using 4.0.30 (using qwerty entry, as I don’t have a MIDI keyboard there)
  • IAC also worked on that machine using 4.1.10
  • 4.0.30 worked fine on the original machine as well
  • 4.1.10 partially worked on original machine, after running 4.0.30 first - it didn’t crash, but it would not trigger MIDI notes when entering. It did trigger notes with qwerty entry.
  • saving an endpoint and loading the playback template works on 4.0.30
  • saving an endpoint and loading the playback template beach balls on 4.1.10
  • 4.1.10 also beach balls when playing a document that works in 4.0.30

I’m not sure what other useful info I can provide (I emailed a diagnostic zip to @dspreadbury earlier).

In the mean time, I will continue to use 4.0.30, which isn’t giving me any trouble.

Here’s a doc created in 4.0.30 that plays fine, but beach balls on 4.1.10. Spoiler: it’s a single note for a single instrument routed to IAC.

795830-example.dorico.zip (399.1 KB)