Dorico - Chord Symbol Bug

Hi everyone :slight_smile:

I think Dorico - in the case of the chord detection of a dominant chord with a ninth (in this case its F9) - shows the wrong Chord Symbol in the bottom line of the program (if you select all notes of the chord).
It says “Fmaj9”, but that would be with a major 7th (E), not (Eb), right?
Or am I wrong here?

I think I understand what’s going on. In the bottom program line it looks like the upper-case Maj refers to the 7th and the lower-case maj refers to the 3rd…
Because it displays an “Ebmaj9” chord as “EbmajMaj9”… :slight_smile:

But isn’t that totally confusing??? :stuck_out_tongue:



What do you have selected here?

“None” is really the only useful selection IMO. Dorico creates a dominant chord by appending a 7 to whatever your setting is for a major triad. As a result, “none” is the only practical choice unfortunately, as anything else will give incorrect chord symbols as you’ve discovered. Switch your major triad setting to “none” and see if that fixes it.

Lukas, your observations are correct. I’m not sure what else we can do, except perhaps not label major triads with “maj”, but I think that would also be unclear.

I know this has come up before, but it would be great if this could be fixed so all of the “appearance of major triads” options are valid. It is very unintuitive to a new user that selecting “Bbmaj” as the option for a major triad will result in all mixolydian chord symbols appearing incorrectly. As far as I can tell, there is nothing in the program itself or the documentation warning the user about this.

Off the top of my head there are some modal minor tunes like So What, Impressions, etc., and a handful of tunes with only major chords like The Creator Has a Master Plan, Thembi, etc., but almost every other tune I can think of will have a mixolydian chord at some point, which Dorico will display incorrectly with anything other than “None” selected. I would guess if you opened any real book and counted the number of compositions without a mixolydian chord, it would easily be less than 1%. That means any option other than “None” will result in Dorico incorrectly rendering mixolydian chords in probably 99% of all compositions! For something that is that much of a potential catastrophe if it actually makes it on to a player’s stand, it seems like it should either be fixed or very well documented, perhaps with text alerting the user right under the selection in “appearance of major triads.”

Lukas is talking about the display of the chord symbol in the status bar at the bottom of the window, which doesn’t follow the engraving options settings in any case.

Oh, I thought he was using the MIDI keyboard for chord entry and that’s what was displaying, not just clicking a chord voicing. Sorry. Anyway, just because I’m procrastinating, I flipped through the New Real Book Vol 1, and out of 234 compositions there were 13 that didn’t have a mixolydian chord. I was off in my 99% assertion above, but it is 95%. As changing this setting to anything other than “none” would affect 19 out of 20 tunes on average, it would be great if this could be fixed.

Hi Daniel :slight_smile:
Thank you for your answer.

Why would it be unclear then? I don’t understand that.
Why cant you just use the standard chord symbols in the status bar as well?

In my understanding major (3rd) chords are not labeled any special at all.
It is standard to label minor chords with “Fm”, “Fmin”, “Fmi” or “F-”, augmented chords with “F+”, “F#5” or “Faug” and diminished chords with “Fdim” or F°".

When there is a 7th, a normal “7” means always the b7 in the scale. If it is a Major Chord with a major 7 then you would write “Fmaj7”, “FM7” (but that one is bad because it’s easier to confuse it with “Fm7” which means a minor triad with b7) or “F△7”…
If you have a case where you have to use two “min/maj” labels at the same time and you are not able to write it as superscript, you can use Parentheses e.g.“Fm(maj7)”.

And if there is a 9th, 11th or 13th, you just hide the 7th but it is still included and e.g. in “Fmaj9” the “maj” still refers to the 7th, so it’s F A C E G.
You alter 9ths, 11ths and 13ths with a “#” or a “b”.

Sorry, but I don’t know why there should be a problem to label chords correct in that bar, when they can be labeled correct in the score itself. :stuck_out_tongue: :slight_smile:

I think the chord detection works, it seems to me as if it’s just a little bit of formatting that’s gone wrong.

Thank you for your answer :slight_smile:


A little suggestion by the way:

If you use Shift+k to insert a new key and you write e.g. “Fm”, it doesn’t work. It just works if you use a lower-case f.
I know that that’s faster because it is just one letter :slight_smile: But I think it’s not a big deal to let also “Fm” etc. work for inserting F minor.


I might be wrong, but I think the answer is that Dorico conceives of the chord name as a triad, and then the 7th and other alterations are amended to the end. As you’ve pointed out, this often results in the nonsensical as in EbmajMaj7, or just flat out wrong as in Fmaj9 for a mixolydian chord. Instead of defaulting to a triad for the first label, Dorico really should consider the chord up through the 7th both for labeling in that bar and also for symbols in the score to avoid these errant labels.

Todd, would I be right in saying, then, that you think that any of the options for the ‘Appearance of major triad’ should always be ignored except when the chord symbol describes a pure major triad?

Yes, at least as it is implemented currently. If I have anything other than None selected, then as soon as I enter a dominant 7th chord Dorico will display it incorrectly as a major 7th, using whatever major triad notation I have selected in that setting.