Dorico conflict with other apps on Mac

I recently bought Dorico Pro 2.2. Huge improvement over what I’ve been using (Notion). However, I’m having problems with other apps since installing it. StudioOne 4 Pro, and Logic Pro X will no longer record audio. I can playback audio on those aps, create an audio track and click the record button, the level meter responds to incoming audio but when I try to record, nothing gets recorded. I know this is being caused by the installation of Dorico because while using the Demo version, it first happened. I deleted all the steinberg stuff, and the DAW aps returned to normal behavior. Then I tried again to install Dorico and everything continued working, now suddenly the problem is back. Can anyone suggest anything?

What OS? How are you bringing in the audio? What is the output?

You have Dorico set to take exclusive control of your sound card. It’s a common question. I think it’s in Preferences.

Type this into a Google search (without the quotes): “dorico audio exclusive

I’m on a Macintosh. OSX Mojave. Input and output on the laptop is through built in audio and on the iMac it is through a Presonus audio interface. Under preferences, I don’t see any “ASIO Generic Low Latency Device”. Also, the problem persists even when Dorico is not running and I did set the option to release the audio when in the background. Didn’t help. Any other ideas?

The exclusive audio thing is a Windows problem.

Are you seeing the same problem on the laptop and iMac?

Can you record audio to any other app? QuickTime Player, Voice Memos, Audacity? Logic has its own settings for audio input device. Have you checked that they are correct?

I’m not sure that Dorico keeps any background audio processes after you’ve quit it, so that might point to something else. Logic records audio for me, even when Dorico is running, so it’s not a universal problem, which suggests that some other factor is the root cause.
Have you checked all your Audio settings in Audio MIDI, and your Presonus drivers, if there are any, and in the apps themselves.

On Mac, the audio hardware is fully multi-client capable, so you don’t need to worry about things like Dorico taking exclusive control of your audio hardware, and indeed I would advise against setting the ‘Suspend audio device in background’ option, as that has been known to cause problems with the software hanging on some systems.

It sounds like maybe the input settings for your other applications have ended up getting changed somehow, though I can’t think of any way in which Dorico itself could be responsible for this. Dorico and its audio engine are both carefully programmed not to interfere with any system settings or indeed with any other software on your computer.

I’ve double checked the audio settings on the other applications and everything appears unchanged. Logic does work OK on the laptop but not the iMac. Studio One is my goto DAW and it doesn’t record anything at all on either computer. In the meantime, I found a workaround. Not one that I’m happy to have to deal with but it does get Studio One working again. I created a separate User account. In that account, Studio One runs just fine. It creates havoc with authorizations on all my numerous plug ins, etc. but I’m trying to work through that so that whenever I need to run Studio One I can just switch to that other user account. Ironically, in that account, Dorico does not work. The included sample scores play OK but anything I create freezes on playback, and there’s no sound.

If a problem behaves differently in different User accounts, then you know that it’s not the installation; it’s not the software itself, but rather some preference or setting in the original user account.
(That could also include conflict with other software that you have set to run automatically as a user preference.)

Don’t “slash and burn” to another user account: test removing selected items from the user Library folder, then login again, and see if anything improves. If not, put the tested items back. In this way, you should be able to pinpoint the exact cause.

When I first encountered this problem was right after I initially installed Dorico Elements. I can’t say for sure that happened upon that installation, but I know it happened approximately at that time. So I uninstalled Dorico and everything related to Steinberg. Nothing else, just the steinberg stuff, installer, dorico, prefs, everything. The problem with Studio One immediately cleared up. Then I reinstalled Dorico and initially all was well. Then the problem returned. I have tried removing other audio related applications that were installed in the last month or two and that did not help. It sure looks like the problem is being caused by something that gets installed along with Dorico. I will keep looking. Because I do not wish to have to rely on separate user accounts for different programs. There are times when I need to run both at the same time.

Addendum to that last post, I should also remind you that when I log in as the new user, Studio One works just fine but Dorico freezes when I try to playback the score. Wouldn’t this suggest that something gets installed to the user account by Dorico that is not in the new user account and this missing item is the culprit? When it is installed, Studio One doesn’t record and when it is not Dorico will not play back? Maybe I’m chasing the wrong fox here but it makes sense to me. It doesn’t seem to be just coincidence that when Dorico is fully functional, Studio One is not and vice versa.

Dorico doesn’t install anything in the current user account. When you run the software, of course various files are created in the user-level Application Support and Preferences folders, but you can delete those files and Dorico will still run. So the problem is not that Dorico is installing something in one user account that is preventing it from running in another one. If Dorico is freezing in your new user account, I’d suggest that’s likely due to a problem with the audio device settings on that account: perhaps check in Edit > Device Setup whether or not the audio device setup is the same in each of the two user accounts.

OK now the plot thickens. So I just logged into my extra user account to see again if I could get Dorico to run. First I checked the device settings and they were the same as the other user. So I tried again to playback a file. The file played but the sound was a measure behind where the cursor was showing. I tried several different files including the same one that wouldn’t play at all, yesterday. Same issue, cursor starts moving a full measure or so before the sound starts. So I close it and go back to check Studio One again and lo and behold it is now refusing to record anything just like on the other user. I’m abandoning the idea of separate users. I’ve deleted the new one since it is no longer working. I submitted a ticket to Steinberg’s support section several days ago and no one has answered. What now?

If the playhead is ahead of the sound, then you’ve got the wrong sample rate chosen in Edit > Device Setup. Try changing it to 44.1kHz instead of 48kHz.

Yes, it was set to 48kHz. I never set it that way, so I suppose it defaults to that on installation. Anyway, I set it to 44.1 and that seems to have resolved the cursor syncing to the audio issue. But I still have the problem with Studio One refusing to record audio. I can get the microphone to work in Studio One but there’s nothing but white noise coming through and the level meter doesn’t respond to sound. When i click record the playhead advances as if a recording is being made but the recording is empty. I am still assuming the problem is related to something that happened when Dorico was installed. Remember, at one point I did delete Dorico, and the problem cleared up, then reinstalled it and the problem came back. I really love Dorico and intend to continue using it no matter what. But I also need Studio One.

I just got myself a trial version of Studio One and here on my iMac they both happily coexist. While playing back a score in Dorico, I can record and playback at the same time in Studio One, no problem.
This suggests to me that it is a problem specific to your setup.
You have a MacBook and an iMac? And exactly the same issue on both of them?

I have had problems on both computers but I wouldn’t say “exactly” the same. On both, there have been issues with attempting to record into Studio One. At first, on the iMac attempting to click the record button on an audio track wouldn’t even work. The button would not turn red. At first, on the MacBook Pro, the button would turn red but then pressing the button to actually begin recording resulted in not even a recorded event being created while on the iMac, the event was created but it was empty. The two systems are not identical setups because I use a Presonus audio interface with iMac and I use the built in audio and mic with the MacBook Pro. As you may have read earlier in the discussion I experienced complete functioning of Studio One on the iMac only after I deleted everything Steinberg related. I’m not sure how it happened but after that I was able to get the laptop to function normally and so I decided it had to do with the installation, reinstalled the program on the iMac and suddenly everything was working. I was happy enough that I upgraded to the Pro version of Dorico and still everything was fine. Then after several days, maybe a week of using Dorico, I had attempted another recording session on the iMac and the problem had returned. I checked again on the MacBook and the problem was back there as well. I ended up creating separate users on both computers and was able to record in Studio One on both computers. Then after a couple days, the problem showed up again on the MacBook. Then yesterday, just for the heck of it, I wanted to do a recording on the iMac and I tried recording using my original user account. Lo and Behold it was working just fine. The problem is still there on the MacBook on which I have tried deleting everything that audio related that had been installed in recent months and it didn’t help. I tried booting it in safe mode and that didn’t help. Yesterday I discovered that when I try to record audio over the mic on the MacBook, the track records the sound of one of the other tracks but refuses to access the built in Microphone. This is new behavior I had not noticed before yesterday. I might suggest continuing to test your setup for a few days and see if the problem shows up after some usage. I’ll be testing the iMac again today to see if the problem comes back. It may seem unlikely, but already I’ve seen the problem come and go without me changing anything. And I’ve seen the problem behave in different ways on both computers. Please believe, I’ve been using Mac computers for 30 years with experience with Finale, Sibelius, Notion, Overture, Encore, plus Logic Pro, Logic Pro X and Studio One 4 professional just to name a few. I’m not a novice and I don’t give up easily, but this problem is becoming more and more frustrating with the passing days. Thanks for trying to help. If the problems persist, I’m going to have to do a clean install of my OS and then add my software, one title at a time to try and isolate if the issue is related to some other application or plug-in or something. But we’re talking many hours of reinstalling everything and I do not wish to go through all that if I can some how avoid it. Not to mention the extra hassle involved with needing a reissue of the activation code for Dorico. Thanks so much for trying to help. Oh yes, I just thought of one other thing I should mention here. When the MacBook has been asleep for awhile and I wake it up and try to start Dorico I usually get a spinning cursor that won’t stop, have to force quit and try again, sometimes I have to try 3 or 4 times before it will start up successfully. I’m not sure but it seems that behavior is worse when iTunes is running and sometimes happens even when the computer has not been asleep since the last session. I have no other applications that behave this way.

Well, I don’t have too much time to play with Studio One, but I tried again and it works fine here.
Also, Dorico does not install anything on Mac that interferes with other programs audio, and it does not run something constantly in the background, so if Dorico is not running, there is nothing of it processing or is in memory.

What I found though (and this is expected) in Studio One, when I go to Song Setup and under Audio I/O Setup untick the input routing, then of course, the play cursor will run, but nothing gets recorded and no event created.
I know, you mentioned you are an experienced user, but I would suggest to check the Studio One preferences and I/O setup.

Thanks for your help. I have everything working OK again right now. It wasn’t a problem with the I/O setup as you suggested, but for the time being, everything seems to be working again.

Dear musicplay,
Would you be a kind fellow Dorician and explain here how you did solve this issue? I admit I’m quite curious about that, but overall, I think that if a user ever stumbles upon this kind of problem, it could help her/him to solve it — that’s why there’s a forum in the first place. Thanks in advance!

I’d love to but I don’t know for sure. Several things have happened. I’ve updated Studio One, I’ve updated Dorico to version 2.2.10 and I’ve plugged and unplugged my headphones (that causes the internal mic to be disabled/enabled). The best I can suggest at this point is that something weird happened with my computer’s audio when I installed. Or possibly it happened when some other application was installed. The reason I didn’t try to document what happened is because I really don’t know for sure. I can tell you for certain that once I updated Dorico I’ve stopped getting the locking up during start up issue (failing to start with cursor spinning forever). At this point I’m just happy everything is running good and diving further into Dorico, learning key commands and building good user habits. The only negative I can point out now is that Dorico really needs to add playback of ornamentations like trills, fall offs, glissandos, bends, open and closed Hi Hat sounds, jazz techniques, etc. But even without those effects it is already the best scoring program I’ve ever used. I’m loving it.