Dorico crashed working on tempi in the Play timeline

Hello all,

I’m working on piece of music where I switch between 2 different tempi. After switching back to Tempo primo I slow down to a fermata, and then I’ve put the “a tempo” mark (with the intention to go back to “Tempo primo”). I needed to alter a bit the tempo around the fermata so I worked in the Play’s time line (see the attached image). After that I saved my work and closed Dorico.

The day after (i.e. today) I’ve opened back my project and played it, and I’ve notice that the “a tempo” was actually playing Tempo second not Tempo primo. So I’ve witched back to the Play’s timeline realising that the tempo after the fermata was indeed slower than the one before it (see the attached image). Then I’ve clicked on the last point in the timeline with the intention of raising it at the right value and Dorico crashed.

I’ve done it again and another crash occurred. Then at the following run of Dorico I’ve saved the diagnostics (attached), but probably I’ve done something slightly differently because I was not able to have a repeatable crash. Instead I’ve solved my tempo problem removing the “a tempo” and placing “Tempo primo” instead, and altering its text to “a tempo”.

Dorico (671 KB)

I have done much the same thing, creating my own a tempo and setting its metronome marking to the specific setting I want the playback to reflect.

The crash when editing tempo marks in Play Mode should be fixed in the next update

Thank you.