Dorico crashes after 10 minutes

Hi,

I’ve just updated to Dorico 3 but I’ve noticed an unexpected behavior while running the program: after about 10 minutes of normal use (without playback) Dorico starts to freeze and become extremely slow. Restarting the software solves the problem, but only for the next 10 minutes. I haven’t encountered such a problem with D2 (Win10). Does someone happen to have an idea what could be the problem?

Thanks,
Augustin

Please provide the diagnostic reports so we can look into it, Augustin. Do Help > Create Diagnostic Report and attach the resulting zip file here.

Is this a large score, and the autosave interval is set to 10 minutes? I switched autosave off in Dorico 2 because of the same problem, working on large projects.

Hi Daniel,
In the meantime, I tried to reproduce the problem. Could you please help me where can I find the zip file? When I click to ‘Create Diagnostic Report’ it seems that nothing happens…

Hi Rob,
The autosave is now set to 5 minutes and I cannot say that it’s a very large score (10 staves, about 200 measures). It is interesting that Dorico doesn’t actually crashes, but freezes for seconds every time I try to imput or edit something.

Thanks,
Augustin

You should find a file DoricoDiagnostics.zip on your desktop

Please find attached the diagnostic files.
Dorico Diagnostics.zip (519 KB)

It looks like auto-save is typically taking about 3.5 seconds, which is the kind of time I would expect with a large project.

Is it possible that you’re getting some kind of MIDI input overflow? Is the green MIDI indicator light in the bottom right-hand corner of the window constantly lit up? Can you check that you don’t have an unwanted input device in the Play page of Preferences that could be causing a MIDI feedback loop?

I can see from the logs that the MIDI input buffer is filling up and Dorico is waiting for the audio engine to process the events, but for some reason the audio engine isn’t doing so.

Could you try following the steps in the playback troubleshooting video from around 12:00 to 14:30, especially the ‘Exclusive mode’ settings and sample rate: https://www.youtube.com/watch?v=5BcPJd92zqU

Dear Paul and Daniel,

Thank you so much for your help, I watched the troubleshooting video and followed the steps, and however I didn’t change any of the settings (everything seemed to be OK), it seems that the problem has disappeared. Today I will work with Dorico again and I will see if it happens again or not.

All best,
Augustin

Uh, the problem has appeared again… I’ve checked the video but everything seem to be OK.

Please do Help > Create Diagnostic Report and provide the latest diagnostics so we can see what might be going on.

Please could you try using the script that’s in this post: https://www.steinberg.net/forums/viewtopic.php?f=246&t=167597&p=899163#p899163 This will give us more detailed information about what’s happening on your system.