Dorico doesn't recognize midi keyboard

I have a Korg K61P midi keyboard that does work with Sibelius, but Dorico does not recognize it. I am running Windows 10 on a PC. I hve just upgraded my Dorico Elements. Hoping you can suggest a solution. I have gone into preferences and advanced options and discovered that Dorico does not recognize that I have a midi device.
Thanks
Stacey Boal

If you go in the Dorico Preferences dialog to the Play tab and scroll down all the way to the Advanced Options and unfold them, is there a checkmark at the item Enable WinRT MIDI with you? If so, untick that one, close the dialog and restart Dorico. Any better then?

Dear Ulf, I went to advanced options, and found ASIO guard checked. WinRT is not checked. What do you suggest? My midi keyboard is connected with a usb cord, not bluetooth.
Thanks
Stacey

Hm, ASIO Guard should make no difference for MIDI.
And what if you do checkmark WinRT? Same situation again? If so, uncheck it again, restart Dorico and then do from the menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Dear Ulf, hoping this will help,
thanks
Stacey

Dorico Diagnostics.zip (417 KB)

Thanks for the data.
That is a bit mysterious: Dorico actually does recognize your K61P, but only as an output device, not the input ports.
So either it is a setting on your K61P, but you say that it works with Sibelius, or - and that is more likely the case - some other program is stealing the input port of your K61P and uses it exclusively. Do you maybe have Sibelius or some other MIDI using app running at the same time.
So please try again from a fresh reboot and only run Dorico, nothing else. Still the same? If so, please post another diagnostics report. Thanks

Hi Ulf, thanks for your patience with this.
I went into background apps. Sibelius was definitely off. It didn’t even show on the list. I switched off all games and and the voice recorder. I rebooted and tried dorico again. Still no response…I can’t find any settings to change on my Korg, and the usb cord is in the only available slot. Now, each time I switch on the Korg, a dialogue appears telling me to install a driver. I click OK and it says the driver is installed. Hoping you can suggest something.
Thanks
Stacey

Dorico Diagnostics.zip (465 KB)

Thanks again for the data. Unfortunately, I have no idea anymore right at this moment. I need to talk Monday to my colleagues and see if someone knows or has something to suggest. Thank you for your patience.

Thanks for quick reply, and staying with it. Still hopeful,
Stacey

In the meantime, one more idea from my side. Could you please install the utility MIDI-OX which you can get from here.
In there choose Options > MIDI Devices. Does your Korg show up as input device?

Hi Ulf, I downloaded Midi-Ox and clicked Options and devices. Results;
Midi inputs
1] K6IP KBD/KNOB
Midi Outputs
1]K61P Sound/CTAL
2]K61P Midi Out
3] Midi mapper
I tried to play the keyboard and it said “no output port open”. Could something be wrong with my computer? It is relatively new. I could take it back to the store that built it.
Thanks
Stacey

Hi Stacey, no, nothing wrong with your computer. Because also MIDI-OX shows the Korg’s input port, it therefore must be a problem on Dorico’s side. As I said, I will talk tomorrow with colleagues and come back as soon as possible.

One more shot before I go to bed…
I compared mine and your preferences and though it should not have an impact on this matter but worth trying out: In your preferences MIDI Thru is disabled. What if you open the Dorico Preferences dialog, go to the Play tab and scroll down and tick the item Enable MIDI Thru, press Apply and restart Dorico, is it still the same?
Good night.

I tried Enable Midi thru, but sadly, it didn’t work. I await tomorrow’s developments.
Thanks
Stacey