Dorico Element 4 no sound and super slow in loading HALion


I just upgraded from Dorico SE 4 to Dorico Element 4 on Windows 11. When I create a new project from template (e.g. String Orchestra), this is no sound in the created project. Then I opened the HALion Sonic SE routing inspector, I noticed no instrument has been set. I tried loading the HSSE (Elements) play template, it seemed to do nothing and failed to set the correct instrument. I also found Dorico to be super slow in opening the HALion interface (took more than 30s on a SSD). I tried following the troubleshooting video to delete the Dorico 4 AudioEngine_64 folder, again it didn’t work. I have also tried reinstalling HALion and it didn’t help either. Also, none of the demo projects playback work.

I don’t think it is the audio device problem as the playback works if I set the VST instrument manually, but I suppose the playback template should automatically assign the correct instrument in most templates?

I have spent the past few hours trying to fix this and am getting really frustrated. Any help will be much appreciated. Attached please find my diagnostic reports. Thank you so much!
Dorico (1.9 MB)

Did everything work OK on Dorico SE???

No, I remember I also needed to set the VST manually…

What do you mean by manually?

What happens if you start Dorico from scratch, create a new piano piece, add a few notes and playback?

In that case, there is no sound…and when I opened the HALion VST interface in the inspector in the play mode, there is no instrument assigned there.

That makes no sense! If you go to play>playback template and select the HSSE(Elements) template instruments should be assigned…

If it doesn’t, sorry that’s beyond my expertise…

Yes! That’s very puzzling…but I think I somehow managed to fix the error now. I uninstalled HALion and removed ALL HALion related folders from my system drive (HALion created lots of folders in many different places) and then I reinstalled the VST again, it seems to be working correctly now. Maybe some setting files are corrupted over the years… Anyway, thank you so much for offering to help!! Much appreciated!

Presumably you have gone to Play and used “Load Sounds for Unassigned Instruments” already and checked your Device Driver under the Edit menu.

Perhaps your should create a Diagnostic Report (in the Help menu), find it on the Desktop, and attach it here.